aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/monitord
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-11-15 23:25:56 +0800
committervanilla <vanilla@FreeBSD.org>2013-11-15 23:25:56 +0800
commitdfd4a475b86c7ed5ad1f668b182af7acfcd37002 (patch)
tree20fbe8868a1fe547d080c245fa4424657eb5c06b /sysutils/monitord
parent94416c1855e1428f781367d897530c6b71333b9c (diff)
downloadfreebsd-ports-gnome-dfd4a475b86c7ed5ad1f668b182af7acfcd37002.tar.gz
freebsd-ports-gnome-dfd4a475b86c7ed5ad1f668b182af7acfcd37002.tar.zst
freebsd-ports-gnome-dfd4a475b86c7ed5ad1f668b182af7acfcd37002.zip
Support STAGEDIR.
Diffstat (limited to 'sysutils/monitord')
-rw-r--r--sysutils/monitord/Makefile7
-rw-r--r--sysutils/monitord/files/patch-Makefile22
-rw-r--r--sysutils/monitord/files/patch-aa21
-rw-r--r--sysutils/monitord/pkg-plist1
4 files changed, 21 insertions, 30 deletions
diff --git a/sysutils/monitord/Makefile b/sysutils/monitord/Makefile
index 264e17928c6d..0327055e9ad7 100644
--- a/sysutils/monitord/Makefile
+++ b/sysutils/monitord/Makefile
@@ -11,16 +11,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Service that restarts other standalone services
USE_RC_SUBR= monitord
-MAN8= monitord.8
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|syslodg|syslogd|' ${WRKSRC}/${MAN8}
+ @${REINPLACE_CMD} -e 's|syslodg|syslogd|' ${WRKSRC}/${PORTNAME}.8
@${REINPLACE_CMD} -e 's|-pipe||' ${WRKSRC}/Makefile
post-install:
@${INSTALL_DATA} ${WRKSRC}/monitord.conf.sample \
- ${PREFIX}/etc/monitord.conf.sample
- @${CAT} ${PKGMESSAGE}
+ ${STAGEDIR}${PREFIX}/etc/monitord.conf.sample
.include <bsd.port.mk>
diff --git a/sysutils/monitord/files/patch-Makefile b/sysutils/monitord/files/patch-Makefile
index 584f3eb6a78c..2309c6eafd1d 100644
--- a/sysutils/monitord/files/patch-Makefile
+++ b/sysutils/monitord/files/patch-Makefile
@@ -1,6 +1,15 @@
---- Makefile.orig Thu Jun 7 13:16:14 2007
-+++ Makefile Thu Jun 7 13:16:41 2007
-@@ -24,8 +24,6 @@
+--- Makefile.orig 2003-08-22 06:36:42.000000000 +0800
++++ Makefile 2013-11-15 23:14:43.000000000 +0800
+@@ -6,7 +6,7 @@ OBJECTS = monitord.o mail.o
+
+ TARGET = monitord
+
+-MANDIR = /usr/local/man
++MANDIR = $(PREFIX)/man
+
+ .SUFFIXES:
+ .SUFFIXES: .c .o
+@@ -24,10 +24,8 @@ clean:
all: $(TARGET)
@@ -8,4 +17,9 @@
- $(CC) $(OBJECTS) -o $(TARGET)
install:
- $(INSTALL) -cs $(TARGET) /usr/local/sbin
+- $(INSTALL) -cs $(TARGET) /usr/local/sbin
+- $(INSTALL) -c $(TARGET).conf.sample /usr/local/etc
+- $(INSTALL) -c $(TARGET).8 $(MANDIR)/man8
++ $(INSTALL) -cs $(TARGET) $(DESTDIR)$(PREFIX)/sbin
++ $(INSTALL) -c $(TARGET).conf.sample $(DESTDIR)$(PREFIX)/etc
++ $(INSTALL) -c $(TARGET).8 $(DESTDIR)$(MANDIR)/man8
diff --git a/sysutils/monitord/files/patch-aa b/sysutils/monitord/files/patch-aa
index 8f2e0b8e1407..e69de29bb2d1 100644
--- a/sysutils/monitord/files/patch-aa
+++ b/sysutils/monitord/files/patch-aa
@@ -1,21 +0,0 @@
---- Makefile.orig Fri Aug 22 06:36:42 2003
-+++ Makefile Fri Aug 22 15:07:34 2003
-@@ -6,7 +6,7 @@
-
- TARGET = monitord
-
--MANDIR = /usr/local/man
-+MANDIR = $(PREFIX)/man
-
- .SUFFIXES:
- .SUFFIXES: .c .o
-@@ -28,6 +28,6 @@
- $(CC) $(OBJECTS) -o $(TARGET)
-
- install:
-- $(INSTALL) -cs $(TARGET) /usr/local/sbin
-- $(INSTALL) -c $(TARGET).conf.sample /usr/local/etc
-- $(INSTALL) -c $(TARGET).8 $(MANDIR)/man8
-+ $(BSD_INSTALL_PROGRAM) $(TARGET) $(PREFIX)/sbin
-+ if [ ! -e $(PREFIX)/etc/$(TARGET).conf.sample ] ; then $(BSD_INSTALL_DATA) $(TARGET).conf.sample $(PREFIX)/etc; fi
-+ $(BSD_INSTALL_MAN) -c $(TARGET).8 $(MANDIR)/man8
diff --git a/sysutils/monitord/pkg-plist b/sysutils/monitord/pkg-plist
index b614b1d21359..d1127ce01db4 100644
--- a/sysutils/monitord/pkg-plist
+++ b/sysutils/monitord/pkg-plist
@@ -1,3 +1,4 @@
@unexec if cmp -s %D/etc/monitord.conf %D/etc/monitord.conf.sample; then rm -f %D/etc/monitord.conf; fi
etc/monitord.conf.sample
+man/man8/monitord.8.gz
sbin/monitord