aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/monitord
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-06-07 18:33:51 +0800
committersat <sat@FreeBSD.org>2007-06-07 18:33:51 +0800
commite97a4a9e731dbb31542a8d4b692cfaef9efa0b3b (patch)
tree208f3e80a543cf57edf606ae536fda25b8e17a95 /sysutils/monitord
parent36b212817084e52a1a1dddc9edbf1922432e3887 (diff)
downloadfreebsd-ports-gnome-e97a4a9e731dbb31542a8d4b692cfaef9efa0b3b.tar.gz
freebsd-ports-gnome-e97a4a9e731dbb31542a8d4b692cfaef9efa0b3b.tar.zst
freebsd-ports-gnome-e97a4a9e731dbb31542a8d4b692cfaef9efa0b3b.zip
- Add an rc.d script
- Minor fixes - Add mirrors Submitted by: Alex Keda <admin@lissyara.su>
Diffstat (limited to 'sysutils/monitord')
-rw-r--r--sysutils/monitord/Makefile5
-rw-r--r--sysutils/monitord/files/monitord.in28
-rw-r--r--sysutils/monitord/files/patch-Makefile11
-rw-r--r--sysutils/monitord/pkg-message4
4 files changed, 47 insertions, 1 deletions
diff --git a/sysutils/monitord/Makefile b/sysutils/monitord/Makefile
index 62c7280a0032..2580a14a9f30 100644
--- a/sysutils/monitord/Makefile
+++ b/sysutils/monitord/Makefile
@@ -9,18 +9,21 @@ PORTNAME= monitord
PORTVERSION= 0.4.1
PORTREVISION= 2
CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.erudition.net/pub/monitord/
+MASTER_SITES= ftp://ftp.erudition.net/pub/monitord/ CENKES
MAINTAINER= ports@FreeBSD.org
COMMENT= Service that restarts other standalone services
+USE_RC_SUBR= monitord
MAN8= monitord.8
post-patch:
@${REINPLACE_CMD} -e 's|syslodg|syslogd|' ${WRKSRC}/${MAN8}
+ @${REINPLACE_CMD} -e 's|-pipe||' ${WRKSRC}/Makefile
post-install:
@${INSTALL_DATA} ${WRKSRC}/monitord.conf.sample \
${PREFIX}/etc/monitord.conf.sample
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/sysutils/monitord/files/monitord.in b/sysutils/monitord/files/monitord.in
new file mode 100644
index 000000000000..f3f658fce00d
--- /dev/null
+++ b/sysutils/monitord/files/monitord.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: monitord
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable monitord:
+#
+# monitord_enable="YES"
+#
+# See monitord(8) for flags.
+#
+
+. %%RC_SUBR%%
+
+name="monitord"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+: ${monitord_enable="NO"}
+: ${monitord_flags="-f %%PREFIX%%/etc/monitord.conf"}
+
+command="%%PREFIX%%/sbin/monitord"
+required_files="%%PREFIX%%/etc/monitord.conf"
+
+run_rc_command "$1"
diff --git a/sysutils/monitord/files/patch-Makefile b/sysutils/monitord/files/patch-Makefile
new file mode 100644
index 000000000000..584f3eb6a78c
--- /dev/null
+++ b/sysutils/monitord/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Thu Jun 7 13:16:14 2007
++++ Makefile Thu Jun 7 13:16:41 2007
+@@ -24,8 +24,6 @@
+
+ all: $(TARGET)
+
+-$(TARGET): $(OBJECTS)
+- $(CC) $(OBJECTS) -o $(TARGET)
+
+ install:
+ $(INSTALL) -cs $(TARGET) /usr/local/sbin
diff --git a/sysutils/monitord/pkg-message b/sysutils/monitord/pkg-message
new file mode 100644
index 000000000000..f22635ee9c2a
--- /dev/null
+++ b/sysutils/monitord/pkg-message
@@ -0,0 +1,4 @@
+=============================================================
+Monitord requires procfs(5). Add this line to your fstab(5):
+proc /proc procfs rw 0 0
+=============================================================