aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ntfsprogs
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2004-05-10 00:06:23 +0800
committernork <nork@FreeBSD.org>2004-05-10 00:06:23 +0800
commit9fb1130cde1628ba2fe8b1a7f19a8f8be6ccf209 (patch)
tree2b2e12b347df2778b492045caca1d9015ef5fe8d /sysutils/ntfsprogs
parent178885a4b1549f8a0f11a6bf0fe450a821f3e049 (diff)
downloadfreebsd-ports-gnome-9fb1130cde1628ba2fe8b1a7f19a8f8be6ccf209.tar.gz
freebsd-ports-gnome-9fb1130cde1628ba2fe8b1a7f19a8f8be6ccf209.tar.zst
freebsd-ports-gnome-9fb1130cde1628ba2fe8b1a7f19a8f8be6ccf209.zip
Add ntfsprogs 1.9.1, utilities and library to manipulate NTFS
partitions. PR: ports/66406 Submitted by: Florent Thoumie <flz@xbsd.org>
Diffstat (limited to 'sysutils/ntfsprogs')
-rw-r--r--sysutils/ntfsprogs/Makefile56
-rw-r--r--sysutils/ntfsprogs/distinfo2
-rw-r--r--sysutils/ntfsprogs/pkg-descr9
-rw-r--r--sysutils/ntfsprogs/pkg-plist46
4 files changed, 113 insertions, 0 deletions
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
new file mode 100644
index 000000000000..eb6e28b25464
--- /dev/null
+++ b/sysutils/ntfsprogs/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: ntfsprogs
+# Date created: May 8 2004
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ntfsprogs
+PORTVERSION= 1.9.1
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= linux-ntfs
+
+MAINTAINER= flz@xbsd.org
+COMMENT= Utilities and library to manipulate NTFS partitions
+
+GNU_CONFIGURE= yes
+USE_GCC= 3.3
+USE_REINPLACE= yes
+
+MAN8= mkntfs.8 \
+ ntfscat.8 \
+ ntfsclone.8 \
+ ntfscluster.8 \
+ ntfsfix.8 \
+ ntfsinfo.8 \
+ ntfslabel.8 \
+ ntfsls.8 \
+ ntfsprogs.8 \
+ ntfsresize.8 \
+ ntfsundelete.8
+
+.if defined(WITH_GNOMEVFS2)
+USE_GNOME= gnomevfs2
+PLIST_SUB= GNOMEVFS2=""
+MAN8+= libntfs-gnomevfs.8
+.else
+CONFIGURE_ARGS= --disable-gnome-vfs
+PLIST_SUB= GNOMEVFS2="@comment "
+.endif
+
+.if !defined(WITH_GNOMEVFS2)
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You can define the following for additional features:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WITH_GNOMEVFS2 - Installs Gnome-VFS-2.0 libntfs interface.
+ @${ECHO_MSG} ""
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^transform.*||' ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/libntfs/Makefile.in \
+ ${WRKSRC}/ntfsprogs/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/sysutils/ntfsprogs/distinfo b/sysutils/ntfsprogs/distinfo
new file mode 100644
index 000000000000..156639961417
--- /dev/null
+++ b/sysutils/ntfsprogs/distinfo
@@ -0,0 +1,2 @@
+MD5 (ntfsprogs-1.9.1.tar.gz) = 6f83d5f06dc542a42adc3325d5c3fb6c
+SIZE (ntfsprogs-1.9.1.tar.gz) = 648665
diff --git a/sysutils/ntfsprogs/pkg-descr b/sysutils/ntfsprogs/pkg-descr
new file mode 100644
index 000000000000..01bab5987b15
--- /dev/null
+++ b/sysutils/ntfsprogs/pkg-descr
@@ -0,0 +1,9 @@
+The goals of this project are: create a new Linux kernel driver for the NTFS
+file system (v1.2 and later 3.0), user space utilities (e.g. format, ntfs
+check, etc.) and a library to avoid code duplication and provide access to
+NTFS to other GPLed programs.
+
+WWW: http://linux-ntfs.sourceforge.net/
+
+- Florent Thoumie
+flz@xbsd.org
diff --git a/sysutils/ntfsprogs/pkg-plist b/sysutils/ntfsprogs/pkg-plist
new file mode 100644
index 000000000000..c67fcc692f88
--- /dev/null
+++ b/sysutils/ntfsprogs/pkg-plist
@@ -0,0 +1,46 @@
+bin/ntfscat
+bin/ntfscluster
+bin/ntfsfix
+bin/ntfsinfo
+bin/ntfsls
+%%GNOMEVFS2%%etc/gnome-vfs-2.0/modules/libntfs.conf
+include/ntfs/attrib.h
+include/ntfs/attrlist.h
+include/ntfs/bitmap.h
+include/ntfs/bootsect.h
+include/ntfs/compat.h
+include/ntfs/compress.h
+include/ntfs/debug.h
+include/ntfs/device.h
+include/ntfs/device_io.h
+include/ntfs/dir.h
+include/ntfs/endians.h
+include/ntfs/gnome-vfs-method.h
+include/ntfs/gnome-vfs-module.h
+include/ntfs/inode.h
+include/ntfs/layout.h
+include/ntfs/lcnalloc.h
+include/ntfs/list.h
+include/ntfs/logfile.h
+include/ntfs/mft.h
+include/ntfs/mst.h
+include/ntfs/runlist.h
+include/ntfs/security.h
+include/ntfs/support.h
+include/ntfs/types.h
+include/ntfs/unistr.h
+include/ntfs/volume.h
+%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.a
+%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.la
+%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.so
+%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.so.1
+%%GNOMEVFS2%%lib/libntfs.a
+%%GNOMEVFS2%%lib/libntfs.la
+%%GNOMEVFS2%%lib/libntfs.so
+%%GNOMEVFS2%%lib/libntfs.so.5
+sbin/mkntfs
+sbin/ntfsclone
+sbin/ntfslabel
+sbin/ntfsresize
+sbin/ntfsundelete
+@dirrm include/ntfs