aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/nut
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /sysutils/nut
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'sysutils/nut')
-rw-r--r--sysutils/nut/Makefile4
-rw-r--r--sysutils/nut/files/extra-patch-m4_nut_check_libusb.m431
2 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index b08f0277bb44..1ab9b2aa0621 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -96,7 +96,11 @@ PLIST_SUB+= NUT_SERIAL="@comment "
.endif
.if !defined(WITHOUT_USB)
+. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+. else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-m4_nut_check_libusb.m4
+. endif
CONFIGURE_ARGS+= --with-usb=auto
MAN8+= bcmxcp_usb.8 megatec_usb.8 richcomm_usb.8 tripplite_usb.8 \
usbhid-ups.8
diff --git a/sysutils/nut/files/extra-patch-m4_nut_check_libusb.m4 b/sysutils/nut/files/extra-patch-m4_nut_check_libusb.m4
new file mode 100644
index 000000000000..d6a89d6d8198
--- /dev/null
+++ b/sysutils/nut/files/extra-patch-m4_nut_check_libusb.m4
@@ -0,0 +1,31 @@
+--- m4/nut_check_libusb.m4.orig 2009-03-07 23:56:24.000000000 +0300
++++ m4/nut_check_libusb.m4 2009-03-07 23:57:04.000000000 +0300
+@@ -17,24 +17,12 @@
+
+ dnl Check for libusb libs and flags
+ AC_MSG_CHECKING(for libusb cflags)
+- CFLAGS=`libusb-config --cflags 2>/dev/null`
+- if (test "$?" != "0")
+- then
+- AC_MSG_RESULT(not found)
+- nut_have_libusb=no
+- else
+- AC_MSG_RESULT(${CFLAGS})
+- fi
++ CFLAGS=""
++ AC_MSG_RESULT(${CFLAGS})
+
+ AC_MSG_CHECKING(for libusb libs)
+- LDFLAGS=`libusb-config --libs 2>/dev/null`
+- if (test "$?" != "0")
+- then
+- AC_MSG_RESULT(not found)
+- nut_have_libusb=no
+- else
+- AC_MSG_RESULT(${LDFLAGS})
+- fi
++ LDFLAGS="-lusb"
++ AC_MSG_RESULT(${LDFLAGS})
+
+ if test "${nut_have_libusb}" = "yes"; then
+ LIBUSB_CFLAGS="${CFLAGS}"