aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/oak
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2005-06-21 14:34:57 +0800
committerdemon <demon@FreeBSD.org>2005-06-21 14:34:57 +0800
commit4cebd70d1ac820ef5e9043fbe770e694bd51fc20 (patch)
tree7fe907194fd4eb2f6f1c1c88072b47e3dea43374 /sysutils/oak
parentc91b7261a7bce034e04602ce34fb9e3764dd7954 (diff)
downloadfreebsd-ports-gnome-4cebd70d1ac820ef5e9043fbe770e694bd51fc20.tar.gz
freebsd-ports-gnome-4cebd70d1ac820ef5e9043fbe770e694bd51fc20.tar.zst
freebsd-ports-gnome-4cebd70d1ac820ef5e9043fbe770e694bd51fc20.zip
New port: oak.
Oak is a program that can be used to monitor syslogs from a collection of servers and notify operators when problem conditions arise. In addition to providing immediate notification of critical problems oak will also batch less critical problems into summary messages that can be sent less often and via any medium. For example you may wish to have oak page you on critical events while sending a summary of less important messages to your terminal once an hour. In addition you could send a daily email message summarizing all events. WWW: http://www.ktools.org/oak/
Diffstat (limited to 'sysutils/oak')
-rw-r--r--sysutils/oak/Makefile23
-rw-r--r--sysutils/oak/distinfo2
-rw-r--r--sysutils/oak/files/patch-Makefile.in9
-rw-r--r--sysutils/oak/files/patch-matchline.c12
-rw-r--r--sysutils/oak/files/patch-text.c10
-rw-r--r--sysutils/oak/pkg-descr10
6 files changed, 66 insertions, 0 deletions
diff --git a/sysutils/oak/Makefile b/sysutils/oak/Makefile
new file mode 100644
index 000000000000..27ad9a592b79
--- /dev/null
+++ b/sysutils/oak/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: oak
+# Date created: 21 June 2005
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oak
+PORTVERSION= 1.5.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.ktools.org/dist/oak/
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= System Log Reporting Tool
+
+GNU_CONFIGURE= yes
+ALL_TARGET= oak
+PLIST_FILES= bin/oak
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/oak ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/oak/distinfo b/sysutils/oak/distinfo
new file mode 100644
index 000000000000..7907bad3e112
--- /dev/null
+++ b/sysutils/oak/distinfo
@@ -0,0 +1,2 @@
+MD5 (oak-1.5.0.tar.gz) = 69ccdfae317b8f6bb6bf1f27aae5bd02
+SIZE (oak-1.5.0.tar.gz) = 31034
diff --git a/sysutils/oak/files/patch-Makefile.in b/sysutils/oak/files/patch-Makefile.in
new file mode 100644
index 000000000000..625633836382
--- /dev/null
+++ b/sysutils/oak/files/patch-Makefile.in
@@ -0,0 +1,9 @@
+--- Makefile.in.orig Sun Feb 27 21:54:53 2005
++++ Makefile.in Tue Jun 21 10:27:59 2005
+@@ -1,5 +1,5 @@
+ CC=@CC@
+-CFLAGS=-g -Wall
++CFLAGS=@CFLAGS@
+ OBJS=action.o matchline.o oak.o queuelist.o fire.o queue.o util.o list.o global.o readconfig.o text.o queue_entry.o string.o
+
+ oak: $(OBJS)
diff --git a/sysutils/oak/files/patch-matchline.c b/sysutils/oak/files/patch-matchline.c
new file mode 100644
index 000000000000..8919774f55a0
--- /dev/null
+++ b/sysutils/oak/files/patch-matchline.c
@@ -0,0 +1,12 @@
+--- matchline.c.orig Sun Feb 27 21:54:53 2005
++++ matchline.c Tue Jun 21 10:25:59 2005
+@@ -1,8 +1,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <regex.h>
+ #include <sys/types.h>
++#include <regex.h>
+ #include <time.h>
+ #include "oak.h"
+
diff --git a/sysutils/oak/files/patch-text.c b/sysutils/oak/files/patch-text.c
new file mode 100644
index 000000000000..207cb7ee9cab
--- /dev/null
+++ b/sysutils/oak/files/patch-text.c
@@ -0,0 +1,10 @@
+--- text.c.orig Sun Feb 27 21:54:53 2005
++++ text.c Tue Jun 21 10:26:41 2005
+@@ -1,6 +1,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <sys/types.h>
+ #include <regex.h>
+ #include <ctype.h>
+ #include "oak.h"
diff --git a/sysutils/oak/pkg-descr b/sysutils/oak/pkg-descr
new file mode 100644
index 000000000000..bff511e0a521
--- /dev/null
+++ b/sysutils/oak/pkg-descr
@@ -0,0 +1,10 @@
+Oak is a program that can be used to monitor syslogs from a collection
+of servers and notify operators when problem conditions arise. In
+addition to providing immediate notification of critical problems oak
+will also batch less critical problems into summary messages that can
+be sent less often and via any medium. For example you may wish to
+have oak page you on critical events while sending a summary of less
+important messages to your terminal once an hour. In addition you
+could send a daily email message summarizing all events.
+
+WWW: http://www.ktools.org/oak/