aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ori
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-02-06 05:20:24 +0800
committertijl <tijl@FreeBSD.org>2017-02-06 05:20:24 +0800
commit766087b5ea83ecaaaffe737d90df248e9f40ef0d (patch)
tree7c63a95968ed9b4eb610fca1b72ff17c7d9581c2 /sysutils/ori
parentd9d1054d95b1ce955b4ac3a668f60925fba13fac (diff)
downloadfreebsd-ports-gnome-766087b5ea83ecaaaffe737d90df248e9f40ef0d.tar.gz
freebsd-ports-gnome-766087b5ea83ecaaaffe737d90df248e9f40ef0d.tar.zst
freebsd-ports-gnome-766087b5ea83ecaaaffe737d90df248e9f40ef0d.zip
- Remove inclusion of bsd.default-versions.mk from ftp/curl/Makefile so
bsd.default-versions.mk can rely on ARCH being defined. - In bsd.port.mk move inclusion of bsd.default-versions.mk from the pre-makefile section to the options section so the variables can be used earlier. Also put the bit of code sitting between the options section and the pre-makefile section into the options section. - Remove last few cases where ports set WITH_OPENSSL_PORT. This variable is handled in bsd.default-versions.mk and some ports were setting it after including bsd.port.options.mk. After FreeBSD 9 EoL all but a few ports, and then only when setting non-default options, work without setting that variable. PR: 215996 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'sysutils/ori')
-rw-r--r--sysutils/ori/Makefile9
-rw-r--r--sysutils/ori/files/patch-SConstruct18
2 files changed, 23 insertions, 4 deletions
diff --git a/sysutils/ori/Makefile b/sysutils/ori/Makefile
index a7ef75164db9..42d678a956bf 100644
--- a/sysutils/ori/Makefile
+++ b/sysutils/ori/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ori
PORTVERSION= 0.8.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= sysutils net
MASTER_SITES= http://cdn.bitbucket.org/orifs/ori/downloads/
@@ -13,9 +13,10 @@ COMMENT= Ori distributed file system
LIB_DEPENDS= libevent.so:devel/libevent2 \
libboost_date_time.so:devel/boost-libs
-USES= execinfo fuse pkgconfig scons tar:xz
-USE_OPENSSL= yes
-WITH_OPENSSL_PORT= yes
+USES= execinfo fuse pkgconfig scons ssl tar:xz
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto
+MAKE_ARGS= VERBOSE=1
PLIST_FILES= bin/ori \
bin/oridbg \
diff --git a/sysutils/ori/files/patch-SConstruct b/sysutils/ori/files/patch-SConstruct
new file mode 100644
index 000000000000..20224d3e8d08
--- /dev/null
+++ b/sysutils/ori/files/patch-SConstruct
@@ -0,0 +1,18 @@
+--- SConstruct.orig 2014-01-17 06:40:03 UTC
++++ SConstruct
+@@ -302,15 +302,6 @@ if (env["WITH_MDNS"]) and (sys.platform
+ print 'Please install libdns_sd'
+ Exit(1)
+
+-if env["HAS_PKGCONFIG"]:
+- if not conf.CheckPkg("openssl"):
+- print 'openssl is not registered in pkg-config'
+- Exit(1)
+- if not conf.CheckPkgMinVersion("openssl", "1.0.0"):
+- print 'openssl version 1.0.0 or above required'
+- Exit(1)
+- env.ParseConfig('pkg-config --libs --cflags openssl')
+-
+ conf.Finish()
+
+ Export('env')