aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pam_mount
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2010-11-02 17:51:12 +0800
committergahr <gahr@FreeBSD.org>2010-11-02 17:51:12 +0800
commit57748ac08768f487225d3916d09fab54d8372fd4 (patch)
tree98c2d51637711fab7dea1f8afd716a836378f95b /sysutils/pam_mount
parentca0eb3bff32b459f4245e1bc9e302769da98c96d (diff)
downloadfreebsd-ports-gnome-57748ac08768f487225d3916d09fab54d8372fd4.tar.gz
freebsd-ports-gnome-57748ac08768f487225d3916d09fab54d8372fd4.tar.zst
freebsd-ports-gnome-57748ac08768f487225d3916d09fab54d8372fd4.zip
- New port: sysutils/pam_mount
pam_mount is a Pluggable Authentication Module that can mount volumes for a user session. This module is aimed at environments with central file servers that a user wishes to mount on login and unmount on logout, such as (semi-)diskless stations where many users can logon and where statically mounting the entire /home from a server is a security risk, or listing all possible volumes in /etc/fstab is not feasible. WWW: http://pam-mount.sourceforge.net/
Diffstat (limited to 'sysutils/pam_mount')
-rw-r--r--sysutils/pam_mount/Makefile38
-rw-r--r--sysutils/pam_mount/distinfo3
-rw-r--r--sysutils/pam_mount/files/patch-src_pam_mount.c11
-rw-r--r--sysutils/pam_mount/pkg-descr9
-rw-r--r--sysutils/pam_mount/pkg-plist10
5 files changed, 71 insertions, 0 deletions
diff --git a/sysutils/pam_mount/Makefile b/sysutils/pam_mount/Makefile
new file mode 100644
index 000000000000..6b724f13bfb6
--- /dev/null
+++ b/sysutils/pam_mount/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# New ports collection Makefile for: pam_mount
+# Date created: 14 October 2010
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_mount
+PORTVERSION= 2.5
+CATEGORIES= sysutils
+MASTER_SITES= SF/${PORTNAME:S/_/-/}/${PORTNAME}/${PORTVERSION}/
+EXTRACT_SUFX= .tar.xz
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A PAM that can mount volumes for a user session
+
+LIB_DEPENDS= HX.25:${PORTSDIR}/lang/libhx
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= libcrypto_LIBS="-L/usr/lib -lcrypto" \
+ libcrypto_CFLAGS="-I/usr/include"
+CONFIGURE_ARGS+=--localstatedir=/var
+
+post-patch:
+ ${REINPLACE_CMD} -e '11172s|yes|no|' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/pam_mount.c
+ ${REINPLACE_CMD} -e '/dist_security_DATA/s|\.xml$$|.xml.sample|' \
+ ${WRKSRC}/config/Makefile.am ${WRKSRC}/config/Makefile.in
+ ${MV} ${WRKSRC}/config/pam_mount.conf.xml ${WRKSRC}/config/pam_mount.conf.xml.sample
+
+MAN1= pmt-fd0ssh.1
+MAN5= pam_mount.conf.5
+MAN8= mount.crypt.8 mount.crypt_LUKS.8 mount.crypto_LUKS.8 \
+ pmvarrun.8 pmt-ehd.8 umount.crypt.8 umount.crypt_LUKS.8 \
+ umount.crypto_LUKS.8 pam_mount.8
+
+.include <bsd.port.mk>
diff --git a/sysutils/pam_mount/distinfo b/sysutils/pam_mount/distinfo
new file mode 100644
index 000000000000..a56ce74c9c9a
--- /dev/null
+++ b/sysutils/pam_mount/distinfo
@@ -0,0 +1,3 @@
+MD5 (pam_mount-2.5.tar.xz) = f005ac284ebbd600f8eb2a729da1d644
+SHA256 (pam_mount-2.5.tar.xz) = 7fa248a98ffa49dc6d8ceae1b45088571b6845d7831cae95fc75ccbcca3afb26
+SIZE (pam_mount-2.5.tar.xz) = 288644
diff --git a/sysutils/pam_mount/files/patch-src_pam_mount.c b/sysutils/pam_mount/files/patch-src_pam_mount.c
new file mode 100644
index 000000000000..3db87a06953c
--- /dev/null
+++ b/sysutils/pam_mount/files/patch-src_pam_mount.c
@@ -0,0 +1,11 @@
+--- src/pam_mount.c.orig 2010-08-10 01:07:35.000000000 +0200
++++ src/pam_mount.c 2010-10-14 18:04:54.000000000 +0200
+@@ -39,6 +39,8 @@
+
+ #if defined(__OpenBSD__) || defined(__NetBSD__) || defined(__APPLE__)
+ # define CONFIGFILE "/etc/pam_mount.conf.xml"
++#elif defined(__FreeBSD__)
++# define CONFIGFILE "%%PREFIX%%/etc/security/pam_mount.conf.xml"
+ #else
+ # define CONFIGFILE "/etc/security/pam_mount.conf.xml"
+ #endif
diff --git a/sysutils/pam_mount/pkg-descr b/sysutils/pam_mount/pkg-descr
new file mode 100644
index 000000000000..89cef29469b1
--- /dev/null
+++ b/sysutils/pam_mount/pkg-descr
@@ -0,0 +1,9 @@
+pam_mount is a Pluggable Authentication Module that can mount volumes for a
+user session.
+This module is aimed at environments with central file servers that a user
+wishes to mount on login and unmount on logout, such as (semi-)diskless
+stations where many users can logon and where statically mounting the entire
+/home from a server is a security risk, or listing all possible volumes in
+/etc/fstab is not feasible.
+
+WWW: http://pam-mount.sourceforge.net/
diff --git a/sysutils/pam_mount/pkg-plist b/sysutils/pam_mount/pkg-plist
new file mode 100644
index 000000000000..0fb9243e37e9
--- /dev/null
+++ b/sysutils/pam_mount/pkg-plist
@@ -0,0 +1,10 @@
+bin/pmt-fd0ssh
+bin/pmt-ofl
+etc/security/pam_mount.conf.xml.sample
+lib/pam_mount.so
+sbin/pmvarrun
+sbin/pmt-ehd
+@dirrm share/xml/pam_mount/dtd
+@dirrm share/xml/pam_mount
+@dirrm etc/security
+@unexec rmdir /var/run/pam_mount 2> /dev/null