aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pefs-kmod
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-11-10 03:13:27 +0800
committerrene <rene@FreeBSD.org>2013-11-10 03:13:27 +0800
commitbc9eaafddac55414d201b6636e63508ce80779b9 (patch)
tree7436338612f22a81def9ee6c2d2e3826c1504ea4 /sysutils/pefs-kmod
parent74e9373bcd181bd5e011c695cd6ff38aeea7d44b (diff)
downloadfreebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.tar.gz
freebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.tar.zst
freebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.zip
Convert to USES=kmod, which removes duplicated code and ensures that all
required steps are followed. There are no user-visible changes. The exception is multimedia/ptx-kmod, which now installs the kernel module into /boot/modules instead of ${PREFIX}/libexec/${PORTNAME}, this was something USES=kmod cannot handle. PR: ports/183625 Submitted by: myself Approved by: portmgr (bdrewery) Exp-run by: bdrewery
Diffstat (limited to 'sysutils/pefs-kmod')
-rw-r--r--sysutils/pefs-kmod/Makefile10
-rw-r--r--sysutils/pefs-kmod/pkg-plist4
2 files changed, 5 insertions, 9 deletions
diff --git a/sysutils/pefs-kmod/Makefile b/sysutils/pefs-kmod/Makefile
index baa96784e97e..a94732fa9142 100644
--- a/sysutils/pefs-kmod/Makefile
+++ b/sysutils/pefs-kmod/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pefs
DISTVERSION= 2013-10-13
-CATEGORIES= sysutils kld
+CATEGORIES= sysutils
MASTER_SITES= https://pefs.googlecode.com/files/
PKGNAMESUFFIX= -kmod
@@ -12,20 +12,18 @@ COMMENT= PEFS kernel level stacked cryptographic filesystem
LICENSE= BSD
-SSP_UNSAFE= kernel module does not support ssp
FETCH_ARGS= -Fpr # work around 302 redirect
-KMODDIR?= /boot/modules
-PLIST_SUB= KMODDIR=${KMODDIR}
MAKE_ENV= BINDIR="${PREFIX}/sbin" MANDIR="${MANPREFIX}/man/man" \
- NO_MANCOMPRESS= \
- KMODDIR="${KMODDIR}" SYSDIR="${SRC_BASE}/sys"
+ NO_MANCOMPRESS=
MAN8= pam_pefs.8 pefs.8
ONLY_FOR_ARCHS= i386 amd64 # not tested on other archs
NO_STAGE= yes
+
+USES= kmod
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800000
diff --git a/sysutils/pefs-kmod/pkg-plist b/sysutils/pefs-kmod/pkg-plist
index 3aef5f2c9aa3..7e7bd3a98bf5 100644
--- a/sysutils/pefs-kmod/pkg-plist
+++ b/sysutils/pefs-kmod/pkg-plist
@@ -1,7 +1,5 @@
sbin/pefs
lib/pam_pefs.so
lib/pam_pefs.so.5
-@cwd %%KMODDIR%%
+@cwd /%%KMODDIR%%
pefs.ko
-@exec kldxref %%KMODDIR%%
-@unexec kldxref %%KMODDIR%%