aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pftop/Makefile
diff options
context:
space:
mode:
authormlaier <mlaier@FreeBSD.org>2007-09-09 02:14:51 +0800
committermlaier <mlaier@FreeBSD.org>2007-09-09 02:14:51 +0800
commit76548feec787d076a8b52c19253549ec717c37bc (patch)
treec429230255ba3c8e479c37cd4084416c5c2b632c /sysutils/pftop/Makefile
parent473f44e9475bd04e230ad6b2859d3571d457858e (diff)
downloadfreebsd-ports-gnome-76548feec787d076a8b52c19253549ec717c37bc.tar.gz
freebsd-ports-gnome-76548feec787d076a8b52c19253549ec717c37bc.tar.zst
freebsd-ports-gnome-76548feec787d076a8b52c19253549ec717c37bc.zip
Update pftop to 0.6 in order to make it work with changed pf ABI after the
4.1 import. Reported by: Bruce Cran Approved by: gabor PR: ports/116187
Diffstat (limited to 'sysutils/pftop/Makefile')
-rw-r--r--sysutils/pftop/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
index 8fd69dc9c36f..ee1ca21bc784 100644
--- a/sysutils/pftop/Makefile
+++ b/sysutils/pftop/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pftop
-PORTVERSION= 0.5
-#PORTREVISION= 2
+PORTVERSION= 0.6
CATEGORIES= sysutils net
MASTER_SITES= http://www.eee.metu.edu.tr/~canacar/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -33,13 +32,20 @@ CFLAGS+= -DHAVE_ALTQ=1
.elif ${OSVERSION} < 600025
MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=35
CFLAGS+= -DHAVE_ALTQ=1 -DHAVE_RULE_ANCHOR=1
-.else
+.elif ${OSVERSION} < 700049
MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=37
CFLAGS+= -DHAVE_ALTQ=1
+.else
+MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=41
+CFLAGS+= -DHAVE_ALTQ=1
.endif
PLIST_FILES= sbin/pftop
+post-patch:
+ @${REINPLACE_CMD} -e 's|<sys/queue.h>|"${FILESDIR}/queue.h"|g' \
+ ${WRKSRC}/engine.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pftop ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/pftop.8 ${PREFIX}/man/man8