aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/php72-posix
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-11-16 18:48:48 +0800
committertz <tz@FreeBSD.org>2017-11-16 18:48:48 +0800
commit9c489fdd6e8643dedbe20c8b8fbcfc2d73c2109c (patch)
treea2ff3d816b255016827738be132f8fc8bff8f5d9 /sysutils/php72-posix
parent27bd51e10cb05bed8f12f0c893e867200727f95c (diff)
downloadfreebsd-ports-gnome-9c489fdd6e8643dedbe20c8b8fbcfc2d73c2109c.tar.gz
freebsd-ports-gnome-9c489fdd6e8643dedbe20c8b8fbcfc2d73c2109c.tar.zst
freebsd-ports-gnome-9c489fdd6e8643dedbe20c8b8fbcfc2d73c2109c.zip
Add PHP 7.2 RC6
Notable changes: - mcrypt module was removed - sodium module was added - sybase_ct artifacts removed Also many PECL ports will not work with this version since some files got renamed. Reviewed by: mat, ale, Rainer Duffner <rainer@ultra-secure.de> Differential Revision: https://reviews.freebsd.org/D12980
Diffstat (limited to 'sysutils/php72-posix')
-rw-r--r--sysutils/php72-posix/Makefile9
-rw-r--r--sysutils/php72-posix/files/patch-posix.c38
-rw-r--r--sysutils/php72-posix/php71-posix/Makefile9
-rw-r--r--sysutils/php72-posix/php71-posix/files/patch-posix.c38
4 files changed, 94 insertions, 0 deletions
diff --git a/sysutils/php72-posix/Makefile b/sysutils/php72-posix/Makefile
new file mode 100644
index 000000000000..02d5050d8073
--- /dev/null
+++ b/sysutils/php72-posix/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -posix
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php72-posix/files/patch-posix.c b/sysutils/php72-posix/files/patch-posix.c
new file mode 100644
index 000000000000..d2365b249569
--- /dev/null
+++ b/sysutils/php72-posix/files/patch-posix.c
@@ -0,0 +1,38 @@
+--- posix.c.orig Fri Feb 23 00:40:39 2007
++++ posix.c Sun May 13 17:52:27 2007
+@@ -838,7 +838,7 @@
+ #if defined(ZTS) && defined(HAVE_GETGRNAM_R) && defined(_SC_GETGR_R_SIZE_MAX)
+ buflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ g = &gbuf;
+@@ -888,7 +888,7 @@
+
+ grbuflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (grbuflen < 1) {
+- RETURN_FALSE;
++ grbuflen = 1024;
+ }
+
+ grbuf = emalloc(grbuflen);
+@@ -955,7 +955,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWNAM_R)
+ buflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ pw = &pwbuf;
+@@ -1004,7 +1004,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWUID_R)
+ pwbuflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (pwbuflen < 1) {
+- RETURN_FALSE;
++ pwbuflen = 1024;
+ }
+ pwbuf = emalloc(pwbuflen);
+
diff --git a/sysutils/php72-posix/php71-posix/Makefile b/sysutils/php72-posix/php71-posix/Makefile
new file mode 100644
index 000000000000..d2734136a02b
--- /dev/null
+++ b/sysutils/php72-posix/php71-posix/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -posix
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php72-posix/php71-posix/files/patch-posix.c b/sysutils/php72-posix/php71-posix/files/patch-posix.c
new file mode 100644
index 000000000000..d2365b249569
--- /dev/null
+++ b/sysutils/php72-posix/php71-posix/files/patch-posix.c
@@ -0,0 +1,38 @@
+--- posix.c.orig Fri Feb 23 00:40:39 2007
++++ posix.c Sun May 13 17:52:27 2007
+@@ -838,7 +838,7 @@
+ #if defined(ZTS) && defined(HAVE_GETGRNAM_R) && defined(_SC_GETGR_R_SIZE_MAX)
+ buflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ g = &gbuf;
+@@ -888,7 +888,7 @@
+
+ grbuflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (grbuflen < 1) {
+- RETURN_FALSE;
++ grbuflen = 1024;
+ }
+
+ grbuf = emalloc(grbuflen);
+@@ -955,7 +955,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWNAM_R)
+ buflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ pw = &pwbuf;
+@@ -1004,7 +1004,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWUID_R)
+ pwbuflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (pwbuflen < 1) {
+- RETURN_FALSE;
++ pwbuflen = 1024;
+ }
+ pwbuf = emalloc(pwbuflen);
+