aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/portbrowser
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2005-03-25 14:03:22 +0800
committerhrs <hrs@FreeBSD.org>2005-03-25 14:03:22 +0800
commitb7418f8980757a6fefec74c3dd5379736a7bc84e (patch)
tree3d8cf17b840736adb7baef28121c549eeafe332a /sysutils/portbrowser
parent232447ced7a0826b2094828cca04e2e7be75a506 (diff)
downloadfreebsd-ports-gnome-b7418f8980757a6fefec74c3dd5379736a7bc84e.tar.gz
freebsd-ports-gnome-b7418f8980757a6fefec74c3dd5379736a7bc84e.tar.zst
freebsd-ports-gnome-b7418f8980757a6fefec74c3dd5379736a7bc84e.zip
Use ${INDEXFILE} for a filename of INDEX in /usr/ports.
PR: ports/79036, ports/79154 Approved by: portmgr(kiron)
Diffstat (limited to 'sysutils/portbrowser')
-rw-r--r--sysutils/portbrowser/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/sysutils/portbrowser/Makefile b/sysutils/portbrowser/Makefile
index ae379f077eba..6922b1d39db6 100644
--- a/sysutils/portbrowser/Makefile
+++ b/sysutils/portbrowser/Makefile
@@ -6,7 +6,7 @@
PORTNAME= portbrowser
PORTVERSION= 0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.bytelabs.org/
DISTNAME= pb-browser-${PORTVERSION}
@@ -16,6 +16,7 @@ MAINTAINER= hrs@FreeBSD.org
COMMENT= Graphical frontend for the BSD ports system
USE_GNOME= gtk20
+USE_REINPLACE= yes
MAKE_ENV= MANDIR=${PREFIX}/man/man \
BINDIR=${PREFIX}/bin \
NOMANCOMPRESS=YES
@@ -23,4 +24,8 @@ PLIST_FILES= bin/pbrowser
MAN1= pbrowser.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|"INDEX"|"${INDEXFILE}"|' \
+ ${WRKSRC}/src/pkgobject.h
+
.include <bsd.port.mk>