aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/portupgrade
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-11 18:07:05 +0800
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-11 18:07:05 +0800
commit68b126ec35200d35c0552224158293c49a9492d2 (patch)
tree0f948bf0380f024d77ebdce9e37876004c8f7064 /sysutils/portupgrade
parent22d14000a56aaaf6fff38301370ef8173417a08d (diff)
downloadfreebsd-ports-gnome-68b126ec35200d35c0552224158293c49a9492d2.tar.gz
freebsd-ports-gnome-68b126ec35200d35c0552224158293c49a9492d2.tar.zst
freebsd-ports-gnome-68b126ec35200d35c0552224158293c49a9492d2.zip
Add a hotfix to support the "MD5 (file) = IGNORE" case.
Diffstat (limited to 'sysutils/portupgrade')
-rw-r--r--sysutils/portupgrade/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index 16fb600aa621..34478d947f6b 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20010811
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.iDaemons.org/distfiles/
@@ -36,6 +37,8 @@ MANCOMPRESSED= yes
post-patch:
${RUBY} -i -pe 'sub %r:/usr/local:, "${LOCALBASE}"' ${WRKSRC}/pkgdb.rb
+ ${RUBY} -i~ -ne 'if ~%r:if /\^MD5 : then puts " if /^MD5 \\((.*)\\) = / =~ line"; else puts $$_; end' ${WRKSRC}/portsclean
+
do-install:
cd ${WRKSRC} && ${RUBY} install.rb