aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/py-salt
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-02-04 01:34:08 +0800
committerfeld <feld@FreeBSD.org>2016-02-04 01:34:08 +0800
commite9665b1a81488ae58aa553e957a186455906e464 (patch)
treef450fb6dd818e548a24bdb58c8bc6ab61f4d0924 /sysutils/py-salt
parentefb4b36fe6f7f676b300e39858b0bf0c7d59742f (diff)
downloadfreebsd-ports-gnome-e9665b1a81488ae58aa553e957a186455906e464.tar.gz
freebsd-ports-gnome-e9665b1a81488ae58aa553e957a186455906e464.tar.zst
freebsd-ports-gnome-e9665b1a81488ae58aa553e957a186455906e464.zip
sysutils/py-salt: Patch to fix major regression
There was a major regression in 2015.8.4 which breaks a lot of salt functionality. This adds a patch to fix it ahead of the upcoming 2015.8.5. The reason for patching in the ports tree is that there is a major CVE that is addressed in 2015.8.4 which should be resolved immediately by merging a functional salt to quarterly. Regression: https://github.com/saltstack/salt/issues/30820 Security: CVE-2016-1866 Security: https://vuxml.freebsd.org/freebsd/0652005e-ca96-11e5-96d6-14dae9d210b8.html Approved by: ports-secteam (with hat) MFH: 2016Q1
Diffstat (limited to 'sysutils/py-salt')
-rw-r--r--sysutils/py-salt/Makefile1
-rw-r--r--sysutils/py-salt/files/patch-salt_state.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/py-salt/Makefile b/sysutils/py-salt/Makefile
index 3822a039b344..41bd8ed4d746 100644
--- a/sysutils/py-salt/Makefile
+++ b/sysutils/py-salt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= salt
PORTVERSION= 2015.8.4
+PORTREVISION= 1
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/sysutils/py-salt/files/patch-salt_state.py b/sysutils/py-salt/files/patch-salt_state.py
new file mode 100644
index 000000000000..1ce4b70e67c8
--- /dev/null
+++ b/sysutils/py-salt/files/patch-salt_state.py
@@ -0,0 +1,11 @@
+--- salt/state.py.orig 2016-02-03 17:25:12 UTC
++++ salt/state.py
+@@ -190,7 +190,7 @@ def find_name(name, state, high):
+ if len(arg) != 1:
+ continue
+ if arg[next(iter(arg))] == name:
+- ext_id.append((name, state))
++ ext_id.append((nid, state))
+ return ext_id
+
+