aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/rename
diff options
context:
space:
mode:
authorjsa <jsa@FreeBSD.org>2011-03-17 03:32:21 +0800
committerjsa <jsa@FreeBSD.org>2011-03-17 03:32:21 +0800
commit79f38c9fae369c501efc389438525ce25c67aea9 (patch)
tree6d1e04c235826222bd7435833809580cdff2cee7 /sysutils/rename
parent6570a159373da05887de4c86afa723f4118de304 (diff)
downloadfreebsd-ports-gnome-79f38c9fae369c501efc389438525ce25c67aea9.tar.gz
freebsd-ports-gnome-79f38c9fae369c501efc389438525ce25c67aea9.tar.zst
freebsd-ports-gnome-79f38c9fae369c501efc389438525ce25c67aea9.zip
Fix when building with GCC 4.5. While here, fix gripe with clang and a
few typos. PR: ports/154173 Submitted by: bf Approved by: kwm (mentor)
Diffstat (limited to 'sysutils/rename')
-rw-r--r--sysutils/rename/Makefile1
-rw-r--r--sysutils/rename/files/patch-rename.c28
2 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/rename/Makefile b/sysutils/rename/Makefile
index 29927975084c..c3f1b149b136 100644
--- a/sysutils/rename/Makefile
+++ b/sysutils/rename/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rename
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://mirror2.unixfreunde.de/ \
http://freebsd.unixfreunde.de/sources/
diff --git a/sysutils/rename/files/patch-rename.c b/sysutils/rename/files/patch-rename.c
new file mode 100644
index 000000000000..17a74c2fd911
--- /dev/null
+++ b/sysutils/rename/files/patch-rename.c
@@ -0,0 +1,28 @@
+--- ./rename.c.orig 2002-05-20 11:50:50.000000000 -0400
++++ ./rename.c 2011-03-13 05:05:52.000000000 -0400
+@@ -65,7 +65,7 @@
+
+ #if HAVE_REGEX_H
+ #include <regex.h>
+-#elif
++#else
+ #include "regex.h"
+ #endif
+
+@@ -608,7 +608,7 @@
+
+ skip:
+ if (attr & MOD_VERBO)
+- printf("skiped\n");
++ printf("skipped\n");
+ return rs;
+ }
+
+@@ -659,6 +659,6 @@
+ if (mode)
+ printf(version, VERSION);
+ else
+- printf(help);
++ printf("%s", help);
+ }
+