aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/rubygem-smart_proxy_chef
diff options
context:
space:
mode:
authormmoll <mmoll@FreeBSD.org>2015-05-30 02:36:47 +0800
committermmoll <mmoll@FreeBSD.org>2015-05-30 02:36:47 +0800
commit47f801154604664f2b6ed344941ae82b93c06a85 (patch)
treee5a17d1c76ff568f04702e29ad94e637e4d193b2 /sysutils/rubygem-smart_proxy_chef
parentcb90e4296294bd9eca855b814896128c48fe6949 (diff)
downloadfreebsd-ports-gnome-47f801154604664f2b6ed344941ae82b93c06a85.tar.gz
freebsd-ports-gnome-47f801154604664f2b6ed344941ae82b93c06a85.tar.zst
freebsd-ports-gnome-47f801154604664f2b6ed344941ae82b93c06a85.zip
new port: sysutils/rubygem-smart_proxy_chef
Chef Plug-In for Foreman's Smart Proxy WWW: https://github.com/theforeman/smart_proxy_chef Approved by: mat (mentor)
Diffstat (limited to 'sysutils/rubygem-smart_proxy_chef')
-rw-r--r--sysutils/rubygem-smart_proxy_chef/Makefile29
-rw-r--r--sysutils/rubygem-smart_proxy_chef/distinfo2
-rw-r--r--sysutils/rubygem-smart_proxy_chef/pkg-descr3
-rw-r--r--sysutils/rubygem-smart_proxy_chef/pkg-message2
-rw-r--r--sysutils/rubygem-smart_proxy_chef/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/rubygem-smart_proxy_chef/Makefile b/sysutils/rubygem-smart_proxy_chef/Makefile
new file mode 100644
index 000000000000..ef915b11c68b
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_chef/Makefile
@@ -0,0 +1,29 @@
+# Created by: Michael Moll <mmoll@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= smart_proxy_chef
+PORTVERSION= 0.1.3
+CATEGORIES= sysutils ruby
+MASTER_SITES= RG
+
+MAINTAINER= mmoll@FreeBSD.org
+COMMENT= Chef Plug-In for Foreman's Smart Proxy
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= foreman-proxy>=1.8.0:${PORTSDIR}/net/foreman-proxy \
+ rubygem-chef-api>0:${PORTSDIR}/sysutils/rubygem-chef-api
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.d
+ ${INSTALL_DATA} ${WRKSRC}/settings.d/chef.yml.example \
+ ${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.d/chef.yml.sample
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/foreman-proxy/bundler.d
+ ${INSTALL_DATA} ${WRKSRC}/bundler.d/chef.rb \
+ ${STAGEDIR}${PREFIX}/share/foreman-proxy/bundler.d/chef.rb
+
+.include <bsd.port.mk>
diff --git a/sysutils/rubygem-smart_proxy_chef/distinfo b/sysutils/rubygem-smart_proxy_chef/distinfo
new file mode 100644
index 000000000000..e69b217a686d
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_chef/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/smart_proxy_chef-0.1.3.gem) = 8491b1803bc2b611109daabe7404d7dc513c977ccff21c6216f56f45ee8ac1dd
+SIZE (rubygem/smart_proxy_chef-0.1.3.gem) = 19968
diff --git a/sysutils/rubygem-smart_proxy_chef/pkg-descr b/sysutils/rubygem-smart_proxy_chef/pkg-descr
new file mode 100644
index 000000000000..e601e423e6f9
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_chef/pkg-descr
@@ -0,0 +1,3 @@
+This plug-in adds support for Chef to Foreman's Smart Proxy.
+
+WWW: https://github.com/theforeman/smart_proxy_chef
diff --git a/sysutils/rubygem-smart_proxy_chef/pkg-message b/sysutils/rubygem-smart_proxy_chef/pkg-message
new file mode 100644
index 000000000000..414cd9cab750
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_chef/pkg-message
@@ -0,0 +1,2 @@
+Further configuration is required to connect Chef and foreman-proxy, see:
+http://theforeman.org/plugins/foreman_chef/0.1/
diff --git a/sysutils/rubygem-smart_proxy_chef/pkg-plist b/sysutils/rubygem-smart_proxy_chef/pkg-plist
new file mode 100644
index 000000000000..ed82c9b81f36
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_chef/pkg-plist
@@ -0,0 +1,2 @@
+share/foreman-proxy/bundler.d/chef.rb
+@sample etc/foreman-proxy/settings.d/chef.yml.sample