aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/runit
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-03-26 06:15:48 +0800
committersergei <sergei@FreeBSD.org>2004-03-26 06:15:48 +0800
commit9732e4cd8f0c82950ad29d14285271c5e2693ef6 (patch)
treef15a6c5faa8a4a71b0bf02b604b9173f1dc11bb5 /sysutils/runit
parent1104d0294bb16b5c089c77e4757e07c5c89af324 (diff)
downloadfreebsd-ports-gnome-9732e4cd8f0c82950ad29d14285271c5e2693ef6.tar.gz
freebsd-ports-gnome-9732e4cd8f0c82950ad29d14285271c5e2693ef6.tar.zst
freebsd-ports-gnome-9732e4cd8f0c82950ad29d14285271c5e2693ef6.zip
- Make running self-tests an optional step since it may fail
in some environments (particularlly, bento's). Move it from do-build to a new test target. Reported by: bento (via kris)
Diffstat (limited to 'sysutils/runit')
-rw-r--r--sysutils/runit/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/sysutils/runit/Makefile b/sysutils/runit/Makefile
index 2b003885f63c..bd1e6fd20d0d 100644
--- a/sysutils/runit/Makefile
+++ b/sysutils/runit/Makefile
@@ -30,7 +30,7 @@ do-configure:
${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/src/conf-cc
do-build:
- cd ${WRKSRC} && package/compile && package/check
+ cd ${WRKSRC} && package/compile
@${MKDIR} ${WRKDIR}/etc/getty-ttyv4
@${SED} -e 's!%%PREFIX%%!${PREFIX}!' \
-e 's!%%SERVICE_DIR%%!${SERVICE_DIR}!' \
@@ -41,6 +41,10 @@ do-build:
-e 's!/usr/local!${PREFIX}!g' \
${WRKSRC}/${file} > ${WRKDIR}/${file:S!freebsd/!!}.sample
.endfor
+ @${ECHO_MSG} "Type 'make test' to run self-tests"
+
+test:
+ cd ${WRKSRC} && package/check
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/command/* ${PREFIX}/sbin