aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/screen
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2007-10-26 02:01:51 +0800
committercy <cy@FreeBSD.org>2007-10-26 02:01:51 +0800
commit6e218446fe0c04a97059191e77dda8b84f70c864 (patch)
tree05a652c35414a4c9717d46523fa8985e31495fe7 /sysutils/screen
parent4f643a930139b48aeed43ba4c02f32ad7c0906f7 (diff)
downloadfreebsd-ports-gnome-6e218446fe0c04a97059191e77dda8b84f70c864.tar.gz
freebsd-ports-gnome-6e218446fe0c04a97059191e77dda8b84f70c864.tar.zst
freebsd-ports-gnome-6e218446fe0c04a97059191e77dda8b84f70c864.zip
Fix (enable) installation of man pages and info documents.
PR: 117488
Diffstat (limited to 'sysutils/screen')
-rw-r--r--sysutils/screen/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index b88302fabe25..f2c2fea1b2d2 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -7,6 +7,7 @@
PORTNAME= screen
PORTVERSION= 4.0.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
http://komquats.com/distfiles/ \
@@ -23,6 +24,10 @@ OPTIONS= CJK "Treat CJK ambiguous characters as full width" OFF \
NETHACK "Enable nethack-style messages" ON \
XTERM_256 "Enable support for 256 colour xterm" OFF
+NO_PACKAGE= Tends to loop using 100% CPU when used from package - perhaps it hard-codes information about the build host
+
+.include <bsd.port.pre.mk>
+
GNU_CONFIGURE= yes
.if defined(WITH_MAN)
MAN1= screen.1
@@ -38,10 +43,6 @@ INFO= screen
MAKE_ARGS+= -DNO_INFO
.endif
-NO_PACKAGE= Tends to loop using 100% CPU when used from package - perhaps it hard-codes information about the build host
-
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "alpha"
CFLAGS+= -O0
.endif
@@ -72,5 +73,8 @@ post-install:
@if [ ! -f ${PREFIX}/etc/screenrc ]; then \
${CP} ${EXAMPLESDIR}/screenrc ${PREFIX}/etc/screenrc ; \
fi
+.if defined(WITH_MAN)
+ ${INSTALL_MAN} ${WRKSRC}/doc/screen.1 ${MANPREFIX}/man/man1
+.endif
.include <bsd.port.post.mk>