aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/solaar
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-22 16:04:25 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-22 16:04:25 +0800
commita18af7748d40630f2b3dcc51f1317c1c8ea23515 (patch)
treeb87b18c315a72ec8f8b739ae8bcdfbf70e663294 /sysutils/solaar
parentc44988a97b1280f99cb7c0dfd3cdd32bfe99f84f (diff)
downloadfreebsd-ports-gnome-a18af7748d40630f2b3dcc51f1317c1c8ea23515.tar.gz
freebsd-ports-gnome-a18af7748d40630f2b3dcc51f1317c1c8ea23515.tar.zst
freebsd-ports-gnome-a18af7748d40630f2b3dcc51f1317c1c8ea23515.zip
sysutils/solaar: Update to 0.9.2-259-gc07c115
This make Solaar compatible with Python 3.7 where 'async' has become a reserved keyword. Changes: https://github.com/pwr/Solaar/compare/0.9.2-221-g1a67b33...0.9.2-259-gc07c115
Diffstat (limited to 'sysutils/solaar')
-rw-r--r--sysutils/solaar/Makefile4
-rw-r--r--sysutils/solaar/distinfo6
-rw-r--r--sysutils/solaar/files/patch-setup.py18
3 files changed, 15 insertions, 13 deletions
diff --git a/sysutils/solaar/Makefile b/sysutils/solaar/Makefile
index 391552cdd5a7..330d8668ab25 100644
--- a/sysutils/solaar/Makefile
+++ b/sysutils/solaar/Makefile
@@ -5,8 +5,8 @@ PORTNAME= solaar
# release for now:
# https://github.com/pwr/Solaar/issues/288
# https://github.com/pwr/Solaar/issues/296
-DISTVERSION= 0.9.2-221
-DISTVERSIONSUFFIX= -g1a67b33
+DISTVERSION= 0.9.2-259
+DISTVERSIONSUFFIX= -gc07c115
CATEGORIES= sysutils
MAINTAINER= tobik@FreeBSD.org
diff --git a/sysutils/solaar/distinfo b/sysutils/solaar/distinfo
index 1a4350dd05fe..38d771c4ff14 100644
--- a/sysutils/solaar/distinfo
+++ b/sysutils/solaar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516754216
-SHA256 (pwr-Solaar-0.9.2-221-g1a67b33_GH0.tar.gz) = ce5f9dc83a0bb3ba2d84e1cc5c169fe4cb3d53d1ff2e269b9e4ce3382e6e2ceb
-SIZE (pwr-Solaar-0.9.2-221-g1a67b33_GH0.tar.gz) = 1192295
+TIMESTAMP = 1550816390
+SHA256 (pwr-Solaar-0.9.2-259-gc07c115_GH0.tar.gz) = ba3cfc65cc249d80a571ee003d73d3f2376dfada8a2a9e7e2e74c05f952a4868
+SIZE (pwr-Solaar-0.9.2-259-gc07c115_GH0.tar.gz) = 1194838
diff --git a/sysutils/solaar/files/patch-setup.py b/sysutils/solaar/files/patch-setup.py
index e86197cd8012..2d18f8a8f728 100644
--- a/sysutils/solaar/files/patch-setup.py
+++ b/sysutils/solaar/files/patch-setup.py
@@ -1,19 +1,21 @@
---- setup.py.orig 2017-03-20 23:07:26 UTC
+--- setup.py.orig 2019-01-30 15:58:00 UTC
+++ setup.py
-@@ -6,10 +6,8 @@ from distutils.core import setup
+@@ -6,14 +6,9 @@ from distutils.core import setup
autostart_path = '/etc/xdg/autostart'
import sys
-backup_path_0 = sys.path[0]
-sys.path[0] = backup_path_0 + '/lib'
--from solaar import NAME, __version__
--sys.path[0] = backup_path_0
-+NAME = 'Solaar'
-+__version__ = '0.9.2'
+-#from solaar import NAME, __version__
+ __version__ = '0.9.2'
+ NAME = 'Solaar'
+-sys.path[0] = backup_path_0
+-
if 'install' in sys.argv:
# naively guess where the autostart .desktop file should be installed
-@@ -22,7 +20,7 @@ if 'install' in sys.argv:
+ if '--prefix' in sys.argv or any(x.startswith('--prefix=') for x in sys.argv) or '--home' in sys.argv:
+@@ -25,7 +20,7 @@ if 'install' in sys.argv:
autostart_path = path.join(xdg_config_home, 'autostart')
del environ, path, xdg_config_home
@@ -22,7 +24,7 @@
def _data_files():
-@@ -36,7 +34,6 @@ def _data_files():
+@@ -39,7 +34,6 @@ def _data_files():
yield _dirname(mo), [mo]
yield 'share/applications', ['share/applications/solaar.desktop']