aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/sysinfo
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 04:01:07 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 04:01:07 +0800
commit839ca29ce3909cfe75f51f01c6bfd6263cca79ac (patch)
tree8462df47de7a523e2debd710ebc0516911e33a43 /sysutils/sysinfo
parent7a2d41eb20684123f01fb37f8af0b0c0bdfd1f26 (diff)
downloadfreebsd-ports-gnome-839ca29ce3909cfe75f51f01c6bfd6263cca79ac.tar.gz
freebsd-ports-gnome-839ca29ce3909cfe75f51f01c6bfd6263cca79ac.tar.zst
freebsd-ports-gnome-839ca29ce3909cfe75f51f01c6bfd6263cca79ac.zip
Convert left sysutils ports to new options framework
Diffstat (limited to 'sysutils/sysinfo')
-rw-r--r--sysutils/sysinfo/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/sysutils/sysinfo/Makefile b/sysutils/sysinfo/Makefile
index a9912ce24afc..d5d14c30a95f 100644
--- a/sysutils/sysinfo/Makefile
+++ b/sysutils/sysinfo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sysinfo
-# Date created: 22 April 2009
-# Whom: Daniel Gerzo <danger@FreeBSD.org>
-#
+# Created by: Daniel Gerzo <danger@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= sysinfo
PORTVERSION= 1.0.1
@@ -21,16 +17,17 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAN5= sysinfo.conf.5
MAN8= sysinfo.8
-OPTIONS= DMIDECODE "Include information from the dmidecode tool" Off \
- PORTAUDIT "Include information from the portaudit tool" Off
+OPTIONS_DEFINE= DMIDECODE PORTAUDIT
+DMIDECODE_DESC= Include information from the dmidecode tool
+PORTAUDIT_DESC= Include information from the portaudit tool
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DMIDECODE)
+.if ${PORT_OPTIONS:MDMIDECODE}
RUN_DEPENDS= dmidecode:${PORTSDIR}/sysutils/dmidecode
.endif
-.if defined(WITH_PORTAUDIT)
+.if ${PORT_OPTIONS:MPORTAUDIT}
RUN_DEPENDS+= portaudit:${PORTSDIR}/ports-mgmt/portaudit
.endif
@@ -58,4 +55,4 @@ post-install:
${CP} -p ${PREFIX}/etc/sysinfo.conf.sample ${PREFIX}/etc/sysinfo.conf ; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>