aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/torsmo
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-29 23:50:55 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-29 23:50:55 +0800
commita26d83226490bc9ab9aaef89ed8043fb1ddb56b7 (patch)
treeebb08102e8ab2686bcfb90364ffbf15ace78f35e /sysutils/torsmo
parent568dba655f0d65041dce3dd8aa3d858abac25781 (diff)
downloadfreebsd-ports-gnome-a26d83226490bc9ab9aaef89ed8043fb1ddb56b7.tar.gz
freebsd-ports-gnome-a26d83226490bc9ab9aaef89ed8043fb1ddb56b7.tar.zst
freebsd-ports-gnome-a26d83226490bc9ab9aaef89ed8043fb1ddb56b7.zip
1: Stagify.
2: new syntax of LIB_DEPENDS. Approved by: portmgr@ (blanket approval)
Diffstat (limited to 'sysutils/torsmo')
-rw-r--r--sysutils/torsmo/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/sysutils/torsmo/Makefile b/sysutils/torsmo/Makefile
index 021c86f518fd..2844505732a4 100644
--- a/sysutils/torsmo/Makefile
+++ b/sysutils/torsmo/Makefile
@@ -13,9 +13,9 @@ COMMENT= System monitor that renders text on desktop
GNU_CONFIGURE= yes
USE_XORG= x11
CPPFLAGS+= -I${LOCALBASE}/include
-MAN1= torsmo.1
PLIST_FILES= bin/torsmo \
+ man/man1/torsmo.1.gz \
%%EXAMPLESDIR%%/torsmorc.sample
PLIST_DIRS= %%EXAMPLESDIR%%
PORTDOCS= AUTHORS ChangeLog NEWS README
@@ -24,11 +24,10 @@ OPTIONS_DEFINE= XFT DOUBLE_BUFFER DOCS
OPTIONS_DEFAULT= XFT DOUBLE_BUFFER
DOUBLE_BUFFER_DESC= Flicker-free operation support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MXFT}
-LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+LIB_DEPENDS+= libXft.so:${PORTSDIR}/x11-fonts/libXft
CONFIGURE_ARGS+= --enable-xft
.endif
@@ -38,10 +37,10 @@ CONFIGURE_ARGS+= --disable-double-buffer
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/torsmorc.sample ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/torsmorc.sample ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>