aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/unetbootin/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2019-03-22 21:37:04 +0800
committerdanfe <danfe@FreeBSD.org>2019-03-22 21:37:04 +0800
commitf41fb2cc5b37f0365a6b33d3b2a66f8f4f304b09 (patch)
tree23ea7225a322ad3d1ade35014c0e6e6570571237 /sysutils/unetbootin/Makefile
parent97d686c5ece1626de8b84c3d2b4959ee64b45779 (diff)
downloadfreebsd-ports-gnome-f41fb2cc5b37f0365a6b33d3b2a66f8f4f304b09.tar.gz
freebsd-ports-gnome-f41fb2cc5b37f0365a6b33d3b2a66f8f4f304b09.tar.zst
freebsd-ports-gnome-f41fb2cc5b37f0365a6b33d3b2a66f8f4f304b09.zip
- Resurrect and apply unofficial patch from Gentoo to build against
Qt version 5 (this breaks unetbootin::lstFtpDirFiles() due to https://bugreports.qt.io/browse/QTBUG-26294) - Comment out all sources that require FTP LIST command - Don't wait until file is fully downloaded before dumping it on disk - Fix some QNetworkReply/QFile resource freeing bugs - Delete unetbootin::dlprogressupdate64() because it's never used - Fix some slot warnings while here Patches by: Valeriy Malov <jazzvoid@gmail.com> Obtained from: https://bugs.gentoo.org/show_bug.cgi?id=644360
Diffstat (limited to 'sysutils/unetbootin/Makefile')
-rw-r--r--sysutils/unetbootin/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/unetbootin/Makefile b/sysutils/unetbootin/Makefile
new file mode 100644
index 000000000000..f3cd1667ef5e
--- /dev/null
+++ b/sysutils/unetbootin/Makefile
@@ -0,0 +1,47 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= unetbootin
+PORTVERSION= 661
+CATEGORIES= sysutils
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-source-${PORTVERSION}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Bootable Live USB creator for various Linux distributions
+
+LICENSE= GPLv2+
+
+RUN_DEPENDS= 7z:archivers/p7zip \
+ syslinux:sysutils/syslinux \
+ mke2fs:sysutils/e2fsprogs
+
+USES= qt:5
+USE_QT= buildtools_build linguisttools_build qmake_build \
+ core gui network widgets
+QMAKE_ARGS= DEFINES+=LOCALBASE=\\\\\\\"${LOCALBASE}\\\\\\\"
+
+NO_WRKSUBDIR= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/,${PREFIX}/,g' \
+ ${WRKSRC}/main.cpp
+
+do-configure:
+ ${LUPDATE} ${WRKSRC}/unetbootin.pro
+ ${LRELEASE} ${WRKSRC}/unetbootin.pro
+ cd ${WRKSRC} && ${QMAKE_ENV} ${QMAKE} ${QMAKE_ARGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unetbootin ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/unetbootin.xpm \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/unetbootin_*.qm ${STAGEDIR}${DATADIR}
+.for n in 16 22 24 32 48 64 128 192 256 512
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${n}x${n}/apps
+ ${INSTALL_DATA} ${WRKSRC}/unetbootin_${n}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${n}x${n}/apps/unetbootin.png
+.endfor
+
+.include <bsd.port.mk>