aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/vii
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-08-29 22:34:03 +0800
committergarga <garga@FreeBSD.org>2005-08-29 22:34:03 +0800
commitebd63d45ab8ecf90b9b39b10327a56de3a46547e (patch)
tree4bb1ae48fa0345f2f1a0ff1cdd394e0aca7c7ddf /sysutils/vii
parent95e7502868200b45b5af8d6237d35c8d5562a929 (diff)
downloadfreebsd-ports-gnome-ebd63d45ab8ecf90b9b39b10327a56de3a46547e.tar.gz
freebsd-ports-gnome-ebd63d45ab8ecf90b9b39b10327a56de3a46547e.tar.zst
freebsd-ports-gnome-ebd63d45ab8ecf90b9b39b10327a56de3a46547e.zip
Add vii 4.0, execute a command repeatedly and scroll the output.
PR: ports/84852 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'sysutils/vii')
-rw-r--r--sysutils/vii/Makefile26
-rw-r--r--sysutils/vii/distinfo2
-rw-r--r--sysutils/vii/pkg-descr14
3 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/vii/Makefile b/sysutils/vii/Makefile
new file mode 100644
index 000000000000..6666ab10bcd6
--- /dev/null
+++ b/sysutils/vii/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: vii
+# Date created: 12 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vii
+PORTVERSION= 4.0
+CATEGORIES= sysutils
+MASTER_SITES= http://vii.sourceforge.net/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Execute a command repeatedly and scroll the output
+
+GNU_CONFIGURE= yes
+MAKE_ARGS+= CFLAGS="${CFLAGS}"
+
+PLIST_FILES= bin/vii
+MAN1= vii.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man1/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/vii/distinfo b/sysutils/vii/distinfo
new file mode 100644
index 000000000000..5903f284f640
--- /dev/null
+++ b/sysutils/vii/distinfo
@@ -0,0 +1,2 @@
+MD5 (vii-4.0.tar.gz) = ffdcbf72ef961cac01a15911ae5a73c8
+SIZE (vii-4.0.tar.gz) = 120680
diff --git a/sysutils/vii/pkg-descr b/sysutils/vii/pkg-descr
new file mode 100644
index 000000000000..8073a6c83382
--- /dev/null
+++ b/sysutils/vii/pkg-descr
@@ -0,0 +1,14 @@
+Vii (pronounced seven) is a simple program which accepts input from the
+standard input and displays pages of the input on the terminal.
+
+These pages are delimited by form-feeds (or EOF). The display can be scrolled
+if the output is wider or longer than the screen.
+
+Vii can also repeatedly execute a command (at a configurable interval) and the
+most recent output is displayed. This is useful for status monitoring where the
+command itself does not have a repeatable or curses interface.
+
+WWW: http://vii.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch