aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/webmin
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2002-02-24 19:26:31 +0800
committerolgeni <olgeni@FreeBSD.org>2002-02-24 19:26:31 +0800
commitcde6b3b9844691b96e8bfbc1a7a7fd895a5ec9a5 (patch)
treefbd5cb81b610a25dd3c1e28f9769a6dfc3d9698d /sysutils/webmin
parentba7ea1d23c6dbebda904ae39b3509158a5ec401d (diff)
downloadfreebsd-ports-gnome-cde6b3b9844691b96e8bfbc1a7a7fd895a5ec9a5.tar.gz
freebsd-ports-gnome-cde6b3b9844691b96e8bfbc1a7a7fd895a5ec9a5.tar.zst
freebsd-ports-gnome-cde6b3b9844691b96e8bfbc1a7a7fd895a5ec9a5.zip
Preload libpam.so.1 in the startup script so that PAM authentication will
actually work. Submitted by: MikeM <MyRaQ@mgm51.com> Add dependency on security/p5-Authen-PAM, and change BUILD_DEPENDS to RUN_DEPENDS (perl modules are needed at runtime too...). Add proper return codes to the startup script.
Diffstat (limited to 'sysutils/webmin')
-rw-r--r--sysutils/webmin/Makefile5
-rw-r--r--sysutils/webmin/files/webmin.sh.in4
-rw-r--r--sysutils/webmin/files/webmin.sh.sample4
3 files changed, 11 insertions, 2 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index d45b2e4e95f0..0659606b9e9d 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webmin
PORTVERSION= 0.92
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils
MASTER_SITES= http://www.webmin.com/webmin/updates/ \
http://www.webmin.com/webmin/download/
@@ -17,7 +17,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= olgeni@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Authen/PAM.pm:${PORTSDIR}/security/p5-Authen-PAM
NO_BUILD= yes
USE_PERL5= yes
diff --git a/sysutils/webmin/files/webmin.sh.in b/sysutils/webmin/files/webmin.sh.in
index b70dee31fd79..b218d6af9fc4 100644
--- a/sysutils/webmin/files/webmin.sh.in
+++ b/sysutils/webmin/files/webmin.sh.in
@@ -5,10 +5,13 @@
case $1 in
start)
+ LD_PRELOAD=/usr/lib/libpam.so.1
+ export LD_PRELOAD
if [ -x !!PREFIX!!/etc/webmin/start ]; then
!!PREFIX!!/etc/webmin/start >/dev/null
echo -n ' webmin'
fi
+ exit 0
;;
stop)
@@ -16,6 +19,7 @@ case $1 in
!!PREFIX!!/etc/webmin/stop >/dev/null
echo -n ' webmin'
fi
+ exit 0
;;
*)
diff --git a/sysutils/webmin/files/webmin.sh.sample b/sysutils/webmin/files/webmin.sh.sample
index b70dee31fd79..b218d6af9fc4 100644
--- a/sysutils/webmin/files/webmin.sh.sample
+++ b/sysutils/webmin/files/webmin.sh.sample
@@ -5,10 +5,13 @@
case $1 in
start)
+ LD_PRELOAD=/usr/lib/libpam.so.1
+ export LD_PRELOAD
if [ -x !!PREFIX!!/etc/webmin/start ]; then
!!PREFIX!!/etc/webmin/start >/dev/null
echo -n ' webmin'
fi
+ exit 0
;;
stop)
@@ -16,6 +19,7 @@ case $1 in
!!PREFIX!!/etc/webmin/stop >/dev/null
echo -n ' webmin'
fi
+ exit 0
;;
*)