aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/webmin
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-02-28 04:42:17 +0800
committerolgeni <olgeni@FreeBSD.org>2001-02-28 04:42:17 +0800
commitf53849e52be66ab5bb51bbd3e9736b81961091d0 (patch)
treec2659f3c19f6e5d9c9d5e377674cd3dbf4339480 /sysutils/webmin
parent49c0719c5943eb58cec81958792cc8fbc2d26c9b (diff)
downloadfreebsd-ports-gnome-f53849e52be66ab5bb51bbd3e9736b81961091d0.tar.gz
freebsd-ports-gnome-f53849e52be66ab5bb51bbd3e9736b81961091d0.tar.zst
freebsd-ports-gnome-f53849e52be66ab5bb51bbd3e9736b81961091d0.zip
Provide sensible defaults for the postgresql module (correct username for
login, correct paths). No PORTREVISION bump: if webmin has already been installed then the postgresql module must be reconfigured by hand. These changes are provided as perl regexes in the Makefile, because we only want to change specific settings that could be shuffled in the next versions of webmin (the same holds true for the postfix module).
Diffstat (limited to 'sysutils/webmin')
-rw-r--r--sysutils/webmin/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index 577542478cf7..9277670e15df 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -49,6 +49,15 @@ post-patch:
${WRKSRC}/postfix/config.sed > ${WRKSRC}/postfix/config
${RM} ${WRKSRC}/postfix/config.sed
+ ${CP} ${WRKSRC}/postgresql/config ${WRKSRC}/postgresql/config.sed
+ ${SED} -e "s@^hba_conf=.*@hba_conf=${LOCALBASE}/pgsql/data/pg_hba.conf@" \
+ -e "s@^login=.*@login=pgsql@" \
+ -e "s@^pid_file=.*@pid_file=${LOCALBASE}/pgsql/data/postmaster.pid@" \
+ -e "s@^start_cmd=.*@start_cmd=${LOCALBASE}/etc/rc.d/pgsql.sh start@" \
+ -e "s@^stop_cmd=.*@stop_cmd=${LOCALBASE}/etc/rc.d/pgsql.sh stop@" \
+ ${WRKSRC}/postgresql/config.sed > ${WRKSRC}/postgresql/config
+ ${RM} ${WRKSRC}/postgresql/config.sed
+
do-install:
@${MKDIR} ${PREFIX}/lib/webmin
@${CP} -r ${WRKSRC}/* ${PREFIX}/lib/webmin