aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/xstow
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-01-11 23:24:16 +0800
committerdanfe <danfe@FreeBSD.org>2018-01-11 23:24:16 +0800
commit0115fee286494819f4ec33920c47b1dd4922730a (patch)
tree04f9cb0012d2624a423eff125b258a44b81eaba6 /sysutils/xstow
parent93a48aabd3bb2fca444d15fb6310aa7000465299 (diff)
downloadfreebsd-ports-gnome-0115fee286494819f4ec33920c47b1dd4922730a.tar.gz
freebsd-ports-gnome-0115fee286494819f4ec33920c47b1dd4922730a.tar.zst
freebsd-ports-gnome-0115fee286494819f4ec33920c47b1dd4922730a.zip
- Don't install boilerplate COPYING file as part of documentation, define
LICENSE instead (GPLv2) - Wrap two overly long lines, properly indent USES - Use option helper target for installing documentation, and INSTALL_DATA to install plain text files which are not actually real manual pages
Diffstat (limited to 'sysutils/xstow')
-rw-r--r--sysutils/xstow/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/sysutils/xstow/Makefile b/sysutils/xstow/Makefile
index 2f59fc6b2f8d..8a1025b8a29a 100644
--- a/sysutils/xstow/Makefile
+++ b/sysutils/xstow/Makefile
@@ -9,7 +9,9 @@ MASTER_SITES= SF/${PORTNAME}/
MAINTAINER= rakuco@FreeBSD.org
COMMENT= Enhanced replacement for GNU stow written in C++
-USES= tar:bzip2
+LICENSE= GPLv2
+
+USES= tar:bzip2
GNU_CONFIGURE= yes
.if defined(WITH_DEBUG)
@@ -19,12 +21,13 @@ CONFIGURE_ARGS+= --enable-debug
PLIST_FILES= bin/merge-info bin/xstow \
man/man1/merge-info.1.gz man/man1/xstow.1.gz \
man/man5/xstow.ini.5.gz
-PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO xstow.html xstow.ini xstow.ini.html
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO xstow.html \
+ xstow.ini xstow.ini.html
OPTIONS_DEFINE= DOCS
-post-install:
- (cd ${WRKSRC} && \
- ${INSTALL_MAN} AUTHORS COPYING ChangeLog NEWS README TODO ${STAGEDIR}${DOCSDIR})
+post-install-DOCS-on:
+ ${INSTALL_DATA} ${PORTDOCS:M[ACNRT]*:S|^|${WRKSRC}/|} \
+ ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>