aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-07-04 10:48:20 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-07-04 10:48:20 +0800
commit0ad7b76a3d6ecb65380cc3164e3836c8db3a485c (patch)
tree515ddf5e5883001817d3f62a5425b03b0d557923 /sysutils
parent7c1d69b31042fe15a7cf7e4ed0d349fd2aa33777 (diff)
downloadfreebsd-ports-gnome-0ad7b76a3d6ecb65380cc3164e3836c8db3a485c.tar.gz
freebsd-ports-gnome-0ad7b76a3d6ecb65380cc3164e3836c8db3a485c.tar.zst
freebsd-ports-gnome-0ad7b76a3d6ecb65380cc3164e3836c8db3a485c.zip
- Update to 9.20140613
- Fix shebang - Update pkg-descr - Use single space after WWW: - Take maintainership Changes: http://source.joeyh.branchable.com/?p=source.git
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/debhelper/Makefile13
-rw-r--r--sysutils/debhelper/distinfo4
-rw-r--r--sysutils/debhelper/files/patch-Makefile32
-rw-r--r--sysutils/debhelper/pkg-descr12
-rw-r--r--sysutils/debhelper/pkg-plist37
5 files changed, 49 insertions, 49 deletions
diff --git a/sysutils/debhelper/Makefile b/sysutils/debhelper/Makefile
index 0c2fe0ac1228..3bbb4eea7b4b 100644
--- a/sysutils/debhelper/Makefile
+++ b/sysutils/debhelper/Makefile
@@ -2,18 +2,19 @@
# $FreeBSD$
PORTNAME= debhelper
-PORTVERSION= 9.20120909
+PORTVERSION= 9.20140613
CATEGORIES= sysutils
MASTER_SITES= DEBIAN
-DISTFILES= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Helper programs for debian/rules
-MAKE_ENV+= SITE_PERL_REL=${SITE_PERL_REL}
+MAKE_ARGS= PREFIX=${PREFIX} SITE_PERL=${SITE_PERL}
NO_BUILD= yes
-USES= perl5
+USES= gmake perl5 shebangfix
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
+SHEBANG_FILES= dh*
+
.include <bsd.port.mk>
diff --git a/sysutils/debhelper/distinfo b/sysutils/debhelper/distinfo
index 9e97985ac10a..2bc912892927 100644
--- a/sysutils/debhelper/distinfo
+++ b/sysutils/debhelper/distinfo
@@ -1,2 +1,2 @@
-SHA256 (debhelper_9.20120909.tar.gz) = fabcdb9c41975ea0a1ccc66d6e065e424ed7a2119f6f1a6f7bfb7d06701370af
-SIZE (debhelper_9.20120909.tar.gz) = 464785
+SHA256 (debhelper_9.20140613.tar.gz) = 11d02f7e45affeddf327efc923a582b3fa7ba7246a9858a2a15d5262078bcedd
+SIZE (debhelper_9.20140613.tar.gz) = 476444
diff --git a/sysutils/debhelper/files/patch-Makefile b/sysutils/debhelper/files/patch-Makefile
index 44cc9bfb8f90..2bec4ff8f10b 100644
--- a/sysutils/debhelper/files/patch-Makefile
+++ b/sysutils/debhelper/files/patch-Makefile
@@ -1,26 +1,28 @@
---- Makefile.orig 2012-08-26 22:22:58.000000000 +0800
-+++ Makefile 2012-08-26 22:23:51.000000000 +0800
-@@ -78,15 +78,14 @@
+--- Makefile.orig 2013-11-11 03:11:15.000000000 +0800
++++ Makefile 2014-07-01 01:06:16.800481843 +0800
+@@ -88,17 +88,16 @@
done;
install:
-- install -d $(DESTDIR)/usr/bin \
-- $(DESTDIR)/usr/share/debhelper/autoscripts \
+- install -d $(DESTDIR)$(PREFIX)/bin \
+- $(DESTDIR)$(PREFIX)/share/debhelper/autoscripts \
- $(DESTDIR)$(PERLLIBDIR)/Sequence \
- $(DESTDIR)$(PERLLIBDIR)/Buildsystem
-- install dh $(COMMANDS) $(DESTDIR)/usr/bin
-- install -m 0644 autoscripts/* $(DESTDIR)/usr/share/debhelper/autoscripts
++ install -d \
++ $(DESTDIR)${SITE_PERL}/Debian/Debhelper/Sequence \
++ $(DESTDIR)${SITE_PERL}/Debian/Debhelper/Buildsystem
+ install dh $(COMMANDS) $(DESTDIR)$(PREFIX)/bin
+- install -m 0644 autoscripts/* $(DESTDIR)$(PREFIX)/share/debhelper/autoscripts
- install -m 0644 Debian/Debhelper/*.pm $(DESTDIR)$(PERLLIBDIR)
++ install -m 0644 autoscripts/* $(DESTDIR)$(PREFIX)/bin
++ install -m 0644 Debian/Debhelper/*.pm $(DESTDIR)${SITE_PERL}/Debian/Debhelper
+ [ "$(PREFIX)" = /usr ] || \
+- sed -i '/$$prefix=/s@/usr@$(PREFIX)@g' $(DESTDIR)$(PERLLIBDIR)/Dh_Lib.pm
- install -m 0644 Debian/Debhelper/Sequence/*.pm $(DESTDIR)$(PERLLIBDIR)/Sequence
- install -m 0644 Debian/Debhelper/Buildsystem/*.pm $(DESTDIR)$(PERLLIBDIR)/Buildsystem
-+ install -d \
-+ $(PREFIX)/${SITE_PERL_REL}/Debian/Debhelper/Sequence \
-+ $(PREFIX)/${SITE_PERL_REL}/Debian/Debhelper/Buildsystem
-+ install dh $(COMMANDS) $(PREFIX)/bin
-+ install -m 0644 autoscripts/* $(PREFIX)/bin
-+ install -m 0644 Debian/Debhelper/*.pm $(PREFIX)/$(SITE_PERL_REL)/Debian/Debhelper
-+ install -m 0644 Debian/Debhelper/Sequence/*.pm $(PREFIX)/$(SITE_PERL_REL)/Debian/Debhelper/Sequence
-+ install -m 0644 Debian/Debhelper/Buildsystem/*.pm $(PREFIX)/$(SITE_PERL_REL)/Debian/Debhelper/Buildsystem
++ sed -i '' '/$$prefix=/s@/usr@$(PREFIX)@g' $(DESTDIR)${SITE_PERL}/Debian/Debhelper/Dh_Lib.pm
++ install -m 0644 Debian/Debhelper/Sequence/*.pm $(DESTDIR)${SITE_PERL}/Debian/Debhelper/Sequence
++ install -m 0644 Debian/Debhelper/Buildsystem/*.pm $(DESTDIR)${SITE_PERL}/Debian/Debhelper/Buildsystem
test: version
./run perl -MTest::Harness -e 'runtests grep { ! /CVS/ && ! /\.svn/ && -f && -x } @ARGV' t/* t/buildsystems/*
diff --git a/sysutils/debhelper/pkg-descr b/sysutils/debhelper/pkg-descr
index f942b0e45ccf..59786d30b374 100644
--- a/sysutils/debhelper/pkg-descr
+++ b/sysutils/debhelper/pkg-descr
@@ -1,7 +1,7 @@
-A collection of programs that can be used in a debian/rules file to automate
-common tasks related to building debian packages. Programs are included to
-install various files into your package, compress files, fix file permissions,
-integrate your package with the debian menu system, debconf, doc-base, etc.
-Most debian packages use debhelper as part of their build process.
+debhelper is a collection of programs that can be used in a debian/rules file to
+automate common tasks related to building binary debian packages. Programs are
+included to install various files into your package, compress files, fix file
+permissions, integrate your package with the debian menu system, etc. This will
+be of use only to debian developers or others who wish to build debian packages.
-WWW: http://joeyh.name/code/debhelper/
+WWW: http://joeyh.name/code/debhelper/
diff --git a/sysutils/debhelper/pkg-plist b/sysutils/debhelper/pkg-plist
index 34e74da87ab3..f9c986cd085d 100644
--- a/sysutils/debhelper/pkg-plist
+++ b/sysutils/debhelper/pkg-plist
@@ -1,17 +1,3 @@
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem.pm
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem/ant.pm
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem/autoconf.pm
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem/cmake.pm
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem/makefile.pm
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem/perl_build.pm
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem/perl_makemaker.pm
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem/python_distutils.pm
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem/qmake.pm
-%%SITE_PERL%%/Debian/Debhelper/Buildsystem/qmake_qt4.pm
-%%SITE_PERL%%/Debian/Debhelper/Dh_Buildsystems.pm
-%%SITE_PERL%%/Debian/Debhelper/Dh_Getopt.pm
-%%SITE_PERL%%/Debian/Debhelper/Dh_Lib.pm
-%%SITE_PERL%%/Debian/Debhelper/Sequence/python_support.pm
bin/dh
bin/maintscript-helper
bin/postinst-emacsen
@@ -19,14 +5,13 @@ bin/postinst-icons
bin/postinst-init
bin/postinst-init-nostart
bin/postinst-init-restart
+bin/postinst-init-tmpfiles
bin/postinst-makeshlibs
bin/postinst-menu
bin/postinst-menu-method
-bin/postinst-mime
bin/postinst-modules
bin/postinst-moveconffile
bin/postinst-python
-bin/postinst-sharedmimeinfo
bin/postinst-suid
bin/postinst-ucf
bin/postinst-usrlocal
@@ -39,13 +24,12 @@ bin/postrm-init
bin/postrm-makeshlibs
bin/postrm-menu
bin/postrm-menu-method
-bin/postrm-mime
bin/postrm-modules
bin/postrm-sgmlcatalog
-bin/postrm-sharedmimeinfo
bin/postrm-suid
bin/postrm-ucf
bin/postrm-xfonts
+bin/preinst-emacsen
bin/preinst-moveconffile
bin/preinst-sgmlcatalog
bin/prerm-emacsen
@@ -54,8 +38,21 @@ bin/prerm-init-norestart
bin/prerm-python
bin/prerm-usrlocal
bin/prerm-wm
-@dirrmtry %%SITE_PERL%%/Debian/Debhelper/Sequence
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem.pm
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem/ant.pm
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem/autoconf.pm
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem/cmake.pm
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem/makefile.pm
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem/perl_build.pm
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem/python_distutils.pm
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem/qmake.pm
+%%SITE_PERL%%/Debian/Debhelper/Buildsystem/qmake_qt4.pm
+%%SITE_PERL%%/Debian/Debhelper/Dh_Buildsystems.pm
+%%SITE_PERL%%/Debian/Debhelper/Dh_Getopt.pm
+%%SITE_PERL%%/Debian/Debhelper/Dh_Lib.pm
+%%SITE_PERL%%/Debian/Debhelper/Sequence/python_support.pm
@dirrmtry %%SITE_PERL%%/Debian/Debhelper/Buildsystem
+@dirrmtry %%SITE_PERL%%/Debian/Debhelper/Sequence
@dirrmtry %%SITE_PERL%%/Debian/Debhelper
@dirrmtry %%SITE_PERL%%/Debian
-@dirrmtry %%DATADIR%%