aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-11-17 02:02:26 +0800
committercrees <crees@FreeBSD.org>2011-11-17 02:02:26 +0800
commit0f391b924a889d4e7693d3a0da6eb5ef348f2765 (patch)
tree920f0d940349785f85fc646284d06b89547a25bb /sysutils
parentca51a2791faf2e39982c7bb6c0e4d3327c3ada72 (diff)
downloadfreebsd-ports-gnome-0f391b924a889d4e7693d3a0da6eb5ef348f2765.tar.gz
freebsd-ports-gnome-0f391b924a889d4e7693d3a0da6eb5ef348f2765.tar.zst
freebsd-ports-gnome-0f391b924a889d4e7693d3a0da6eb5ef348f2765.zip
Resurrect cpuburn.
Andriy Gapon has volunteered to maintain it, and I will host its distfiles. Submitted by: avg Feature safe: yes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cpuburn/Makefile42
-rw-r--r--sysutils/cpuburn/distinfo2
-rw-r--r--sysutils/cpuburn/pkg-descr3
3 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/cpuburn/Makefile b/sysutils/cpuburn/Makefile
new file mode 100644
index 000000000000..de51e77b8c79
--- /dev/null
+++ b/sysutils/cpuburn/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: cpuburn
+# Date created: Apr 1, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpuburn
+DISTVERSION= 1_4
+CATEGORIES= sysutils
+MASTER_SITES= http://www.bayofrum.net/dist/${PORTNAME}/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= avg
+DISTNAME= cpuburn_${DISTVERSION}
+EXTRACT_SUFX= _tar.gz
+
+MAINTAINER= avg@FreeBSD.org
+COMMENT= CPU/memory stress testing utilities
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+ONLY_FOR_ARCHS= i386 amd64
+
+PORTDOCS= README Design
+CPUS= BX K6 K7 MMX P5 P6
+PLIST_FILES= ${CPUS:S+^+bin/burn+}
+
+do-build:
+.for CPU in ${CPUS}
+ ${CC} -m32 -s -nostdlib -o ${WRKSRC}/burn${CPU} ${WRKSRC}/burn${CPU}.S
+.endfor
+
+do-install:
+.for CPU in ${CPUS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/burn${CPU} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Design ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/cpuburn/distinfo b/sysutils/cpuburn/distinfo
new file mode 100644
index 000000000000..44b57ecd189b
--- /dev/null
+++ b/sysutils/cpuburn/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cpuburn_1_4_tar.gz) = 1b2a1672f455545a28d0f038737e792e8c3b97789f2029f765847fc2a807244a
+SIZE (cpuburn_1_4_tar.gz) = 7373
diff --git a/sysutils/cpuburn/pkg-descr b/sysutils/cpuburn/pkg-descr
new file mode 100644
index 000000000000..15f45d27edc7
--- /dev/null
+++ b/sysutils/cpuburn/pkg-descr
@@ -0,0 +1,3 @@
+CPUburn contains several utilities for stress testing various x86
+CPUs. To get the most of out of these utilities read the documentation
+under share/doc/cpuburn.