aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /sysutils
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadfreebsd-ports-gnome-0f583d87000061087521fb77c44c9055d122d787.tar.gz
freebsd-ports-gnome-0f583d87000061087521fb77c44c9055d122d787.tar.zst
freebsd-ports-gnome-0f583d87000061087521fb77c44c9055d122d787.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/baloo-widgets/Makefile5
-rw-r--r--sysutils/baloo/Makefile5
-rw-r--r--sysutils/filelight-kde4/Makefile4
-rw-r--r--sysutils/k3b-kde4/Makefile4
-rw-r--r--sysutils/kcm-polkit-kde/Makefile10
-rw-r--r--sysutils/kcron/Makefile4
-rw-r--r--sysutils/kdeadmin4/Makefile9
-rw-r--r--sysutils/kdf/Makefile4
-rw-r--r--sysutils/kdirstat/Makefile4
-rw-r--r--sysutils/kfilemetadata/Makefile4
-rw-r--r--sysutils/kfloppy/Makefile4
-rw-r--r--sysutils/knutclient-kde4/Makefile4
-rw-r--r--sysutils/krename-kde4/Makefile4
-rw-r--r--sysutils/kshutdown-kde4/Makefile4
-rw-r--r--sysutils/ksysguardd/Makefile3
-rw-r--r--sysutils/ksystemlog/Makefile4
-rw-r--r--sysutils/kuser/Makefile4
-rw-r--r--sysutils/nepomuk-core/Makefile4
-rw-r--r--sysutils/nepomuk-widgets/Makefile4
-rw-r--r--sysutils/plasma-applet-apcups/Makefile4
-rw-r--r--sysutils/policykit-qt/Makefile4
-rw-r--r--sysutils/polkit-kde/Makefile4
-rw-r--r--sysutils/polkit-qt/Makefile4
-rw-r--r--sysutils/qzeitgeist/Makefile4
-rw-r--r--sysutils/sweeper/Makefile4
25 files changed, 54 insertions, 58 deletions
diff --git a/sysutils/baloo-widgets/Makefile b/sysutils/baloo-widgets/Makefile
index 28be587a24f2..288cb18a961f 100644
--- a/sysutils/baloo-widgets/Makefile
+++ b/sysutils/baloo-widgets/Makefile
@@ -10,9 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= The BalooWidgets library
-USE_KDE4= automoc4 baloo kfilemetadata
-
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= automoc4 baloo kfilemetadata
USE_QT4= corelib qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/sysutils/baloo/Makefile b/sysutils/baloo/Makefile
index f9f5948ef593..4e8e88b2f0c1 100644
--- a/sysutils/baloo/Makefile
+++ b/sysutils/baloo/Makefile
@@ -15,10 +15,9 @@ CONFLICTS_INSTALL= kde-runtime-4.12.*
LIB_DEPENDS= libxapian.so:databases/xapian-core \
libqjson.so:devel/qjson
-USE_KDE4= akonadi automoc4 kdelibs kfilemetadata \
+USES= cmake:outsource gmake kde:4 tar:xz
+USE_KDE= akonadi automoc4 kdelibs kfilemetadata \
pimlibs
-
-USES= cmake:outsource gmake tar:xz
USE_QT4= corelib qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/sysutils/filelight-kde4/Makefile b/sysutils/filelight-kde4/Makefile
index 37a489c96269..1e32f993b39d 100644
--- a/sysutils/filelight-kde4/Makefile
+++ b/sysutils/filelight-kde4/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Map of concentric segmented-rings representing file system
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/sysutils/k3b-kde4/Makefile b/sysutils/k3b-kde4/Makefile
index d7060cedab9e..dff19b4e5c8f 100644
--- a/sysutils/k3b-kde4/Makefile
+++ b/sysutils/k3b-kde4/Makefile
@@ -16,10 +16,10 @@ LIB_DEPENDS= libcdda_paranoia.so:audio/cdparanoia \
RUN_DEPENDS= cdrecord:sysutils/cdrtools
BUILD_DEPENDS= cdrecord:sysutils/cdrtools
-USES= cmake gettext pkgconfig shared-mime-info tar:xz
+USES= cmake gettext kde:4 pkgconfig shared-mime-info tar:xz
CMAKE_ARGS= -DK3B_BUILD_K3BSETUP:BOOL=OFF \
-DK3B_ENABLE_MUSICBRAINZ:BOOL=OFF
-USE_KDE4= automoc4 kdelibs libkcddb
+USE_KDE= automoc4 kdelibs libkcddb
USE_QT4= gui phonon qt3support webkit \
qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/sysutils/kcm-polkit-kde/Makefile b/sysutils/kcm-polkit-kde/Makefile
index 8ace26d3b485..d56099ef6afb 100644
--- a/sysutils/kcm-polkit-kde/Makefile
+++ b/sysutils/kcm-polkit-kde/Makefile
@@ -12,11 +12,11 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Polkit-KDE configuration module
LIB_DEPENDS= libpolkit-qt-agent-1.so:sysutils/polkit-qt
-RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/libexec/polkit-kde-authentication-agent-1:sysutils/polkit-kde
+RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/libexec/polkit-kde-authentication-agent-1:sysutils/polkit-kde
-USE_KDE4= kdelibs automoc4
+USES= cmake gmake kde:4 pkgconfig tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= dbus xml moc_build qmake_build rcc_build uic_build
-USES= cmake gmake pkgconfig tar:bzip2
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-kcmodules-1
@@ -24,8 +24,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-kcmodules-1
PORTDATE= 20121008
post-patch:
- ${REINPLACE_CMD} -e 's,/usr,${KDE4_PREFIX},' \
- -e 's,/etc,${KDE4_PREFIX}/etc,' \
+ ${REINPLACE_CMD} -e 's,/usr,${KDE_PREFIX},' \
+ -e 's,/etc,${KDE_PREFIX}/etc,' \
${WRKSRC}/helper/polkitkde1helper.cpp \
${WRKSRC}/polkitactions/ActionWidget.cpp \
${WRKSRC}/polkitconfig/kcmpolkitconfig.cpp
diff --git a/sysutils/kcron/Makefile b/sysutils/kcron/Makefile
index 21be2ddf6629..31b1577ea088 100644
--- a/sysutils/kcron/Makefile
+++ b/sysutils/kcron/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE task scheduler
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/sysutils/kdeadmin4/Makefile b/sysutils/kdeadmin4/Makefile
index 706ce1998ddd..43ee01a9e8bb 100644
--- a/sysutils/kdeadmin4/Makefile
+++ b/sysutils/kdeadmin4/Makefile
@@ -7,19 +7,18 @@ CATEGORIES= sysutils kde
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Administration applications (meta port)
-USE_KDE4= # blank, needed to get KDE4_VERSION
-USES= metaport
+USES= kde:4 metaport
OPTIONS_DEFINE= KCRON KSYSTEMLOG KUSER
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
KCRON_DESC= Task scheduler
-KCRON_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kcm_cron.so:sysutils/kcron
+KCRON_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/kcm_cron.so:sysutils/kcron
KSYSTEMLOG_DESC= System log viewer
-KSYSTEMLOG_RUN_DEPENDS= ${KDE4_PREFIX}/bin/ksystemlog:sysutils/ksystemlog
+KSYSTEMLOG_RUN_DEPENDS= ${KDE_PREFIX}/bin/ksystemlog:sysutils/ksystemlog
KUSER_DESC= User management application
-KUSER_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kuser:sysutils/kuser
+KUSER_RUN_DEPENDS= ${KDE_PREFIX}/bin/kuser:sysutils/kuser
.include <bsd.port.mk>
diff --git a/sysutils/kdf/Makefile b/sysutils/kdf/Makefile
index 623a3388321f..3abd5b64556c 100644
--- a/sysutils/kdf/Makefile
+++ b/sysutils/kdf/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Shows free space of devices for KDE
-USE_KDE4= automoc4 kdelibs
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= automoc4 kdelibs
USE_QT4= qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/sysutils/kdirstat/Makefile b/sysutils/kdirstat/Makefile
index cf9de24f9c97..85eac0560087 100644
--- a/sysutils/kdirstat/Makefile
+++ b/sysutils/kdirstat/Makefile
@@ -15,9 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
WRKSRC= ${WRKDIR}/jeromerobert-k4dirstat-3a4663ee20e7
-USES= cmake cpe desktop-file-utils gettext-tools tar:bzip2
+USES= cmake cpe desktop-file-utils gettext-tools kde:4 tar:bzip2
CPE_VENDOR= kdirstat_project
-USE_KDE4= automoc4 kdelibs libkonq
+USE_KDE= automoc4 kdelibs libkonq
USE_QT4= moc_build qmake_build rcc_build uic_build
INSTALLS_ICONS= yes
diff --git a/sysutils/kfilemetadata/Makefile b/sysutils/kfilemetadata/Makefile
index 4c3629c9662e..026f95fbf04f 100644
--- a/sysutils/kfilemetadata/Makefile
+++ b/sysutils/kfilemetadata/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4 \
libepub.so:textproc/ebook-tools \
libqmobipocket.so:graphics/kdegraphics4-mobipocket
-USE_KDE4= automoc4 kdelibs
-USES= cmake:outsource pkgconfig tar:xz
+USES= cmake:outsource kde:4 pkgconfig tar:xz
+USE_KDE= automoc4 kdelibs
USE_QT4= corelib qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/sysutils/kfloppy/Makefile b/sysutils/kfloppy/Makefile
index 0331e7bae14f..1379fc6ef8d3 100644
--- a/sysutils/kfloppy/Makefile
+++ b/sysutils/kfloppy/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Floppy disk formatter for KDE
-USE_KDE4= automoc4 kdelibs
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= automoc4 kdelibs
USE_QT4= qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/sysutils/knutclient-kde4/Makefile b/sysutils/knutclient-kde4/Makefile
index 7d289a93d491..4d08b2b03f31 100644
--- a/sysutils/knutclient-kde4/Makefile
+++ b/sysutils/knutclient-kde4/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= libqimageblitz.so:x11/qimageblitz
CONFLICTS= knutclient-0.*
-USES= cmake gettext
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4
+USE_KDE= kdelibs automoc4
USE_QT4= corelib gui qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/sysutils/krename-kde4/Makefile b/sysutils/krename-kde4/Makefile
index bdded72607f6..47aade9f0930 100644
--- a/sysutils/krename-kde4/Makefile
+++ b/sysutils/krename-kde4/Makefile
@@ -13,8 +13,8 @@ LIB_DEPENDS= libtag.so:audio/taglib \
libexiv2.so:graphics/exiv2 \
libpodofo.so:graphics/podofo
-USES= cmake:outsource gettext tar:bzip2
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= qmake_build moc_build rcc_build uic_build
post-patch:
diff --git a/sysutils/kshutdown-kde4/Makefile b/sysutils/kshutdown-kde4/Makefile
index ccbcb5c933b3..589dd661690d 100644
--- a/sysutils/kshutdown-kde4/Makefile
+++ b/sysutils/kshutdown-kde4/Makefile
@@ -9,9 +9,9 @@ DISTNAME= ${PORTNAME}-source-${DISTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Advanced shutdown utility for KDE
-USES= alias cmake:outsource compiler:c++0x gettext zip
+USES= alias cmake:outsource compiler:c++0x gettext kde:4 zip
USE_QT4= moc_build qmake_build rcc_build uic_build
-USE_KDE4= automoc4 workspace
+USE_KDE= automoc4 workspace
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
diff --git a/sysutils/ksysguardd/Makefile b/sysutils/ksysguardd/Makefile
index df204aacdceb..a12203a6b984 100644
--- a/sysutils/ksysguardd/Makefile
+++ b/sysutils/ksysguardd/Makefile
@@ -11,8 +11,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= KDE System Guard Daemon
DISTINFO_FILE= ${.CURDIR:H:H}/x11/kde4-workspace/distinfo
-USE_KDE4= # blank, needed to get KDE4_VERSION
-USES= cmake tar:xz
+USES= cmake kde:4 tar:xz
CMAKE_ARGS+= -DBIN_INSTALL_DIR:STRING="${PREFIX}/bin" \
-DSYSCONF_INSTALL_DIR:STRING="${PREFIX}/etc"
diff --git a/sysutils/ksystemlog/Makefile b/sysutils/ksystemlog/Makefile
index cd343555b966..a3e660ce2751 100644
--- a/sysutils/ksystemlog/Makefile
+++ b/sysutils/ksystemlog/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE system log application
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/sysutils/kuser/Makefile b/sysutils/kuser/Makefile
index 829c6577aa6e..69e42f00060b 100644
--- a/sysutils/kuser/Makefile
+++ b/sysutils/kuser/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE user manager
-USE_KDE4= kdelibs pimlibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs pimlibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/sysutils/nepomuk-core/Makefile b/sysutils/nepomuk-core/Makefile
index 0b3542a51ca8..4629b818bd4a 100644
--- a/sysutils/nepomuk-core/Makefile
+++ b/sysutils/nepomuk-core/Makefile
@@ -18,9 +18,9 @@ LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4 \
libepub.so:textproc/ebook-tools \
libqmobipocket.so:graphics/kdegraphics4-mobipocket
-USE_KDE4= automoc4 baloo kdelibs kfilemetadata \
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= automoc4 baloo kdelibs kfilemetadata \
ontologies soprano
-USES= cmake:outsource tar:xz
USE_QT4= corelib dbus gui qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
MAKE_ENV= XDG_CONFIG_HOME=/dev/null
diff --git a/sysutils/nepomuk-widgets/Makefile b/sysutils/nepomuk-widgets/Makefile
index 0e437d03db7e..ce06cf0b7139 100644
--- a/sysutils/nepomuk-widgets/Makefile
+++ b/sysutils/nepomuk-widgets/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= The NepomukWidget libraries
-USE_KDE4= kdelibs automoc4 soprano nepomuk-core
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4 soprano nepomuk-core
USE_QT4= corelib dbus gui moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/sysutils/plasma-applet-apcups/Makefile b/sysutils/plasma-applet-apcups/Makefile
index 30271ca30caf..46e7b62df715 100644
--- a/sysutils/plasma-applet-apcups/Makefile
+++ b/sysutils/plasma-applet-apcups/Makefile
@@ -13,8 +13,8 @@ COMMENT= Plasma applet to monitor the status of APC UPS
PROJECTHOST= plasma-apcups
-USES= cmake gettext
-USE_KDE4= automoc4 kdelibs
+USES= cmake gettext kde:4
+USE_KDE= automoc4 kdelibs
USE_QT4= qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/sysutils/policykit-qt/Makefile b/sysutils/policykit-qt/Makefile
index 835a6db38f83..871d0502245c 100644
--- a/sysutils/policykit-qt/Makefile
+++ b/sysutils/policykit-qt/Makefile
@@ -14,10 +14,10 @@ COMMENT= PolicyKit manager for Qt
LIB_DEPENDS= libpolkit.so:sysutils/policykit
USE_LDCONFIG= yes
-USE_KDE4= automoc4
+USES= cmake gettext kde:4 pkgconfig tar:bzip2
+USE_KDE= automoc4
USE_QT4= corelib dbus gui network svg xml \
qmake_build moc_build rcc_build uic_build
-USES= cmake gettext pkgconfig tar:bzip2
PORTSCOUT= limit:^0
diff --git a/sysutils/polkit-kde/Makefile b/sysutils/polkit-kde/Makefile
index 693e01375b7d..23794cae51c5 100644
--- a/sysutils/polkit-kde/Makefile
+++ b/sysutils/polkit-kde/Makefile
@@ -15,9 +15,9 @@ LICENSE= GPLv2
LIB_DEPENDS= libpolkit-qt-agent-1.so:sysutils/polkit-qt
-USE_KDE4= kdelibs automoc4
+USES= cmake kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
-USES= cmake tar:bzip2
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
diff --git a/sysutils/polkit-qt/Makefile b/sysutils/polkit-qt/Makefile
index 6af126e46d3c..795c6ee1f9f3 100644
--- a/sysutils/polkit-qt/Makefile
+++ b/sysutils/polkit-qt/Makefile
@@ -19,11 +19,11 @@ CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF \
-DBUILD_TEST:BOOL=OFF \
-DUSE_QT4:BOOL=ON
+USES= cmake:outsource kde:4 pkgconfig tar:bzip2
USE_GNOME= glib20
-USE_KDE4= automoc4
+USE_KDE= automoc4
USE_QT4= corelib dbus gui \
qmake_build moc_build rcc_build uic_build
-USES= cmake:outsource pkgconfig tar:bzip2
USE_LDCONFIG= yes
post-patch:
diff --git a/sysutils/qzeitgeist/Makefile b/sysutils/qzeitgeist/Makefile
index 0e340469d6cc..40e0cdda5ca5 100644
--- a/sysutils/qzeitgeist/Makefile
+++ b/sysutils/qzeitgeist/Makefile
@@ -20,10 +20,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= rapper:textproc/raptor2 \
${PYTHON_SITELIBDIR}/rdflib/__init__.py:textproc/py-rdflib
-USE_KDE4= automoc4
+USES= cmake kde:4 python:build tar:bzip2
+USE_KDE= automoc4
USE_QT4= dbus declarative qtestlib \
moc_build qmake_build rcc_build uic_build
-USES= cmake python:build tar:bzip2
USE_LDCONFIG= yes
# To be kept in sync with sysutils/zeitgeist.
diff --git a/sysutils/sweeper/Makefile b/sysutils/sweeper/Makefile
index 8e29156c6b52..332f4d11f3dd 100644
--- a/sysutils/sweeper/Makefile
+++ b/sysutils/sweeper/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Cleans temporal files for KDE
-USE_KDE4= automoc4 kdelibs
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= automoc4 kdelibs
USE_QT4= qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>