aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-11-13 02:40:26 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-11-13 02:40:26 +0800
commit0fe4c2cd0bae65b144b2b9d69eb6c5632bb65546 (patch)
tree0220e70b0e415f35d706e2f959b70f9be9feb4ce /sysutils
parentf973c32f41cc709a195e8ad42c8d506dc7a23f0d (diff)
downloadfreebsd-ports-gnome-0fe4c2cd0bae65b144b2b9d69eb6c5632bb65546.tar.gz
freebsd-ports-gnome-0fe4c2cd0bae65b144b2b9d69eb6c5632bb65546.tar.zst
freebsd-ports-gnome-0fe4c2cd0bae65b144b2b9d69eb6c5632bb65546.zip
Add fusefs-ext4fuse, an EXT4 implementation for FUSE.
Feature safe: yes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-ext4fuse/Makefile35
-rw-r--r--sysutils/fusefs-ext4fuse/distinfo2
-rw-r--r--sysutils/fusefs-ext4fuse/pkg-descr3
4 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5e13d2da1d46..6a76e3e8d227 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -259,6 +259,7 @@
SUBDIR += fusefs-cryptofs
SUBDIR += fusefs-curlftpfs
SUBDIR += fusefs-encfs
+ SUBDIR += fusefs-ext4fuse
SUBDIR += fusefs-funionfs
SUBDIR += fusefs-fur
SUBDIR += fusefs-fusexmp_fh
diff --git a/sysutils/fusefs-ext4fuse/Makefile b/sysutils/fusefs-ext4fuse/Makefile
new file mode 100644
index 000000000000..1fd9f47579d0
--- /dev/null
+++ b/sysutils/fusefs-ext4fuse/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: fusefs-ext4fuse
+# Date created: 12 Nov 2011
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ext4fuse
+PORTVERSION= 20111112
+CATEGORIES= sysutils
+MASTER_SITES= CRITICAL
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= EXT4 implementation for FUSE
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= fusefs-libs>=2.7.2:${PORTSDIR}/sysutils/fusefs-libs
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs \
+ execinfo.1:${PORTSDIR}/devel/libexecinfo
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+USE_GMAKE= yes
+
+MAKE_JOBS_SAFE= yes
+
+ALL_TARGET= ${PORTNAME}
+
+PLIST_FILES= bin/ext4fuse
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-ext4fuse/distinfo b/sysutils/fusefs-ext4fuse/distinfo
new file mode 100644
index 000000000000..eeda8847fb23
--- /dev/null
+++ b/sysutils/fusefs-ext4fuse/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ext4fuse-20111112.tar.gz) = 7d5be9b5cf0a156a5b93358fb950bc5a5009428f2c378fa8f127f69e6e2b1ffa
+SIZE (ext4fuse-20111112.tar.gz) = 24895
diff --git a/sysutils/fusefs-ext4fuse/pkg-descr b/sysutils/fusefs-ext4fuse/pkg-descr
new file mode 100644
index 000000000000..92e8b616b9a1
--- /dev/null
+++ b/sysutils/fusefs-ext4fuse/pkg-descr
@@ -0,0 +1,3 @@
+EXT4 implementation for FUSE.
+
+WWW: https://github.com/gerard/ext4fuse/