aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-05-27 23:27:15 +0800
committerRyan Steinmetz <zi@FreeBSD.org>2012-05-27 23:27:15 +0800
commit16db829d8314c8c75e12c8993092ab5ab1b798b0 (patch)
treeb829c6504e7b931bd65a7610d0e52b49167c7fe8 /sysutils
parenta6237e6e988c36f60029e18c1e010d218d2c99f9 (diff)
downloadfreebsd-ports-gnome-16db829d8314c8c75e12c8993092ab5ab1b798b0.tar.gz
freebsd-ports-gnome-16db829d8314c8c75e12c8993092ab5ab1b798b0.tar.zst
freebsd-ports-gnome-16db829d8314c8c75e12c8993092ab5ab1b798b0.zip
New port: sysutils/vpnc-scripts
A collection of scripts that do route modification and other changes to a system after establishing a VPN connection to a remote network. These are typically used with openconnect or Cisco's VPN client. WWW: http://git.infradead.org/users/dwmw2/vpnc-scripts.git
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/vpnc-scripts/Makefile29
-rw-r--r--sysutils/vpnc-scripts/distinfo2
-rw-r--r--sysutils/vpnc-scripts/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 51cde1241de5..ddb56e38ba2f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -960,6 +960,7 @@
SUBDIR += vobcopy
SUBDIR += volman
SUBDIR += vordog
+ SUBDIR += vpnc-scripts
SUBDIR += vstrip
SUBDIR += vttest
SUBDIR += wait_on
diff --git a/sysutils/vpnc-scripts/Makefile b/sysutils/vpnc-scripts/Makefile
new file mode 100644
index 000000000000..70b20376c4db
--- /dev/null
+++ b/sysutils/vpnc-scripts/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: vpnc-scripts
+# Date created: 20 Apr 2012
+# Whom: Ryan Steinmetz <zi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vpnc-scripts
+PORTVERSION= 20120526
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.infradead.org/pub/${PORTNAME}/ \
+ http://mirrors.rit.edu/zi/
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= A collection of scripts to setup routes and other changes for a VPN
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+NO_BUILD= yes
+
+PLIST_FILES= sbin/vpnc-script sbin/vpnc-script-sshd sbin/vpnc-script-ptrtd
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/vpnc-script ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/vpnc-script-sshd ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/vpnc-script-ptrtd ${PREFIX}/sbin
+
+.include <bsd.port.mk>
diff --git a/sysutils/vpnc-scripts/distinfo b/sysutils/vpnc-scripts/distinfo
new file mode 100644
index 000000000000..3db5d4974fb0
--- /dev/null
+++ b/sysutils/vpnc-scripts/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vpnc-scripts-20120526.tar.gz) = 5058b70f2b40528ec4543273e099f97337cb1b0cbf8ba92d39e4050bb20f8998
+SIZE (vpnc-scripts-20120526.tar.gz) = 18091
diff --git a/sysutils/vpnc-scripts/pkg-descr b/sysutils/vpnc-scripts/pkg-descr
new file mode 100644
index 000000000000..4e5c7e5a94e2
--- /dev/null
+++ b/sysutils/vpnc-scripts/pkg-descr
@@ -0,0 +1,6 @@
+A collection of scripts that do route modification and other changes to
+a system after establishing a VPN connection to a remote network.
+
+These are typically used with openconnect or Cisco's VPN client.
+
+WWW: http://git.infradead.org/users/dwmw2/vpnc-scripts.git