aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorGlen Barber <gjb@FreeBSD.org>2013-03-01 05:02:28 +0800
committerGlen Barber <gjb@FreeBSD.org>2013-03-01 05:02:28 +0800
commit1735026060ee8b2771a3e62ece042180d61fd8ee (patch)
tree18a3ca9ea956b6eb383c478a6b71d5e8dd7e59a8 /sysutils
parent6dcbb6a6fe772074318e978ac56224189817edc2 (diff)
downloadfreebsd-ports-gnome-1735026060ee8b2771a3e62ece042180d61fd8ee.tar.gz
freebsd-ports-gnome-1735026060ee8b2771a3e62ece042180d61fd8ee.tar.zst
freebsd-ports-gnome-1735026060ee8b2771a3e62ece042180d61fd8ee.zip
- Update to 3.5.0a2
New features: - cf-promises flag --parse-tree is replaced by --policy-output-format=, requiring the user to specify the output format (none, cf, json) - cf-promises allows partial check of policy (without body common control) without integrity check; --full-check enforces integrity check - agent binaries support JSON input format (.json file as generated by cf-promises) - cf-key: new options --trust-key/-t and --print-digest/-p - Class "failsafe_fallback" is defined in failsafe.cf when main policy contains errors and failsafe is run because of this - add scope attribute for body classes (Redmine #2013) Changes: - process promises don't log if processes are out of range unless you run in verbose mode - reports promises are now allowed in any context (Redmine #2005) - cf-report has been removed - cf-execd: --once implies --no-fork Bugfixes: - do not wait for splaytime when executing only once - disable xml editing functionality when libxml2 doesn't provide necessary APIs (Redmine #1937) Approved by: cy (maintainer, implicit)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cfengine-devel/Makefile5
-rw-r--r--sysutils/cfengine-devel/distinfo4
-rw-r--r--sysutils/cfengine-devel/files/patch-doc-build-stdlib.c56
-rw-r--r--sysutils/cfengine-devel/files/patch-libutils-ip_address.c10
-rw-r--r--sysutils/cfengine-devel/pkg-plist2
5 files changed, 14 insertions, 63 deletions
diff --git a/sysutils/cfengine-devel/Makefile b/sysutils/cfengine-devel/Makefile
index 69c04f8a21bd..4dbf163f28c9 100644
--- a/sysutils/cfengine-devel/Makefile
+++ b/sysutils/cfengine-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cfengine
-PORTVERSION= 3.5.0a1
-PORTREVISION= 2
+PORTVERSION= 3.5.0a2
PORTEPOCH= 1
CATEGORIES= sysutils
PKGNAMESUFFIX= -devel
@@ -78,7 +77,7 @@ LIB_DEPENDS+= virt.1000:${PORTSDIR}/devel/libvirt
.endif
MAN8= cf-agent.8 cf-key.8 cf-monitord.8 \
- cf-report.8 cf-serverd.8 cf-execd.8 \
+ cf-serverd.8 cf-execd.8 \
cf-promises.8 cf-runagent.8
post-patch:
diff --git a/sysutils/cfengine-devel/distinfo b/sysutils/cfengine-devel/distinfo
index 7103a18967ae..a5baa9a2e022 100644
--- a/sysutils/cfengine-devel/distinfo
+++ b/sysutils/cfengine-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cfengine-3.5.0a1.tar.gz) = 47d3eff2321360e0c5287e7a4d2c6d57acb90b279fb28fbc5571307716f0d225
-SIZE (cfengine-3.5.0a1.tar.gz) = 4773963
+SHA256 (cfengine-3.5.0a2.tar.gz) = 39ab4e6237a52c8b41698f0ca0f0ecddcc4b722782eedab07ba359d6bd3c71fa
+SIZE (cfengine-3.5.0a2.tar.gz) = 4767372
diff --git a/sysutils/cfengine-devel/files/patch-doc-build-stdlib.c b/sysutils/cfengine-devel/files/patch-doc-build-stdlib.c
deleted file mode 100644
index 05816b0944fc..000000000000
--- a/sysutils/cfengine-devel/files/patch-doc-build-stdlib.c
+++ /dev/null
@@ -1,56 +0,0 @@
---- docs/tools/build-stdlib.c.orig 2013-02-22 07:56:59.781081590 -0500
-+++ docs/tools/build-stdlib.c 2013-02-22 07:56:21.000000000 -0500
-@@ -9,7 +9,7 @@
- #define true 1
-
- #include <stdio.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include <string.h>
-
- struct Item
-@@ -25,7 +25,7 @@
- struct Item *SortItemListNames(struct Item *list);
- int IncludeManualFile(FILE *fout,char *file);
-
--
-+int
- main(int argc, char *argv[])
-
- { FILE *fin,*fout = NULL;
-@@ -35,7 +35,7 @@
- if ((fin = fopen(argv[1],"r")) == NULL)
- {
- printf("Could not open the %s file\n", argv[1]);
-- return;
-+ return 1;
- }
-
-
-@@ -67,7 +67,7 @@
- if ((fout = fopen(name,"w")) == NULL)
- {
- printf("Could not open output file %s\n",name);
-- return;
-+ return 1;
- }
-
- fprintf(fout,"%s",buffer);
-@@ -92,7 +92,7 @@
- if ((fout = fopen("CfengineStdLibrary.texinfo","w")) == NULL)
- {
- printf("Could not open the CfengineStdLibrary.texinfo file\n");
-- return;
-+ return 1;
- }
-
- IncludeManualFile(fout,"preamble.texinfo");
-@@ -131,7 +131,7 @@
- if ((fp = fopen(file,"r")) == NULL)
- {
- printf("Could not read %s\n",file);
-- return;
-+ return 1;
- }
-
- while(!feof(fp))
diff --git a/sysutils/cfengine-devel/files/patch-libutils-ip_address.c b/sysutils/cfengine-devel/files/patch-libutils-ip_address.c
new file mode 100644
index 000000000000..952ceb299233
--- /dev/null
+++ b/sysutils/cfengine-devel/files/patch-libutils-ip_address.c
@@ -0,0 +1,10 @@
+--- libutils/ip_address.c.orig 2013-02-28 14:46:19.800950567 -0500
++++ libutils/ip_address.c 2013-02-28 14:46:32.928950862 -0500
+@@ -25,6 +25,7 @@
+ #include <stdint.h>
+ #include <ctype.h>
+ #include <sys/socket.h>
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+
diff --git a/sysutils/cfengine-devel/pkg-plist b/sysutils/cfengine-devel/pkg-plist
index ec8262632cd7..31ebc155be24 100644
--- a/sysutils/cfengine-devel/pkg-plist
+++ b/sysutils/cfengine-devel/pkg-plist
@@ -7,7 +7,6 @@ sbin/cf-execd
sbin/cf-key
sbin/cf-monitord
sbin/cf-promises
-sbin/cf-report
sbin/cf-runagent
sbin/cf-serverd
sbin/rpmvercmp
@@ -15,7 +14,6 @@ share/cfengine/CoreBase/cf-sketch-runfile.cf
share/cfengine/CoreBase/def.cf
share/cfengine/CoreBase/promises.cf
share/cfengine/CoreBase/controls/cf_execd.cf
-share/cfengine/CoreBase/controls/cf_report.cf
share/cfengine/CoreBase/controls/cf_agent.cf
share/cfengine/CoreBase/controls/cf_runagent.cf
share/cfengine/CoreBase/controls/cf_monitord.cf