aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-26 16:31:19 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-26 16:31:19 +0800
commit173934c619ee04e35cbb7572f004ba5f55667bdb (patch)
tree280970a451f3cac5ecbc28ba9143519b46d4d56c /sysutils
parentfca4f090b75fb9f7edb777137cc282b73e6c6d6d (diff)
downloadfreebsd-ports-gnome-173934c619ee04e35cbb7572f004ba5f55667bdb.tar.gz
freebsd-ports-gnome-173934c619ee04e35cbb7572f004ba5f55667bdb.tar.zst
freebsd-ports-gnome-173934c619ee04e35cbb7572f004ba5f55667bdb.zip
Support staging
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/crashme/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/sysutils/crashme/Makefile b/sysutils/crashme/Makefile
index a859425c3288..82e7dc2958e0 100644
--- a/sysutils/crashme/Makefile
+++ b/sysutils/crashme/Makefile
@@ -5,7 +5,7 @@ PORTNAME= crashme
PORTVERSION= 2.4
PORTREVISION= 1
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITES= LOCAL
MASTER_SITE_SUBDIR=kris
DISTNAME= crashme
EXTRACT_SUFX= .tgz
@@ -13,19 +13,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gjc@alum.mit.edu
COMMENT= A tool to test an operating system's robustness
-NO_STAGE= yes
# according to license.rtf, and using the most restrictive one:
LICENSE= LGPL21
-USE_GMAKE= yes
+USES= gmake
NO_WRKSUBDIR= yes
+
MAKEFILE= makefile
-MAN1= crashme.1
-PLIST_FILES= bin/crashme bin/pddet
+PLIST_FILES= bin/crashme bin/pddet man/man1/crashme.1.gz
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/crashme ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/pddet ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/crashme.man ${PREFIX}/man/man1/crashme.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/crashme ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/pddet ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/crashme.man \
+ ${STAGEDIR}${MANPREFIX}/man/man1/crashme.1
.include <bsd.port.mk>