aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-04-12 00:37:34 +0800
committerlofi <lofi@FreeBSD.org>2005-04-12 00:37:34 +0800
commit1a936393b150fe8da385ff5b80c2aefc9c2d2884 (patch)
tree4260e604e8966f97691b20e3a9184d8cc481cdd0 /sysutils
parent630595b68f9b9cdb65317449b3439905b5869a33 (diff)
downloadfreebsd-ports-gnome-1a936393b150fe8da385ff5b80c2aefc9c2d2884.tar.gz
freebsd-ports-gnome-1a936393b150fe8da385ff5b80c2aefc9c2d2884.tar.zst
freebsd-ports-gnome-1a936393b150fe8da385ff5b80c2aefc9c2d2884.zip
Add lineak_kdeplugins, kdeplugins for lineak
PR: ports/79503 Submitted by: Kay Lehmann <kay_lehmann@web.de>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/lineak-kdeplugins/Makefile41
-rw-r--r--sysutils/lineak-kdeplugins/distinfo2
-rw-r--r--sysutils/lineak-kdeplugins/pkg-descr5
-rw-r--r--sysutils/lineak-kdeplugins/pkg-plist8
-rw-r--r--sysutils/lineak_kdeplugins/Makefile41
-rw-r--r--sysutils/lineak_kdeplugins/distinfo2
-rw-r--r--sysutils/lineak_kdeplugins/pkg-descr5
-rw-r--r--sysutils/lineak_kdeplugins/pkg-plist8
9 files changed, 113 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 8783358e326e..c6aeea43db5d 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -245,6 +245,7 @@
SUBDIR += libretto-config
SUBDIR += libutempter
SUBDIR += lineak_defaultplugin
+ SUBDIR += lineak_kdeplugins
SUBDIR += lineak_xosdplugin
SUBDIR += lineakd
SUBDIR += linneighborhood
diff --git a/sysutils/lineak-kdeplugins/Makefile b/sysutils/lineak-kdeplugins/Makefile
new file mode 100644
index 000000000000..5cfc5b12aeb7
--- /dev/null
+++ b/sysutils/lineak-kdeplugins/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: lineak_kdeplugins
+# Date created: 2004-12-29
+# Whom: Kay Lehmann <kay_lehmann@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lineak_kdeplugins
+PORTVERSION= 0.8.3
+CATEGORIES= sysutils deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lineak
+DIST_SUBDIR= lineak
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= KDE plugins for lineakd
+
+LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd
+
+USE_KDE_VER= 3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --program-prefix=''
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+
+MAN1= lineak_kdeplugins.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "Needs KDE to be compiled with gcc 3.4"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/lineak-kdeplugins/distinfo b/sysutils/lineak-kdeplugins/distinfo
new file mode 100644
index 000000000000..6a8b6c4f74fd
--- /dev/null
+++ b/sysutils/lineak-kdeplugins/distinfo
@@ -0,0 +1,2 @@
+MD5 (lineak/lineak_kdeplugins-0.8.3.tar.gz) = dd0c1bf35adf280025b895c4618a331a
+SIZE (lineak/lineak_kdeplugins-0.8.3.tar.gz) = 862043
diff --git a/sysutils/lineak-kdeplugins/pkg-descr b/sysutils/lineak-kdeplugins/pkg-descr
new file mode 100644
index 000000000000..29d6f4c6e8db
--- /dev/null
+++ b/sysutils/lineak-kdeplugins/pkg-descr
@@ -0,0 +1,5 @@
+KDE plugins for lineakd. Contains some macros to control
+kmail, konqueror, kmix, kdesktop, juk, kscd and amarok
+(if last is installed).
+
+WWW: http://lineak.sf.net/
diff --git a/sysutils/lineak-kdeplugins/pkg-plist b/sysutils/lineak-kdeplugins/pkg-plist
new file mode 100644
index 000000000000..b76a0c094336
--- /dev/null
+++ b/sysutils/lineak-kdeplugins/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+lib/lineakd/plugins/amarokplugin.so
+lib/lineakd/plugins/jukplugin.so
+lib/lineakd/plugins/kdesktopplugin.so
+lib/lineakd/plugins/kmailplugin.so
+lib/lineakd/plugins/kmixplugin.so
+lib/lineakd/plugins/konqplugin.so
+lib/lineakd/plugins/kscdplugin.so
diff --git a/sysutils/lineak_kdeplugins/Makefile b/sysutils/lineak_kdeplugins/Makefile
new file mode 100644
index 000000000000..5cfc5b12aeb7
--- /dev/null
+++ b/sysutils/lineak_kdeplugins/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: lineak_kdeplugins
+# Date created: 2004-12-29
+# Whom: Kay Lehmann <kay_lehmann@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lineak_kdeplugins
+PORTVERSION= 0.8.3
+CATEGORIES= sysutils deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lineak
+DIST_SUBDIR= lineak
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= KDE plugins for lineakd
+
+LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd
+
+USE_KDE_VER= 3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --program-prefix=''
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+
+MAN1= lineak_kdeplugins.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "Needs KDE to be compiled with gcc 3.4"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/lineak_kdeplugins/distinfo b/sysutils/lineak_kdeplugins/distinfo
new file mode 100644
index 000000000000..6a8b6c4f74fd
--- /dev/null
+++ b/sysutils/lineak_kdeplugins/distinfo
@@ -0,0 +1,2 @@
+MD5 (lineak/lineak_kdeplugins-0.8.3.tar.gz) = dd0c1bf35adf280025b895c4618a331a
+SIZE (lineak/lineak_kdeplugins-0.8.3.tar.gz) = 862043
diff --git a/sysutils/lineak_kdeplugins/pkg-descr b/sysutils/lineak_kdeplugins/pkg-descr
new file mode 100644
index 000000000000..29d6f4c6e8db
--- /dev/null
+++ b/sysutils/lineak_kdeplugins/pkg-descr
@@ -0,0 +1,5 @@
+KDE plugins for lineakd. Contains some macros to control
+kmail, konqueror, kmix, kdesktop, juk, kscd and amarok
+(if last is installed).
+
+WWW: http://lineak.sf.net/
diff --git a/sysutils/lineak_kdeplugins/pkg-plist b/sysutils/lineak_kdeplugins/pkg-plist
new file mode 100644
index 000000000000..b76a0c094336
--- /dev/null
+++ b/sysutils/lineak_kdeplugins/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+lib/lineakd/plugins/amarokplugin.so
+lib/lineakd/plugins/jukplugin.so
+lib/lineakd/plugins/kdesktopplugin.so
+lib/lineakd/plugins/kmailplugin.so
+lib/lineakd/plugins/kmixplugin.so
+lib/lineakd/plugins/konqplugin.so
+lib/lineakd/plugins/kscdplugin.so