aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2012-12-16 07:55:36 +0800
committerbeech <beech@FreeBSD.org>2012-12-16 07:55:36 +0800
commit1cdffa4424c6fbd0a621cf483e0dd9913190a560 (patch)
treed724adf1a3e15e2689bfc7b5a1876f9a5528cac9 /sysutils
parentacdd3640f9329a336d7c862417d9fd5c964dd4a0 (diff)
downloadfreebsd-ports-gnome-1cdffa4424c6fbd0a621cf483e0dd9913190a560.tar.gz
freebsd-ports-gnome-1cdffa4424c6fbd0a621cf483e0dd9913190a560.tar.zst
freebsd-ports-gnome-1cdffa4424c6fbd0a621cf483e0dd9913190a560.zip
- Update to 1.1
PR: ports/174408 Submitted by: John Hixson <john@pcbsd.org> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/mtpfs/Makefile5
-rw-r--r--sysutils/mtpfs/distinfo4
-rw-r--r--sysutils/mtpfs/files/patch-Makefile.in16
-rw-r--r--sysutils/mtpfs/files/patch-mtpfs.c49
-rw-r--r--sysutils/mtpfs/files/patch-mtpfs.h22
5 files changed, 64 insertions, 32 deletions
diff --git a/sysutils/mtpfs/Makefile b/sysutils/mtpfs/Makefile
index bb9af8b323e3..429bfad44b1e 100644
--- a/sysutils/mtpfs/Makefile
+++ b/sysutils/mtpfs/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= mtpfs
-PORTVERSION= 0.9
-PORTREVISION= 2
+PORTVERSION= 1.1
CATEGORIES= sysutils
-MASTER_SITES= http://www.adebenham.com/mtpfs/
+MASTER_SITES= http://www.adebenham.com/files/mtp/
MAINTAINER= john@pcbsd.org
COMMENT= MTP device filesystem
diff --git a/sysutils/mtpfs/distinfo b/sysutils/mtpfs/distinfo
index 8b48c128c844..345bc174a2a7 100644
--- a/sysutils/mtpfs/distinfo
+++ b/sysutils/mtpfs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mtpfs-0.9.tar.gz) = 828e82955232155380b243348eb16cb5f6acfe02ddbf97222308b2fc2dcb1d09
-SIZE (mtpfs-0.9.tar.gz) = 95038
+SHA256 (mtpfs-1.1.tar.gz) = 1baf357de16995a5f0b5bc1b6833517a77456481d861cdba70f1ce1316ce4c1d
+SIZE (mtpfs-1.1.tar.gz) = 108329
diff --git a/sysutils/mtpfs/files/patch-Makefile.in b/sysutils/mtpfs/files/patch-Makefile.in
index ffcbcc12d024..ff70cb0a0c94 100644
--- a/sysutils/mtpfs/files/patch-Makefile.in
+++ b/sysutils/mtpfs/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig Sun Jul 1 11:45:44 2007
-+++ Makefile.in Sun Jul 1 11:46:00 2007
-@@ -157,7 +157,7 @@
+--- Makefile.in 2012-02-26 17:02:28.000000000 -0800
++++ Makefile.in 2012-12-12 19:11:25.155523995 -0800
+@@ -181,7 +181,7 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
- mtpfs_SOURCES = id3read.c mtpfs.c mtpfs.h id3read.h
--mtpfs_CPPFLAGS = -DFUSE_USE_VERSION=22 $(FUSE_CFLAGS)
-+mtpfs_CPPFLAGS = -DFUSE_USE_VERSION=25 $(FUSE_CFLAGS)
- mtpfs_LDADD = $(FUSE_LIBS)
+ mtpfs_SOURCES = mtpfs.c mtpfs.h $(am__append_1)
+-mtpfs_CPPFLAGS = -DFUSE_USE_VERSION=22 $(FUSE_CFLAGS) $(GLIB_CFLAGS) \
++mtpfs_CPPFLAGS = -DFUSE_USE_VERSION=26 $(FUSE_CFLAGS) $(GLIB_CFLAGS) \
+ $(MTP_CFLAGS) $(am__append_2)
+ mtpfs_LDADD = $(FUSE_LIBS) $(GLIB_LIBS) $(MTP_LIBS) $(am__append_3)
all: all-am
-
diff --git a/sysutils/mtpfs/files/patch-mtpfs.c b/sysutils/mtpfs/files/patch-mtpfs.c
index 22fd26343518..a544c3c9665a 100644
--- a/sysutils/mtpfs/files/patch-mtpfs.c
+++ b/sysutils/mtpfs/files/patch-mtpfs.c
@@ -1,15 +1,6 @@
---- mtpfs.c.orig 2008-08-05 07:29:29.000000000 +0200
-+++ mtpfs.c 2012-10-30 00:47:13.487478272 +0100
-@@ -534,7 +534,7 @@
- }
- }
- close (fi->fh);
-- return_unlock();
-+ return_unlock(0);
- }
-
- void
-@@ -1143,7 +1143,7 @@
+--- mtpfs.c 2012-02-26 16:59:39.000000000 -0800
++++ mtpfs.c 2012-12-12 19:11:46.955525173 -0800
+@@ -1270,7 +1270,7 @@
}
static int
@@ -18,3 +9,37 @@
{
DBG("mtpfs_statfs");
stbuf->f_bsize=1024;
+@@ -1282,7 +1282,7 @@
+ }
+
+ void *
+-mtpfs_init ()
++mtpfs_init (struct fuse_conn_info *conn)
+ {
+ LIBMTP_devicestorage_t *storage;
+ DBG("mtpfs_init");
+@@ -1298,8 +1298,14 @@
+ // Do nothing
+ }
+
++int
++mtpfs_blank_chmod(const char *path, mode_t mode)
++{
++ return (0);
++}
++
+ static struct fuse_operations mtpfs_oper = {
+- .chmod = mtpfs_blank,
++ .chmod = mtpfs_blank_chmod,
+ .release = mtpfs_release,
+ .readdir = mtpfs_readdir,
+ .getattr = mtpfs_getattr,
+@@ -1428,7 +1434,7 @@
+
+ DBG("Start fuse");
+
+- fuse_stat=fuse_main (argc, argv, &mtpfs_oper);
++ fuse_stat=fuse_main (argc, argv, &mtpfs_oper, NULL);
+ DBG("fuse_main returned %d\n", fuse_stat);
+ return fuse_stat;
+ }
diff --git a/sysutils/mtpfs/files/patch-mtpfs.h b/sysutils/mtpfs/files/patch-mtpfs.h
index 422f68842e15..b0b0eafa318b 100644
--- a/sysutils/mtpfs/files/patch-mtpfs.h
+++ b/sysutils/mtpfs/files/patch-mtpfs.h
@@ -1,18 +1,26 @@
---- mtpfs.h.orig 2009-01-04 03:03:56.000000000 +0800
-+++ mtpfs.h 2009-01-04 03:05:16.000000000 +0800
-@@ -18,8 +18,9 @@
+--- mtpfs.h 2012-02-23 20:37:14.000000000 -0800
++++ mtpfs.h 2012-12-12 19:10:01.055523958 -0800
+@@ -18,7 +18,9 @@
#include <fcntl.h>
#include <dirent.h>
#include <errno.h>
-#include <sys/statfs.h>
--
+#include <sys/param.h>
+#include <sys/mount.h>
+#include <sys/statvfs.h>
+
#include <libmtp.h>
#include <glib.h>
- #include <id3tag.h>
-@@ -49,7 +50,7 @@
+@@ -49,7 +51,7 @@
+
+
+ /* fuse functions */
+-static void * mtpfs_init (void);
++static void * mtpfs_init (struct fuse_conn_info *);
+ static int mtpfs_blank ();
+ static int mtpfs_release (const char *path, struct fuse_file_info *fi);
+ void mtpfs_destroy ();
+@@ -62,7 +64,7 @@
static int mtpfs_unlink (const gchar * path);
static int mtpfs_mkdir (const char *path, mode_t mode);
static int mtpfs_rmdir (const char *path);
@@ -20,4 +28,4 @@
+static int mtpfs_statfs (const char *path, struct statvfs *stbuf);
int calc_length(int f);
-
+ static LIBMTP_mtpdevice_t *device;