aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2017-10-20 22:51:35 +0800
committercy <cy@FreeBSD.org>2017-10-20 22:51:35 +0800
commit1ef55e215b05044608a07b0930a64722c161c9f0 (patch)
tree9e0e9b021e87479cdc3b8baf2fcd1ab05f7a482a /sysutils
parentadbdde44fcba65e881b1afa3a498923fb593b6c6 (diff)
downloadfreebsd-ports-gnome-1ef55e215b05044608a07b0930a64722c161c9f0.tar.gz
freebsd-ports-gnome-1ef55e215b05044608a07b0930a64722c161c9f0.tar.zst
freebsd-ports-gnome-1ef55e215b05044608a07b0930a64722c161c9f0.zip
Fix build with SERIAL option.
PR: 223122
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/nut/Makefile2
-rw-r--r--sysutils/nut/files/patch-drivers_libshut.c10
-rw-r--r--sysutils/nut/files/patch-drivers_usbhid-ups.c8
3 files changed, 18 insertions, 2 deletions
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index a10c3ffa5e7e..416bbce8788b 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nut
PORTVERSION= 2.7.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= sysutils
MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
diff --git a/sysutils/nut/files/patch-drivers_libshut.c b/sysutils/nut/files/patch-drivers_libshut.c
index c4a1895398d2..b925c8948250 100644
--- a/sysutils/nut/files/patch-drivers_libshut.c
+++ b/sysutils/nut/files/patch-drivers_libshut.c
@@ -1,6 +1,14 @@
--- drivers/libshut.c.orig 2015-12-29 12:08:34 UTC
+++ drivers/libshut.c
-@@ -809,10 +809,10 @@ int shut_get_string_simple(int upsfd, int index,
+@@ -37,6 +37,7 @@
+ #include "nut_stdint.h" /* for uint8_t, uint16_t, uint32_t */
+
+ #include "serial.h"
++#include "libusb.h"
+ #include "libshut.h"
+ #include "common.h" /* for xmalloc, upsdebugx prototypes */
+
+@@ -809,10 +810,10 @@ int shut_get_string_simple(int upsfd, int index,
return ret;
if (tbuf[1] != USB_DT_STRING)
diff --git a/sysutils/nut/files/patch-drivers_usbhid-ups.c b/sysutils/nut/files/patch-drivers_usbhid-ups.c
index 02ff0956a7a8..620b60c0baf1 100644
--- a/sysutils/nut/files/patch-drivers_usbhid-ups.c
+++ b/sysutils/nut/files/patch-drivers_usbhid-ups.c
@@ -1,5 +1,13 @@
--- drivers/usbhid-ups.c.orig 2015-12-29 12:08:34 UTC
+++ drivers/usbhid-ups.c
+@@ -30,6 +30,7 @@
+ #define DRIVER_VERSION "0.41"
+
+ #include "main.h"
++#include "libusb.h"
+ #include "libhid.h"
+ #include "usbhid-ups.h"
+ #include "hidparser.h"
@@ -790,22 +790,14 @@ void upsdrv_updateinfo(void)
/* Get HID notifications on Interrupt pipe first */
if (use_interrupt_pipe == TRUE) {