aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2003-08-27 16:14:14 +0800
committermich <mich@FreeBSD.org>2003-08-27 16:14:14 +0800
commit2067bd7b72d726216179b494e240736368b9e39a (patch)
tree1bc54efcc7963bf54f4be541f38356772c832731 /sysutils
parentd2efca8bf5eb989eae3ea1cfd73c4d7d908d096d (diff)
downloadfreebsd-ports-gnome-2067bd7b72d726216179b494e240736368b9e39a.tar.gz
freebsd-ports-gnome-2067bd7b72d726216179b494e240736368b9e39a.tar.zst
freebsd-ports-gnome-2067bd7b72d726216179b494e240736368b9e39a.zip
New port: worldtools
worldtools consists of 3 simple scripts: - whereintheworld displays the great lines behind the build logs of a buildworld. It shows at which step the build is at, and which module is currently being built. - buildit runs a command, time(1)s it, logs the output and optionally sends a notification to the user by email when finished. - upgrade is a wrapper for buildit, whereintheworld, cvsup and make buildworld. PR: 55995 Submitted by: The Anarcat <anarcat@anarcat.ath.cx> Approved by: roberto (mentor)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/worldtools/Makefile29
-rw-r--r--sysutils/worldtools/distinfo1
-rw-r--r--sysutils/worldtools/pkg-descr13
-rw-r--r--sysutils/worldtools/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index defc1fb8aa8f..40fc9068da55 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -329,6 +329,7 @@
SUBDIR += wmtop
SUBDIR += wmupmon
SUBDIR += wmzazof
+ SUBDIR += worldtools
SUBDIR += wots
SUBDIR += wtail
SUBDIR += x86info
diff --git a/sysutils/worldtools/Makefile b/sysutils/worldtools/Makefile
new file mode 100644
index 000000000000..554c602318ca
--- /dev/null
+++ b/sysutils/worldtools/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: whereintheworld
+# Date created: 13 august 2003
+# Whom: anarcat
+#
+# $FreeBSD$
+#
+
+PORTNAME= worldtools
+PORTVERSION= 1.1
+CATEGORIES= sysutils
+MASTER_SITES= http://anarcat.ath.cx/software/distfiles/
+
+MAINTAINER= anarcat@anarcat.ath.cx
+COMMENT= Handy tools for living with make world
+
+USE_PERL5_RUN= yes
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/whereintheworld ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/upgrade ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/buildit ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/worldtools/distinfo b/sysutils/worldtools/distinfo
new file mode 100644
index 000000000000..33acaa334779
--- /dev/null
+++ b/sysutils/worldtools/distinfo
@@ -0,0 +1 @@
+MD5 (worldtools-1.1.tar.gz) = 68f921240606d6743819f09277a51d8a
diff --git a/sysutils/worldtools/pkg-descr b/sysutils/worldtools/pkg-descr
new file mode 100644
index 000000000000..0d958ef30a0c
--- /dev/null
+++ b/sysutils/worldtools/pkg-descr
@@ -0,0 +1,13 @@
+worldtools consists of 3 simple scripts:
+
+- whereintheworld displays the great lines behind the build logs of a
+buildworld. It shows at which step the build is at, and which module
+is currently being built.
+
+- buildit runs a command, time(1)s it, logs the output and optionally
+sends a notification to the user by email when finished.
+
+- upgrade is a wrapper for buildit, whereintheworld, cvsup and make
+buildworld.
+
+See the README file for more details.
diff --git a/sysutils/worldtools/pkg-plist b/sysutils/worldtools/pkg-plist
new file mode 100644
index 000000000000..f8109a2e3d07
--- /dev/null
+++ b/sysutils/worldtools/pkg-plist
@@ -0,0 +1,5 @@
+sbin/whereintheworld
+sbin/upgrade
+sbin/buildit
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%