aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-01-06 21:57:05 +0800
committerJason W. Bacon <jwb@FreeBSD.org>2021-01-06 21:57:05 +0800
commit20f4460e114381ac03190ed361d5d0279dc47af9 (patch)
treef6205178fbbed316235d50a5f5294b9fa8b080d1 /sysutils
parent07a67230d3dc6831cd67eadc09a82599fd52906c (diff)
downloadfreebsd-ports-gnome-20f4460e114381ac03190ed361d5d0279dc47af9.tar.gz
freebsd-ports-gnome-20f4460e114381ac03190ed361d5d0279dc47af9.tar.zst
freebsd-ports-gnome-20f4460e114381ac03190ed361d5d0279dc47af9.zip
sysutils/spcm: Tools for building and managing HPC clusters
SPCM (Simple, Portable Cluster Manager) is a free, open source integrated tool set for managing a simple HPC (High Performance Computing) cluster. It is the only portable cluster management suite we are aware of and is designed to be easily adapted to most POSIX platforms. SPCM automates the process of configuring a head node, compute nodes, file servers, and visualization nodes. Most common management tasks can be performed using a simple menu interface, while additional tasks are supported by command-line tools.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/spcm/Makefile25
-rw-r--r--sysutils/spcm/distinfo3
-rw-r--r--sysutils/spcm/files/patch-install.sh11
-rw-r--r--sysutils/spcm/pkg-descr13
-rw-r--r--sysutils/spcm/pkg-plist144
6 files changed, 197 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 84fda1845ddc..113528641a36 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1265,6 +1265,7 @@
SUBDIR += socket
SUBDIR += socklog
SUBDIR += solaar
+ SUBDIR += spcm
SUBDIR += spindown
SUBDIR += spinner
SUBDIR += spiped
diff --git a/sysutils/spcm/Makefile b/sysutils/spcm/Makefile
new file mode 100644
index 000000000000..e1f1d6840561
--- /dev/null
+++ b/sysutils/spcm/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= spcm
+DISTVERSION= 0.5.0
+CATEGORIES= sysutils
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Tools for building and managing HPC clusters
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= auto-admin>=0.6.11:sysutils/auto-admin
+
+USE_GITHUB= yes
+
+GH_ACCOUNT= outpaddling
+GH_PROJECT= SPCM
+
+MAKE_ENV+= DATADIR=${DATADIR}
+
+post-stage:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/cluster-passwd
+
+.include <bsd.port.mk>
diff --git a/sysutils/spcm/distinfo b/sysutils/spcm/distinfo
new file mode 100644
index 000000000000..89102b32334a
--- /dev/null
+++ b/sysutils/spcm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609895790
+SHA256 (outpaddling-SPCM-0.5.0_GH0.tar.gz) = 1851ef0ebe4e06f40949c092f2b957c1abcce46379deb62f2e261761a25a1a9d
+SIZE (outpaddling-SPCM-0.5.0_GH0.tar.gz) = 129354
diff --git a/sysutils/spcm/files/patch-install.sh b/sysutils/spcm/files/patch-install.sh
new file mode 100644
index 000000000000..c7c8d2468f30
--- /dev/null
+++ b/sysutils/spcm/files/patch-install.sh
@@ -0,0 +1,11 @@
+--- install.sh.orig 2021-01-06 01:45:59 UTC
++++ install.sh
+@@ -47,7 +47,7 @@ fi
+ chmod o-rwx ${DESTDIR}${PREFIX}/sbin/*
+
+ install -c cluster-passwd ${DESTDIR}${PREFIX}/bin
+-chmod 6555 ${DESTDIR}${PREFIX}/bin/cluster-passwd
++#chmod 6555 ${DESTDIR}${PREFIX}/bin/cluster-passwd
+
+ # FIXME: Create and install man pages
+
diff --git a/sysutils/spcm/pkg-descr b/sysutils/spcm/pkg-descr
new file mode 100644
index 000000000000..ae5813f87301
--- /dev/null
+++ b/sysutils/spcm/pkg-descr
@@ -0,0 +1,13 @@
+SPCM (Simple, Portable Cluster Manager) is a free, open source
+integrated tool set for managing a simple HPC (High Performance
+Computing) cluster.
+
+It is the only portable cluster management suite we are aware of
+and is designed to be easily adapted to most POSIX platforms.
+
+SPCM automates the process of configuring a head node, compute
+nodes, file servers, and visualization nodes. Most common management
+tasks can be performed using a simple menu interface, while additional
+tasks are supported by command-line tools.
+
+WWW: http://acadix.biz/cluster-admin.php
diff --git a/sysutils/spcm/pkg-plist b/sysutils/spcm/pkg-plist
new file mode 100644
index 000000000000..2ca61cac0651
--- /dev/null
+++ b/sysutils/spcm/pkg-plist
@@ -0,0 +1,144 @@
+bin/cluster-all-nodes
+bin/cluster-backup-nodes
+bin/cluster-compute-nodes
+bin/cluster-down-nodes
+bin/cluster-file-servers
+bin/cluster-head-check
+bin/cluster-node-status
+@mode 6555
+bin/cluster-passwd
+@mode
+bin/cluster-pfs-nodes
+bin/cluster-pw-check
+bin/cluster-raid-nodes
+bin/cluster-vis-nodes
+bin/condor-build-R-packages
+bin/condor-cpus
+bin/condor-list-packages
+bin/job-top
+bin/node-iostat
+bin/node-netstat
+bin/node-ps
+bin/node-top
+bin/psnode
+bin/slurm-cluster-load
+bin/slurm-find-strays
+bin/slurm-gui-job
+bin/slurm-job-hist
+bin/slurm-job-stats
+bin/slurm-job-status
+bin/slurm-load-summary
+bin/slurm-memory-use
+bin/slurm-node-info
+bin/slurm-pending-jobs
+bin/slurm-shell
+bin/slurm-user-cores
+bin/topjob
+bin/topnode
+libexec/add-gecos.awk
+sbin/cluster-add-to-group
+sbin/cluster-adduser
+sbin/cluster-admin
+sbin/cluster-archive-user-dir
+sbin/cluster-change-group-gid
+sbin/cluster-change-nfsd-count
+sbin/cluster-change-primary-group
+sbin/cluster-change-uid
+sbin/cluster-check-cron-updates
+sbin/cluster-create-pw-age
+sbin/cluster-diagnostics
+sbin/cluster-dist-file
+sbin/cluster-enable-autologout
+sbin/cluster-firewall-config
+sbin/cluster-ganglia-restart
+sbin/cluster-get-sync-file
+sbin/cluster-highest-uid
+sbin/cluster-init-node
+sbin/cluster-ipmi-power-on
+sbin/cluster-krb-auth-setup
+sbin/cluster-localbase
+sbin/cluster-lock-local-pw
+sbin/cluster-lock-user
+sbin/cluster-lowest-uid
+sbin/cluster-munge-enable
+sbin/cluster-node-admin
+sbin/cluster-passwd-expiration
+sbin/cluster-passwd-user-expiration
+sbin/cluster-ports-update
+sbin/cluster-power-saver
+sbin/cluster-power-waster
+sbin/cluster-recreate-user
+sbin/cluster-remove-from-group
+sbin/cluster-remove-from-known-hosts
+sbin/cluster-remove-user
+sbin/cluster-restore-user
+sbin/cluster-run
+sbin/cluster-services-menu
+sbin/cluster-set-compute-memory-limits
+sbin/cluster-set-default-nfs-mounts
+sbin/cluster-setup
+sbin/cluster-shutdown
+sbin/cluster-slurm-enable
+sbin/cluster-spcm-update-from-wip
+sbin/cluster-ssh-keygen
+sbin/cluster-stay-down
+sbin/cluster-sync-backup-nodes
+sbin/cluster-sync-files
+sbin/cluster-sync-node
+sbin/cluster-sync-packages
+sbin/cluster-sync-pkgsrc
+sbin/cluster-sync-pw
+sbin/cluster-sync-sysfiles
+sbin/cluster-sync-user
+sbin/cluster-transfer-pw
+sbin/cluster-unlock-local-pw
+sbin/cluster-unlock-user
+sbin/cluster-update-backup-nodes
+sbin/cluster-update-file-servers
+sbin/cluster-update-menu
+sbin/cluster-update-vis-nodes
+sbin/cluster-upgrade
+sbin/cluster-user-admin
+sbin/cluster-user-cleanup
+sbin/cluster-useradd
+sbin/cluster-usermod
+sbin/cluster-users
+sbin/cluster-wip-update
+sbin/compute-node-set-arc-max
+sbin/ganglia-web-setup
+sbin/node-iftop
+sbin/node-set-type
+sbin/node-sync-all-users
+sbin/node-sync-groups
+sbin/node-sync-pkgsrc
+sbin/node-sync-users
+sbin/node-type
+sbin/node-upgrade
+sbin/slurm-cron-updates
+sbin/slurm-drain-all
+sbin/slurm-node-resume
+sbin/slurm-node-suspend
+sbin/slurm-restart
+sbin/slurm-resume-nodes
+sbin/slurm-resume-updated-nodes
+sbin/slurm-shutdown-idle-nodes
+sbin/slurm-sync-backup
+sbin/slurm-sync-config
+sbin/slurm-update-idle-nodes
+sbin/slurm-usage-report
+sbin/spcm-banner
+sbin/spcm-update-from-wip
+%%DATADIR%%/WWW/global_styles.css
+%%DATADIR%%/WWW/gmetad.conf.template
+%%DATADIR%%/WWW/gmond.conf.template
+%%DATADIR%%/WWW/index.php
+%%DATADIR%%/WWW/patch-apache.awk
+%%DATADIR%%/WWW/pkgsrc.jpg
+%%DATADIR%%/WWW/powered-by.png
+%%DATADIR%%/WWW/powerlogo.gif
+%%DATADIR%%/WWW/sync-compute-docs.sh
+%%DATADIR%%/csh.login
+%%DATADIR%%/profile
+%%DATADIR%%/profile.d/zzz-cluster.csh
+%%DATADIR%%/profile.d/zzz-cluster.sh
+%%DATADIR%%/sys-update.sbatch