aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-09-16 02:34:31 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-09-16 02:34:31 +0800
commit270ff0428224da7598394ffb3f1b3bf3167573a1 (patch)
tree7ec96a66609b6ff69ff2193bf74eac39839619ba /sysutils
parent928c2ecf40a306402b51c488a829ca62085596a6 (diff)
downloadfreebsd-ports-gnome-270ff0428224da7598394ffb3f1b3bf3167573a1.tar.gz
freebsd-ports-gnome-270ff0428224da7598394ffb3f1b3bf3167573a1.tar.zst
freebsd-ports-gnome-270ff0428224da7598394ffb3f1b3bf3167573a1.zip
- Drop 8.x support
- Switch to options helpers - Regenerate patches with `make makepatch` Approved by: portmgr blanket
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/abgx360/Makefile18
-rw-r--r--sysutils/abgx360/files/patch-src_abgx360.c (renamed from sysutils/abgx360/files/extra-patch-src-abgx360.c)6
2 files changed, 8 insertions, 16 deletions
diff --git a/sysutils/abgx360/Makefile b/sysutils/abgx360/Makefile
index c428ebd83a59..2c61b555cd56 100644
--- a/sysutils/abgx360/Makefile
+++ b/sysutils/abgx360/Makefile
@@ -12,6 +12,10 @@ COMMENT= Verify and repair Xbox 360 backup images
BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl
+BROKEN_ia64= does not compile
+BROKEN_powerpc= does not compile
+BROKEN_sparc64= does not compile
+
PLIST_FILES= bin/abgx360
GNU_CONFIGURE= yes
@@ -19,16 +23,4 @@ GNU_CONFIGURE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/abgx360 ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-abgx360.c
-.endif
-
-.if ${OSVERSION} > 900000
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/abgx360/files/extra-patch-src-abgx360.c b/sysutils/abgx360/files/patch-src_abgx360.c
index c30dc82ff3d3..1e9547611728 100644
--- a/sysutils/abgx360/files/extra-patch-src-abgx360.c
+++ b/sysutils/abgx360/files/patch-src_abgx360.c
@@ -1,6 +1,6 @@
---- src/abgx360.c.orig 2012-05-07 10:23:05.997665157 -0400
-+++ src/abgx360.c 2012-05-07 10:26:22.824665331 -0400
-@@ -2220,82 +2220,8 @@
+--- src/abgx360.c.orig 2012-01-03 07:29:31 UTC
++++ src/abgx360.c
+@@ -2220,82 +2220,8 @@ int sendcdb(int direction, unsigned char
int sendcdb(int direction, unsigned char *dataBuffer, unsigned long dataBufferSize,
unsigned char *cdb, unsigned char cdbLen, bool checkreturnlength) {