aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2018-12-30 22:15:54 +0800
committeradridg <adridg@FreeBSD.org>2018-12-30 22:15:54 +0800
commit29c47d55694480396d7d98fdeffeddb7f4dc7b64 (patch)
tree8015b15002c74c925a18f0385510aa0aadb2544b /sysutils
parenta5770a6e3267d63a00e228dbddd666e20579a84a (diff)
downloadfreebsd-ports-gnome-29c47d55694480396d7d98fdeffeddb7f4dc7b64.tar.gz
freebsd-ports-gnome-29c47d55694480396d7d98fdeffeddb7f4dc7b64.tar.zst
freebsd-ports-gnome-29c47d55694480396d7d98fdeffeddb7f4dc7b64.zip
Add OPTIONS to some kde@ ports.
For best runtime performance (e.g. a fully functional desktop), users will need a pinentry application -- pinentry-qt fits best into the KDE desktop, but it could be a different one -- and sound output. Pick a default backend and some OSS plugins to make that happen. These are OPTIONS so the users interested in a minimal desktop or one with different audio needs can build suitable packages themselves. Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D18680
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/kf5-kwallet/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/sysutils/kf5-kwallet/Makefile b/sysutils/kf5-kwallet/Makefile
index b6dc956df1cd..acd93d615798 100644
--- a/sysutils/kf5-kwallet/Makefile
+++ b/sysutils/kf5-kwallet/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kwallet
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -21,4 +22,10 @@ USE_KDE= auth codecs config configwidgets coreaddons dbusaddons \
widgetsaddons windowsystem
USE_QT= buildtools_build core dbus gui qmake_build widgets xml
+OPTIONS_DEFINE= PINENTRY
+OPTIONS_DEFAULT= PINENTRY
+
+PINENTRY_DESC= Include pinentry-qt, for wallet passwords
+PINENTRY_RUN_DEPENDS= pinentry-qt5:security/pinentry-qt5
+
.include <bsd.port.mk>