aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-06-05 23:32:48 +0800
committernovel <novel@FreeBSD.org>2005-06-05 23:32:48 +0800
commit2a3b50badc5ede7aa102e4a6b2ee8ee6ba687150 (patch)
tree66f1e476c042e184cfc0e80dbe115bae2d4bc84e /sysutils
parenta5887105bbfc3a46e43ef9f8894730b56858a46e (diff)
downloadfreebsd-ports-gnome-2a3b50badc5ede7aa102e4a6b2ee8ee6ba687150.tar.gz
freebsd-ports-gnome-2a3b50badc5ede7aa102e4a6b2ee8ee6ba687150.tar.zst
freebsd-ports-gnome-2a3b50badc5ede7aa102e4a6b2ee8ee6ba687150.zip
- Exit with !=0 code if patch file was not found (to improve error
handling in scripts) - Install some docs - Bump PORTREVISION
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/deltup/Makefile13
-rw-r--r--sysutils/deltup/files/patch-deltup.cpp19
2 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/deltup/Makefile b/sysutils/deltup/Makefile
index eb1fe4fa70ba..ea471ebcda70 100644
--- a/sysutils/deltup/Makefile
+++ b/sysutils/deltup/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deltup
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,6 +23,10 @@ PLIST_FILES= bin/deltup \
bin/bzip2_old
MAN1= deltup.1
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog README
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/deltup ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/deltup.1 ${PREFIX}/man/man1
@@ -29,4 +34,12 @@ do-install:
@${LN} -s ${BZIP2_CMD} ${PREFIX}/bin/bzip2_old
.endif
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/sysutils/deltup/files/patch-deltup.cpp b/sysutils/deltup/files/patch-deltup.cpp
new file mode 100644
index 000000000000..76817bfbdad6
--- /dev/null
+++ b/sysutils/deltup/files/patch-deltup.cpp
@@ -0,0 +1,19 @@
+--- deltup.cpp.orig Fri May 27 18:53:49 2005
++++ deltup.cpp Fri May 27 18:55:24 2005
+@@ -748,14 +748,14 @@
+ void applyPatchfile(char *fname) {
+ IStream *f = new IFStream(fname);
+ Injectable_IStream f2(*f);
+- if (((IFStream*)f)->bad()) {fprintf(stderr, "file is missing: %s\n", fname); return;}
++ if (((IFStream*)f)->bad()) {fprintf(stderr, "file is missing: %s\n", fname); exit(1);}
+ int type = determine_filetype(f2);
+ delete f;
+ switch (type) {
+ case GZIP: f = new GZ_IFStream(fname); break;
+ case BZIP2: f = new BZ_IFStream(fname); break;
+ case DTU: f = new IFStream(fname); break;
+- case UNKNOWN_FMT: fprintf(stderr, "cannot read file %s\n", fname); return;
++ case UNKNOWN_FMT: fprintf(stderr, "cannot read file %s\n", fname); exit(1);
+ case TARBALL :
+ f = new IFStream(fname);
+ unsigned zero_count;