aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2019-09-20 20:21:11 +0800
committertz <tz@FreeBSD.org>2019-09-20 20:21:11 +0800
commit33097154a7736d41fe8672c3967e4928ba2424d1 (patch)
tree5eb143508ff1769e64395b54d8a3b09e1576fba0 /sysutils
parent99fc42c85683dcf9d1092d6f0b8722678c97ad19 (diff)
downloadfreebsd-ports-gnome-33097154a7736d41fe8672c3967e4928ba2424d1.tar.gz
freebsd-ports-gnome-33097154a7736d41fe8672c3967e4928ba2424d1.tar.zst
freebsd-ports-gnome-33097154a7736d41fe8672c3967e4928ba2424d1.zip
Welcome PHP 7.4 RC 1 in the ports-tree.
There are many greater changes including: - New module ffi - Remove interbase module - Remove recode module - Remove wddx module - Many modules changes the build switches - Many modules changes the config format, so patches needed to be recreated Special thanks to tobik and ale for their support. Reviewed by: tobik, ale, joneum Sponsored by: PHP Update Service Differential Revision: https://reviews.freebsd.org/D21349
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/php74-fileinfo/Makefile11
-rw-r--r--sysutils/php74-fileinfo/files/patch-config.m421
-rw-r--r--sysutils/php74-posix/Makefile11
-rw-r--r--sysutils/php74-posix/files/patch-posix.c38
5 files changed, 83 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 083883b38dc0..33c40a974379 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -892,6 +892,8 @@
SUBDIR += php72-posix
SUBDIR += php73-fileinfo
SUBDIR += php73-posix
+ SUBDIR += php74-fileinfo
+ SUBDIR += php74-posix
SUBDIR += phpfpm_exporter
SUBDIR += phybs
SUBDIR += pick
diff --git a/sysutils/php74-fileinfo/Makefile b/sysutils/php74-fileinfo/Makefile
new file mode 100644
index 000000000000..c815184e57f9
--- /dev/null
+++ b/sysutils/php74-fileinfo/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -fileinfo
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php74-fileinfo/files/patch-config.m4 b/sysutils/php74-fileinfo/files/patch-config.m4
new file mode 100644
index 000000000000..1348023ccf64
--- /dev/null
+++ b/sysutils/php74-fileinfo/files/patch-config.m4
@@ -0,0 +1,21 @@
+--- config.m4.orig 2010-09-07 15:45:30.000000000 +0200
++++ config.m4 2010-09-07 15:46:50.000000000 +0200
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(fileinfo, for fileinfo support,
+ [ --disable-fileinfo Disable fileinfo support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir FILEINFO: pcre install prefix], no, no)
++
+ if test "$PHP_FILEINFO" != "no"; then
+
+ libmagic_sources=" \
+@@ -13,6 +16,8 @@
+ libmagic/is_tar.c libmagic/magic.c libmagic/print.c \
+ libmagic/readcdf.c libmagic/readelf.c libmagic/softmagic.c"
+
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++
+ PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
+ PHP_ADD_BUILD_DIR($ext_builddir/libmagic)
+
diff --git a/sysutils/php74-posix/Makefile b/sysutils/php74-posix/Makefile
new file mode 100644
index 000000000000..55b57e07c08d
--- /dev/null
+++ b/sysutils/php74-posix/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -posix
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php74-posix/files/patch-posix.c b/sysutils/php74-posix/files/patch-posix.c
new file mode 100644
index 000000000000..d2365b249569
--- /dev/null
+++ b/sysutils/php74-posix/files/patch-posix.c
@@ -0,0 +1,38 @@
+--- posix.c.orig Fri Feb 23 00:40:39 2007
++++ posix.c Sun May 13 17:52:27 2007
+@@ -838,7 +838,7 @@
+ #if defined(ZTS) && defined(HAVE_GETGRNAM_R) && defined(_SC_GETGR_R_SIZE_MAX)
+ buflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ g = &gbuf;
+@@ -888,7 +888,7 @@
+
+ grbuflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (grbuflen < 1) {
+- RETURN_FALSE;
++ grbuflen = 1024;
+ }
+
+ grbuf = emalloc(grbuflen);
+@@ -955,7 +955,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWNAM_R)
+ buflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ pw = &pwbuf;
+@@ -1004,7 +1004,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWUID_R)
+ pwbuflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (pwbuflen < 1) {
+- RETURN_FALSE;
++ pwbuflen = 1024;
+ }
+ pwbuf = emalloc(pwbuflen);
+