aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-10-13 01:48:58 +0800
committerkrion <krion@FreeBSD.org>2004-10-13 01:48:58 +0800
commit38c96c42e188eb799def7d5ee2d2d1f93105cee4 (patch)
treea9902993e9ae79bfb9a3251851212e2c52529850 /sysutils
parentc01e35997e36ea75113c495649b6686894a70927 (diff)
downloadfreebsd-ports-gnome-38c96c42e188eb799def7d5ee2d2d1f93105cee4.tar.gz
freebsd-ports-gnome-38c96c42e188eb799def7d5ee2d2d1f93105cee4.tar.zst
freebsd-ports-gnome-38c96c42e188eb799def7d5ee2d2d1f93105cee4.zip
Fix build on 4.x
PR: ports/72589 Submitted by: cperciva
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/estctrl/Makefile9
-rw-r--r--sysutils/estctrl/files/estctrl.c.diff.fbsd411
2 files changed, 19 insertions, 1 deletions
diff --git a/sysutils/estctrl/Makefile b/sysutils/estctrl/Makefile
index 4ede46b035a7..7efebce0ccdf 100644
--- a/sysutils/estctrl/Makefile
+++ b/sysutils/estctrl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= estctrl
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.daemonology.net/freebsd-est/
@@ -25,6 +26,12 @@ PLIST_FILES= sbin/estctrl \
MAKE_ENV= BINDIR=${PREFIX}/sbin
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500101
+EXTRA_PATCHES= ${FILESDIR}/estctrl.c.diff.fbsd4
+.endif
+
post-extract:
${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/estctrl.sh > ${WRKDIR}/estctrl.sh
@@ -33,4 +40,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/estctrl.sh ${PREFIX}/etc/rc.d/estctrl.sh
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/estctrl/files/estctrl.c.diff.fbsd4 b/sysutils/estctrl/files/estctrl.c.diff.fbsd4
new file mode 100644
index 000000000000..68fbb8a5f2ee
--- /dev/null
+++ b/sysutils/estctrl/files/estctrl.c.diff.fbsd4
@@ -0,0 +1,11 @@
+--- estctrl.c.orig Tue Oct 12 17:46:13 2004
++++ estctrl.c Tue Oct 12 17:46:21 2004
+@@ -28,7 +28,7 @@
+ */
+
+ #include <sys/types.h>
+-#include <sys/resource.h>
++#include <sys/dkstat.h>
+ #include <sys/sysctl.h>
+
+ #include<err.h>