aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-05-21 16:58:59 +0800
committeroliver <oliver@FreeBSD.org>2005-05-21 16:58:59 +0800
commit3ad58047473690929d04f9cfb487e366408c8671 (patch)
treebc46e5866041b1b530df2a78a4a95221df0e811c /sysutils
parentcb460d7070d7e27f492dfce24e0fe63fa7bf2803 (diff)
downloadfreebsd-ports-gnome-3ad58047473690929d04f9cfb487e366408c8671.tar.gz
freebsd-ports-gnome-3ad58047473690929d04f9cfb487e366408c8671.tar.zst
freebsd-ports-gnome-3ad58047473690929d04f9cfb487e366408c8671.zip
fix uptime calculation on 64bit platforms
bump PORTREVISION Approved by: maintainer
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xfce4-systemload-plugin/Makefile2
-rw-r--r--sysutils/xfce4-systemload-plugin/files/patch-panel-plugin:uptime.c13
2 files changed, 12 insertions, 3 deletions
diff --git a/sysutils/xfce4-systemload-plugin/Makefile b/sysutils/xfce4-systemload-plugin/Makefile
index e4278ea21018..7579efe81fb0 100644
--- a/sysutils/xfce4-systemload-plugin/Makefile
+++ b/sysutils/xfce4-systemload-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-systemload-plugin
PORTVERSION= 0.3.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils xfce
MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
http://matt.nerim.net/xfce-goodies/ \
diff --git a/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin:uptime.c b/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin:uptime.c
index 539fdf6db3e9..8022de7f2a85 100644
--- a/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin:uptime.c
+++ b/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin:uptime.c
@@ -1,5 +1,5 @@
---- panel-plugin/uptime.c.orig Fri Nov 21 16:21:22 2003
-+++ panel-plugin/uptime.c Fri Nov 21 16:21:36 2003
+--- panel-plugin/uptime.c.orig Thu Nov 13 20:01:50 2003
++++ panel-plugin/uptime.c Fri May 20 22:31:11 2005
@@ -81,6 +81,7 @@
#include <string.h>
#include <sys/param.h>
@@ -8,3 +8,12 @@
#include <sys/types.h>
#include <sys/vmmeter.h>
#include <unistd.h>
+@@ -94,7 +95,7 @@
+ int mib[2] = {CTL_KERN, KERN_BOOTTIME};
+ struct timeval boottime;
+ time_t now;
+- int size = sizeof(boottime);
++ size_t size = sizeof(boottime);
+ gulong uptime;
+
+ if((sysctl(mib, 2, &boottime, &size, NULL, 0) != -1)