aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarius <marius@FreeBSD.org>2010-09-18 01:09:34 +0800
committermarius <marius@FreeBSD.org>2010-09-18 01:09:34 +0800
commit3bbbf22820d4429b75aa978ac741b0384bfe03f2 (patch)
treefa096f5098e39c53545f01503b3ab75425561b10 /sysutils
parentdbca29d801da05df15ec4f77d9631353fc957766 (diff)
downloadfreebsd-ports-gnome-3bbbf22820d4429b75aa978ac741b0384bfe03f2.tar.gz
freebsd-ports-gnome-3bbbf22820d4429b75aa978ac741b0384bfe03f2.tar.zst
freebsd-ports-gnome-3bbbf22820d4429b75aa978ac741b0384bfe03f2.zip
Add a hack allowing to building with TARGET and TARGET_ARCH set in the
environment as done by the release building scripts. The former causes some targets in the Makefiles of the port to be overridden and the later is added to the default COMPILE.c variable by gmake. Arguably the release building scripts should be fixed to not set TARGET and TARGET_ARCH when compiling the cdrtools port in case of a cross-release but for reasons beyond me this just worked with cdrtools 2.01 Approved by: netchild
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cdrtools-devel/Makefile5
-rw-r--r--sysutils/cdrtools/Makefile5
2 files changed, 10 insertions, 0 deletions
diff --git a/sysutils/cdrtools-devel/Makefile b/sysutils/cdrtools-devel/Makefile
index fce5406f8838..61ff3915f8fd 100644
--- a/sysutils/cdrtools-devel/Makefile
+++ b/sysutils/cdrtools-devel/Makefile
@@ -74,6 +74,11 @@ PLIST_SUB= RSCSI="@comment "
.endif
PKGNAMESUFFIX?= -devel
+# Hack to allow building with TARGET and TARGET_ARCH set in the environment
+# as done by the release building scripts.
+MAKE_ARGS= -R
+SETENV= /usr/bin/env -i -P ${PATH}
+
MAKE_ENV= CCOM=cc GMAKE_NOWARN=true INS_BASE=${LOCALBASE} \
INS_RBASE=${LOCALBASE}
CDRTLSTARGET= ${ARCH}-freebsd-cc
diff --git a/sysutils/cdrtools/Makefile b/sysutils/cdrtools/Makefile
index 49f605446979..1d8bc9690f72 100644
--- a/sysutils/cdrtools/Makefile
+++ b/sysutils/cdrtools/Makefile
@@ -69,6 +69,11 @@ PKGNAMESUFFIX= -rscsi
PLIST_SUB= RSCSI="@comment "
.endif
+# Hack to allow building with TARGET and TARGET_ARCH set in the environment
+# as done by the release building scripts.
+MAKE_ARGS= -R
+SETENV= /usr/bin/env -i -P ${PATH}
+
MAKE_ENV= CCOM=cc GMAKE_NOWARN=true INS_BASE=${LOCALBASE} \
INS_RBASE=${LOCALBASE}
CDRTLSTARGET= ${ARCH}-freebsd-cc