aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2005-04-03 19:54:33 +0800
committerlth <lth@FreeBSD.org>2005-04-03 19:54:33 +0800
commit3cbcca36fb1e891373118378f79293638994fa2e (patch)
tree784c521386dabd3f18ffc488de27ea3ab5ddf47f /sysutils
parent3803d7bdf42382153438c630afa1acb253a0b025 (diff)
downloadfreebsd-ports-gnome-3cbcca36fb1e891373118378f79293638994fa2e.tar.gz
freebsd-ports-gnome-3cbcca36fb1e891373118378f79293638994fa2e.tar.zst
freebsd-ports-gnome-3cbcca36fb1e891373118378f79293638994fa2e.zip
Add env4801 0.2, output the voltages and temperatures of a Soekris
Net4801 computer. PR: ports/74316 Submitted by: Patrick M. Hausen (pmh@hausen.com)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/env4801/Makefile37
-rw-r--r--sysutils/env4801/distinfo4
-rw-r--r--sysutils/env4801/files/env4801.sh10
-rw-r--r--sysutils/env4801/pkg-descr16
-rw-r--r--sysutils/env4801/pkg-message10
6 files changed, 78 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 8a1b776fba7c..2f8e34a7dd5a 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -121,6 +121,7 @@
SUBDIR += e2fsprogs
SUBDIR += eject
SUBDIR += enteruser
+ SUBDIR += env4801
SUBDIR += eroaster
SUBDIR += est
SUBDIR += estctrl
diff --git a/sysutils/env4801/Makefile b/sysutils/env4801/Makefile
new file mode 100644
index 000000000000..10752ade0179
--- /dev/null
+++ b/sysutils/env4801/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: env4801
+# Date created: Tue, Nov 24th, 2004
+# Whom: Patrick M. Hausen (pmh@hausen.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= env4801
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://phk.freebsd.dk/soekris/env4801/
+DISTFILES= Makefile env4801.c
+DIST_SUBDIR= env4801
+
+MAINTAINER= pmh@hausen.com
+COMMENT= Output the voltages and temperatures of a Soekris Net4801 computer
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+RC_SCRIPTS_SUB= PREFIX=${PREFIX}
+
+PLIST_FILES= sbin/env4801 etc/rc.d/env4801.sh
+
+post-extract:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/env4801.sh > ${WRKSRC}/env4801.sh
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/env4801 ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/env4801.sh ${PREFIX}/etc/rc.d
+
+post-install:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/env4801/distinfo b/sysutils/env4801/distinfo
new file mode 100644
index 000000000000..62972dfab99f
--- /dev/null
+++ b/sysutils/env4801/distinfo
@@ -0,0 +1,4 @@
+MD5 (env4801/Makefile) = 84e12097921baf6e9b3e9f938be6a29c
+SIZE (env4801/Makefile) = 379
+MD5 (env4801/env4801.c) = 4578ff38083aac95e71a127899294c88
+SIZE (env4801/env4801.c) = 1995
diff --git a/sysutils/env4801/files/env4801.sh b/sysutils/env4801/files/env4801.sh
new file mode 100644
index 000000000000..f49b07233f12
--- /dev/null
+++ b/sysutils/env4801/files/env4801.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+
+case "$1" in
+start|restart)
+ %%PREFIX%%/sbin/env4801 -i
+ ;;
+stop)
+ ;;
+esac
diff --git a/sysutils/env4801/pkg-descr b/sysutils/env4801/pkg-descr
new file mode 100644
index 000000000000..1004fc9d7637
--- /dev/null
+++ b/sysutils/env4801/pkg-descr
@@ -0,0 +1,16 @@
+Soekris Net4801 Environmental Monitor
+
+This is a small program to output the voltages and temperatures
+from the PC87366 chip in the Net4801 computer from Soekris.com.
+
+First run the program with a "-i" to initialize the hardware:
+
+ # env4801 -i
+
+Then, as often as you feel like, read out the measured values:
+
+ # env4801
+
+Author: Poul-Henning Kamp (phk@freebsd.org)
+WWW: http://phk.freebsd.dk/soekris/env4801/
+ http://www.soekris.com/
diff --git a/sysutils/env4801/pkg-message b/sysutils/env4801/pkg-message
new file mode 100644
index 000000000000..0df42d546ea4
--- /dev/null
+++ b/sysutils/env4801/pkg-message
@@ -0,0 +1,10 @@
+
+================================================================
+This port installed %%PREFIX%%/etc/rc.d/env4801.sh to initialize
+the hardware at boot time. The env4801 utility will only run on
+a Soekris Engineering Net4801 device. See pkg-descr for more
+information as currently there is no manpage.
+
+Make sure you have /dev/io enabled by putting io_load="YES" in
+/boot/loader.conf or device io in your kernel config file.
+================================================================