aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-06 22:11:12 +0800
committerpav <pav@FreeBSD.org>2005-07-06 22:11:12 +0800
commit3f60626d45ff9e3143a374ea22db0e94291e2be9 (patch)
treed8501d8beb4d8381a321af58feb6334c988798f7 /sysutils
parent73ccc2860e32238ea0106c63467d0cc144ba8f77 (diff)
downloadfreebsd-ports-gnome-3f60626d45ff9e3143a374ea22db0e94291e2be9.tar.gz
freebsd-ports-gnome-3f60626d45ff9e3143a374ea22db0e94291e2be9.tar.zst
freebsd-ports-gnome-3f60626d45ff9e3143a374ea22db0e94291e2be9.zip
Epylog is a syslog parser which runs periodically, looks at your logs,
processes some of the entries in order to present them in a more comprehensible format, and then mails you the output. It is written specifically for large network clusters where a lot of machines (around 50 and upwards) log to the same loghost using syslog or syslog-ng. It is an alternative to a similar package, called LogWatch. PR: ports/82948 Submitted by: Alan Snelson <Alan@Wave2.co.uk>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/epylog/Makefile27
-rw-r--r--sysutils/epylog/distinfo2
-rw-r--r--sysutils/epylog/pkg-descr20
-rw-r--r--sysutils/epylog/pkg-plist67
5 files changed, 117 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 13d4bc8af375..41661681b9ff 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -125,6 +125,7 @@
SUBDIR += eject
SUBDIR += enteruser
SUBDIR += env4801
+ SUBDIR += epylog
SUBDIR += eroaster
SUBDIR += est
SUBDIR += estctrl
diff --git a/sysutils/epylog/Makefile b/sysutils/epylog/Makefile
new file mode 100644
index 000000000000..6dae9a0b0718
--- /dev/null
+++ b/sysutils/epylog/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: epylog
+# Date created: 3 July 2005
+# Whom: Alan Snelson <alan@wave2.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= epylog
+PORTVERSION= 1.0.3
+CATEGORIES= sysutils
+MASTER_SITES= http://linux.duke.edu/projects/epylog/download/
+
+MAINTAINER= alan@wave2.co.uk
+COMMENT= Epylog is a syslog parser which mails you the output
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2
+
+MAN3= epylog.3
+MAN5= epylog-modules.5 epylog.conf.5
+MAN8= epylog.8
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-lynx --prefix=${PREFIX}
+USE_PERL5= yes
+USE_PYTHON= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/epylog/distinfo b/sysutils/epylog/distinfo
new file mode 100644
index 000000000000..35caf9ede0eb
--- /dev/null
+++ b/sysutils/epylog/distinfo
@@ -0,0 +1,2 @@
+MD5 (epylog-1.0.3.tar.gz) = 6beedd62e0d59d6309ae1f537fc75772
+SIZE (epylog-1.0.3.tar.gz) = 117774
diff --git a/sysutils/epylog/pkg-descr b/sysutils/epylog/pkg-descr
new file mode 100644
index 000000000000..9fd9297c47ef
--- /dev/null
+++ b/sysutils/epylog/pkg-descr
@@ -0,0 +1,20 @@
+Epylog is a syslog parser which runs periodically,
+looks at your logs, processes some of the entries
+in order to present them in a more comprehensible format,
+and then mails you the output.
+It is written specifically for large network clusters
+where a lot of machines (around 50 and upwards) log to the
+same loghost using syslog or syslog-ng.
+It is an alternative to a similar package, called LogWatch.
+
+The epylog engine should work on most unix systems running
+Python-2.2 and above, although currently the processing modules
+are only written to work with linux (and particularly Red Hat Linux
+series 7 and above).
+However, other unix and linux flavors should work fine,
+as long as they use standard logging facilities and things like PAM.
+
+WWW: http://linux.duke.edu/projects/epylog
+
+- Alan Snelson
+alan@wave2.co.uk
diff --git a/sysutils/epylog/pkg-plist b/sysutils/epylog/pkg-plist
new file mode 100644
index 000000000000..3a964db1363d
--- /dev/null
+++ b/sysutils/epylog/pkg-plist
@@ -0,0 +1,67 @@
+etc/cron.daily/epylog.cron
+etc/epylog/epylog.conf
+etc/epylog/modules.d/logins.conf
+etc/epylog/modules.d/mail.conf
+etc/epylog/modules.d/notices.conf
+etc/epylog/modules.d/packets.conf
+etc/epylog/modules.d/spamd.conf
+etc/epylog/modules.d/weeder.conf
+etc/epylog/notice_dist.xml
+etc/epylog/notice_local.xml
+etc/epylog/report_template.html
+etc/epylog/trojans.list
+etc/epylog/weed_dist.cf
+etc/epylog/weed_local.cf
+lib/perl5/site_perl/epylog.pm
+%%PYTHON_SITELIBDIR%%/epylog/__init__.py
+%%PYTHON_SITELIBDIR%%/epylog/__init__.pyc
+%%PYTHON_SITELIBDIR%%/epylog/helpers.py
+%%PYTHON_SITELIBDIR%%/epylog/helpers.pyc
+%%PYTHON_SITELIBDIR%%/epylog/log.py
+%%PYTHON_SITELIBDIR%%/epylog/log.pyc
+%%PYTHON_SITELIBDIR%%/epylog/module.py
+%%PYTHON_SITELIBDIR%%/epylog/module.pyc
+%%PYTHON_SITELIBDIR%%/epylog/mytempfile.py
+%%PYTHON_SITELIBDIR%%/epylog/mytempfile.pyc
+%%PYTHON_SITELIBDIR%%/epylog/publishers.py
+%%PYTHON_SITELIBDIR%%/epylog/publishers.pyc
+%%PYTHON_SITELIBDIR%%/epylog/report.py
+%%PYTHON_SITELIBDIR%%/epylog/report.pyc
+sbin/epylog
+share/doc/epylog-1.0.3/AUTHORS
+share/doc/epylog-1.0.3/ChangeLog
+share/doc/epylog-1.0.3/INSTALL
+share/doc/epylog-1.0.3/LICENSE
+share/doc/epylog-1.0.3/README
+share/doc/epylog-1.0.3/doc/modules.txt
+share/doc/epylog-1.0.3/doc/roadmap.txt
+share/doc/epylog-1.0.3/doc/templates/template.mod.pl
+share/doc/epylog-1.0.3/doc/templates/template_mod.py
+share/doc/epylog-1.0.3/doc/testcase/logins.testcase
+share/doc/epylog-1.0.3/doc/testcase/mail.testcase
+share/doc/epylog-1.0.3/doc/testcase/notices.testcase
+share/doc/epylog-1.0.3/doc/testcase/packets.testcase
+share/doc/epylog-1.0.3/doc/testcase/spamd.testcase
+share/doc/epylog-1.0.3/doc/testcase/weeder.testcase
+share/epylog/modules/logins_mod.py
+share/epylog/modules/logins_mod.pyc
+share/epylog/modules/mail_mod.py
+share/epylog/modules/mail_mod.pyc
+share/epylog/modules/notices_mod.py
+share/epylog/modules/notices_mod.pyc
+share/epylog/modules/packets_mod.py
+share/epylog/modules/packets_mod.pyc
+share/epylog/modules/spamd_mod.py
+share/epylog/modules/spamd_mod.pyc
+share/epylog/modules/weeder_mod.py
+share/epylog/modules/weeder_mod.pyc
+@dirrm share/epylog/modules
+@dirrm share/epylog
+@dirrm share/doc/epylog-1.0.3/doc/testcase
+@dirrm share/doc/epylog-1.0.3/doc/templates
+@dirrm share/doc/epylog-1.0.3/doc
+@dirrm share/doc/epylog-1.0.3
+@dirrm %%PYTHON_SITELIBDIR%%/epylog
+@dirrm etc/epylog/modules.d
+@dirrm etc/epylog
+@unexec rmdir %D/etc/cron.daily 2>/dev/null || true