aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2010-01-24 03:53:40 +0800
committermarcus <marcus@FreeBSD.org>2010-01-24 03:53:40 +0800
commit41d1e1e736294bddde794e6b5b1a5f0e5c0934ad (patch)
tree954d82d8860906a15d30612d94159304a2f7ee1f /sysutils
parente127a46b44a6f97df9ea75bd5afe443104f4744d (diff)
downloadfreebsd-ports-gnome-41d1e1e736294bddde794e6b5b1a5f0e5c0934ad.tar.gz
freebsd-ports-gnome-41d1e1e736294bddde794e6b5b1a5f0e5c0934ad.tar.zst
freebsd-ports-gnome-41d1e1e736294bddde794e6b5b1a5f0e5c0934ad.zip
Correct the properties for USB interface devices.
PR: 142988 Submitted by: thompsa
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_hf-usb2.c6
2 files changed, 4 insertions, 4 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index bf18e1e15daf..3618247ea90f 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.13
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c b/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
index 9f0f5726186c..995ca1708c97 100644
--- a/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
+++ b/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
@@ -1,5 +1,5 @@
---- hald/freebsd/hf-usb2.c.orig 2009-11-21 19:57:40.000000000 -0500
-+++ hald/freebsd/hf-usb2.c 2009-11-21 19:58:07.000000000 -0500
+--- hald/freebsd/hf-usb2.c.orig 2010-01-23 14:52:11.000000000 -0500
++++ hald/freebsd/hf-usb2.c 2010-01-23 14:52:33.000000000 -0500
@@ -0,0 +1,312 @@
+/***************************************************************************
+ * CVSID: $Id$
@@ -82,9 +82,9 @@
+
+ hal_device_property_set_string(device, "info.subsystem", "usb");
+ hal_device_property_set_int(device, "usb.interface.number", i);
-+ hal_device_property_foreach(parent, hf_usb2_copy_parent, device);
+ hal_device_copy_property(parent, "info.product", device, "info.product");
+ hal_device_copy_property(parent, "info.vendor", device, "info.vendor");
++ hal_device_merge_with_rewrite(device, parent, "usb.", "usb_device.");
+
+ if (hf_device_preprobe(device))
+ {