aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-05-29 19:55:40 +0800
committerbapt <bapt@FreeBSD.org>2015-05-29 19:55:40 +0800
commit42ee81da63970122947fa12a05f7b890ccff14fc (patch)
tree2afa660ce5b4f62284565510e1c15d0a7ac43a5f /sysutils
parent685b06a9fef9528632ac4e157005ad05264bed6c (diff)
downloadfreebsd-ports-gnome-42ee81da63970122947fa12a05f7b890ccff14fc.tar.gz
freebsd-ports-gnome-42ee81da63970122947fa12a05f7b890ccff14fc.tar.zst
freebsd-ports-gnome-42ee81da63970122947fa12a05f7b890ccff14fc.zip
The cryptographic hash function BLAKE2 is an improved version of the SHA-3
finalist BLAKE. Like SHA-3, BLAKE2 offers the highest security, yet is fast as MD5 on 64-bit platforms and requires at least 33% less RAM than SHA-2 or SHA-3 on low-end systems. The core algorithm of BLAKE2 is derived from ChaCha, a stream cipher designed by Daniel J. Bernstein that has been proposed as a standard cipher for TLS. WWW: https://blake2.net/
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/b2sum/Makefile24
-rw-r--r--sysutils/b2sum/distinfo2
-rw-r--r--sysutils/b2sum/pkg-descr8
4 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index f93e97b4e71c..7c018f3471cd 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -51,6 +51,7 @@
SUBDIR += autopsy
SUBDIR += avfs
SUBDIR += azure-agent
+ SUBDIR += b2sum
SUBDIR += b43-fwcutter
SUBDIR += backupchecker
SUBDIR += backuppc
diff --git a/sysutils/b2sum/Makefile b/sysutils/b2sum/Makefile
new file mode 100644
index 000000000000..09394df7f9a7
--- /dev/null
+++ b/sysutils/b2sum/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= b2sum
+PORTVERSION= 0.0.d${DISTVERSION}
+DISTVERSION= 20150529
+DISTNAME= blake2_code_${DISTVERSION}${EXTRACT_SUFFX}
+CATEGORIES= sysutils security
+MASTER_SITES= http://blake2.net/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= fast secure hashing
+
+USES= zip
+
+CFLAGS+= -I../sse
+WRKSRC_SUBDIR= b2sum
+MAKEFILE= makefile
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+PLIST_FILES= bin/b2sum
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/b2sum/distinfo b/sysutils/b2sum/distinfo
new file mode 100644
index 000000000000..9d622b1d19b4
--- /dev/null
+++ b/sysutils/b2sum/distinfo
@@ -0,0 +1,2 @@
+SHA256 (blake2_code_20150529.zip) = 30a3140f7747fb67765bcf5f26c85c5e9ec8a168bb31faa2dee93f4cc0b5e813
+SIZE (blake2_code_20150529.zip) = 890257
diff --git a/sysutils/b2sum/pkg-descr b/sysutils/b2sum/pkg-descr
new file mode 100644
index 000000000000..c9dc31b0993c
--- /dev/null
+++ b/sysutils/b2sum/pkg-descr
@@ -0,0 +1,8 @@
+The cryptographic hash function BLAKE2 is an improved version of the SHA-3
+finalist BLAKE. Like SHA-3, BLAKE2 offers the highest security, yet is fast as
+MD5 on 64-bit platforms and requires at least 33% less RAM than SHA-2 or SHA-3
+on low-end systems. The core algorithm of BLAKE2 is derived from ChaCha, a
+stream cipher designed by Daniel J. Bernstein that has been proposed as a
+standard cipher for TLS.
+
+WWW: https://blake2.net/