aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-07-10 23:22:01 +0800
committerPawel Pekala <pawel@FreeBSD.org>2016-07-10 23:22:01 +0800
commit42fdd7bb5d2cecbcb2e59e1d1b5e0f1d748738b1 (patch)
treefdda70298c9550a3ed4c24620363a477b03919f0 /sysutils
parent0cd58730f20c2bf40045bb43e7afa84ae43f1a4d (diff)
downloadfreebsd-ports-gnome-42fdd7bb5d2cecbcb2e59e1d1b5e0f1d748738b1.tar.gz
freebsd-ports-gnome-42fdd7bb5d2cecbcb2e59e1d1b5e0f1d748738b1.tar.zst
freebsd-ports-gnome-42fdd7bb5d2cecbcb2e59e1d1b5e0f1d748738b1.zip
U-Boot loader for Banana Pi M2.
To install this bootloader, follow the instructions in http://linux-sunxi.org/Bootable_SD_card#Bootloader This version is patched so that: * ELF and API features are enabled. * The default environment is trimmed to just what's needed to boot. * The saveenv command writes to the file u-boot.env on the FAT partition. * The DTB file name is chosen based on the board model and passed to ubldr using the fdtfile env variable. ubldr loads the DTB from /boot/dtb/ on the FreeBSD partition. * By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition to address 0x42000000, and launches it. For information about running FreeBSD on Banana Pi, see https://wiki.freebsd.org/FreeBSD/arm/Allwinner For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot PR: 210628 Submitted by: manu
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/u-boot-bananapim2/Makefile14
-rw-r--r--sysutils/u-boot-bananapim2/pkg-descr19
3 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 1ace334f8cfd..1676d87d1d72 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1087,6 +1087,7 @@
SUBDIR += tw_cli
SUBDIR += tzdialog
SUBDIR += u-boot-bananapi
+ SUBDIR += u-boot-bananapim2
SUBDIR += u-boot-beaglebone
SUBDIR += u-boot-cubieboard
SUBDIR += u-boot-cubieboard2
diff --git a/sysutils/u-boot-bananapim2/Makefile b/sysutils/u-boot-bananapim2/Makefile
new file mode 100644
index 000000000000..e6506781d5d9
--- /dev/null
+++ b/sysutils/u-boot-bananapim2/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -${MODEL}
+
+COMMENT= Cross-build U-Boot loader for bananapi M2
+
+LICENSE= GPLv2
+
+MASTERDIR= ${.CURDIR}/../u-boot-olimex-a20-som-evb
+DESCR= ${.CURDIR}/pkg-descr
+MODEL= bananapim2
+BOARD_CONFIG= Sinovoip_BPI_M2_defconfig
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-bananapim2/pkg-descr b/sysutils/u-boot-bananapim2/pkg-descr
new file mode 100644
index 000000000000..e3f7d73edb49
--- /dev/null
+++ b/sysutils/u-boot-bananapim2/pkg-descr
@@ -0,0 +1,19 @@
+U-Boot loader for Banana Pi M2.
+
+To install this bootloader, follow the instructions in
+ http://linux-sunxi.org/Bootable_SD_card#Bootloader
+
+This version is patched so that:
+ * ELF and API features are enabled.
+ * The default environment is trimmed to just what's needed to boot.
+ * The saveenv command writes to the file u-boot.env on the FAT partition.
+ * The DTB file name is chosen based on the board model and passed to ubldr
+ using the fdtfile env variable. ubldr loads the DTB from /boot/dtb/ on
+ the FreeBSD partition.
+ * By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition
+ to address 0x42000000, and launches it.
+
+For information about running FreeBSD on Banana Pi, see
+ https://wiki.freebsd.org/FreeBSD/arm/Allwinner
+
+For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot