aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-01-25 22:38:47 +0800
committermarino <marino@FreeBSD.org>2014-01-25 22:38:47 +0800
commit4747a5e3a06ae7c3bbed3deadb0cbb80826e6341 (patch)
tree27462c9202813b62294b285e4e16683a147f6ecb /sysutils
parent20a34bd0442a24bcd878ae2b59266b74a0103a53 (diff)
downloadfreebsd-ports-gnome-4747a5e3a06ae7c3bbed3deadb0cbb80826e6341.tar.gz
freebsd-ports-gnome-4747a5e3a06ae7c3bbed3deadb0cbb80826e6341.tar.zst
freebsd-ports-gnome-4747a5e3a06ae7c3bbed3deadb0cbb80826e6341.zip
sysutils/fonteditfs: Fix on FreeBSD 10+, support stage
PR: ports/185405 Submitted by; Stephen Hurd Approved by: maintainer (Uri Shaked) Staged by: marino@
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fonteditfs/Makefile8
-rw-r--r--sysutils/fonteditfs/files/patch-Makefile11
2 files changed, 10 insertions, 9 deletions
diff --git a/sysutils/fonteditfs/Makefile b/sysutils/fonteditfs/Makefile
index ab162cb3553c..abf289b111ba 100644
--- a/sysutils/fonteditfs/Makefile
+++ b/sysutils/fonteditfs/Makefile
@@ -6,17 +6,15 @@ PORTVERSION= 1.2
CATEGORIES= sysutils
MASTER_SITES= SF
DISTNAME= fnteditfs-${PORTVERSION}
-EXTRACT_SUFX=.tgz
+EXTRACT_SUFX= .tgz
MAINTAINER= uri@keves.org
COMMENT= Full screen syscons font editor
-MAN1= fnteditfs.1
-PLIST_FILES= bin/fnteditfs
+PLIST_FILES= bin/fnteditfs man/man1/fnteditfs.1.gz
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|__PREFIX__|${PREFIX}|g ; \
+ @${REINPLACE_CMD} -e 's|__PREFIX__|${STAGEDIR}${PREFIX}|g ; \
s|__INSTALL_MAN__|${INSTALL_MAN}|g ; \
s|__INSTALL_SCRIPT__|${INSTALL_SCRIPT}|g' ${WRKSRC}/Makefile
diff --git a/sysutils/fonteditfs/files/patch-Makefile b/sysutils/fonteditfs/files/patch-Makefile
index dca3d68edc7e..1ae7943ad670 100644
--- a/sysutils/fonteditfs/files/patch-Makefile
+++ b/sysutils/fonteditfs/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2003-09-20 12:17:34.000000000 -0300
-+++ Makefile 2009-08-29 14:56:21.000000000 -0300
-@@ -2,12 +2,7 @@
+--- Makefile.orig 2003-09-20 08:17:34.000000000 -0700
++++ Makefile 2014-01-01 12:27:59.000000000 -0800
+@@ -2,14 +2,9 @@
# - TODO: MAKE NEATER ONE
# This makefile should work under most POSIX OSes (at least FreeBSD)
@@ -12,8 +12,11 @@
-
+all: fnteditfs
fnteditfs: fnteditfs.o font.o stack.o
- gcc -o fnteditfs fnteditfs.o font.o stack.o -lcurses
+- gcc -o fnteditfs fnteditfs.o font.o stack.o -lcurses
++ ${CC} -o fnteditfs fnteditfs.o font.o stack.o -lcurses
strip fnteditfs
+
+ fnteditfs.o: fnteditfs.c font.h stack.h
@@ -17,8 +12,8 @@
stack.o: stack.c stack.h